0.6.5.1 Tests - problems with OGS1 USER SERVICES?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

0.6.5.1 Tests - problems with OGS1 USER SERVICES?

Ai Austin
I decided to take a look at the 0.6.5.1 and take the plunge of doing
the build myself (I had used the nightly binaries occasionally up to
mid March).  Set up is:

Opensim 0.6.5.1 28-May-2009 from dist.opensimulator.org
Built with runprebuild.bat and compile.bat
On Windows Vista SP1

I am having problems with errors reported by [OGS1 USER SERVICES] and
I just want to check its nothing silly or well knows already before I
delve deeper.

I have a tried a range of ways to bring this up (all in grid mode
with UGAIM and regions/opensim.exe on same system) even just using a
single region, or starting with a single region and empty data base.

I note an unusual message in the User server and inventory server
console windows

User Server

log4net:ERROR XmlHierarchyConfigurator: No appender named
[NHibernateFileLog] could be found.
log4net:ERROR XmlHierarchyConfigurator: Appender named
[NHibernateFileLog] not found.
09:55:42 - Launching UserServer...
09:55:42 - [STARTUP]: Beginning startup processing
09:55:42 - [STARTUP]: Version: OpenSimulator Server  0.6.5
USER SERVER: User Server (this) External URI for authentication keys
[http://localhost:8002/]:

Inventory Server

log4net:ERROR XmlHierarchyConfigurator: No appender named
[NHibernateFileLog] could be found.
log4net:ERROR XmlHierarchyConfigurator: Appender named
[NHibernateFileLog] not found.
09:55:52 - [STARTUP]: Beginning startup processing
09:55:52 - [STARTUP]: Version: OpenSimulator Server  0.6.5
INVENTORY: Default Inventory Server URI (this server's external name)
[http://127.0.0.1:8004]:


Niote the server's externakl bname as 127.0.0.1 and localhost...
whereas I have http://virtual.aiai.ed.ac.uk:8002 and external IP/DNS
of virtual.aiai.ed.ac.uk etc which is actually
http://129.215.219.138:8002 etc set in my UGAIM XML config files.


----

These are the sort of messages I am seeing in Opensim.exe console
window just before it crashes every time... any pointers anyone?

On a run with a single region:

09:47:12 - [OGS1 USER SERVICES]: Error when trying to fetch profile
data by name from remote user server: System.Net.WebException: Unable
to connect to the remote server --->
System.Net.Sockets.SocketException: No connection could be made
because the target machine actively refused it 129.215.219.138:8002


or on a run with more regions:

2009-06-02 09:05:09,306 ERROR -
OpenSim.Region.Communications.OGS1.OGS1UserDataPlugin [OGS1 USER
SERVICES]: Error when trying to fetch profile data by name from
remote user server: System.Net.WebException: Unable to connect to the
remote server ---> System.Net.Sockets.SocketException: No connection
could be made because the target machine actively refused it
129.215.219.138:8002
    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot,
SocketAddress socketAddress)
    at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
    at System.Net.ServicePoint.ConnectSocketInternal(Boolean
connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress&
address, ConnectSocketState state, IAsyncResult asyncResult, Int32
timeout, Exception& exception)
    --- End of inner exception stack trace ---
    at System.Net.HttpWebRequest.GetRequestStream()
    at Nwc.XmlRpc.XmlRpcRequest.Send(String url, Int32 timeout)
    at
OpenSim.Region.Communications.OGS1.OGS1UserDataPlugin.GetUserProfile(String
name) in
d:\VW\Opensim\OpenSim\Region\Communications\OGS1\OGS1UserDataPlugin.cs:line 193

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: 0.6.5.1 Tests - problems with OGS1 USER SERVICES?

Jonathan Greenlee

At least part of your problem is in your OpenSim.ini
look to your [messaging] section.
I dont guess what you want to use - but you could just comment it out first and see if that improves your results.

--- On Tue, 6/2/09, Ai Austin <[hidden email]> wrote:

> From: Ai Austin <[hidden email]>
> Subject: [Opensim-users] 0.6.5.1 Tests - problems with OGS1 USER SERVICES?
> To: [hidden email]
> Date: Tuesday, June 2, 2009, 6:05 AM
> I decided to take a look at the
> 0.6.5.1 and take the plunge of doing
> the build myself (I had used the nightly binaries
> occasionally up to
> mid March).  Set up is:
>
> Opensim 0.6.5.1 28-May-2009 from dist.opensimulator.org
> Built with runprebuild.bat and compile.bat
> On Windows Vista SP1
>
> I am having problems with errors reported by [OGS1 USER
> SERVICES] and
> I just want to check its nothing silly or well knows
> already before I
> delve deeper.
>
> I have a tried a range of ways to bring this up (all in
> grid mode
> with UGAIM and regions/opensim.exe on same system) even
> just using a
> single region, or starting with a single region and empty
> data base.
>
> I note an unusual message in the User server and inventory
> server
> console windows
>
> User Server
>
> log4net:ERROR XmlHierarchyConfigurator: No appender named
> [NHibernateFileLog] could be found.
> log4net:ERROR XmlHierarchyConfigurator: Appender named
> [NHibernateFileLog] not found.
> 09:55:42 - Launching UserServer...
> 09:55:42 - [STARTUP]: Beginning startup processing
> 09:55:42 - [STARTUP]: Version: OpenSimulator Server 
> 0.6.5
> USER SERVER: User Server (this) External URI for
> authentication keys
> [http://localhost:8002/]:
>
> Inventory Server
>
> log4net:ERROR XmlHierarchyConfigurator: No appender named
> [NHibernateFileLog] could be found.
> log4net:ERROR XmlHierarchyConfigurator: Appender named
> [NHibernateFileLog] not found.
> 09:55:52 - [STARTUP]: Beginning startup processing
> 09:55:52 - [STARTUP]: Version: OpenSimulator Server 
> 0.6.5
> INVENTORY: Default Inventory Server URI (this server's
> external name)
> [http://127.0.0.1:8004]:
>
>
> Niote the server's externakl bname as 127.0.0.1 and
> localhost...
> whereas I have http://virtual.aiai.ed.ac.uk:8002 and
> external IP/DNS
> of virtual.aiai.ed.ac.uk etc which is actually
> http://129.215.219.138:8002 etc set in my UGAIM XML
> config files.
>
>
> ----
>
> These are the sort of messages I am seeing in Opensim.exe
> console
> window just before it crashes every time... any pointers
> anyone?
>
> On a run with a single region:
>
> 09:47:12 - [OGS1 USER SERVICES]: Error when trying to fetch
> profile
> data by name from remote user server:
> System.Net.WebException: Unable
> to connect to the remote server --->
> System.Net.Sockets.SocketException: No connection could be
> made
> because the target machine actively refused it
> 129.215.219.138:8002
>
>
> or on a run with more regions:
>
> 2009-06-02 09:05:09,306 ERROR -
> OpenSim.Region.Communications.OGS1.OGS1UserDataPlugin [OGS1
> USER
> SERVICES]: Error when trying to fetch profile data by name
> from
> remote user server: System.Net.WebException: Unable to
> connect to the
> remote server ---> System.Net.Sockets.SocketException:
> No connection
> could be made because the target machine actively refused
> it
> 129.215.219.138:8002
>     at
> System.Net.Sockets.Socket.DoConnect(EndPoint
> endPointSnapshot,
> SocketAddress socketAddress)
>     at
> System.Net.Sockets.Socket.InternalConnect(EndPoint
> remoteEP)
>     at
> System.Net.ServicePoint.ConnectSocketInternal(Boolean
> connectFailure, Socket s4, Socket s6, Socket& socket,
> IPAddress&
> address, ConnectSocketState state, IAsyncResult
> asyncResult, Int32
> timeout, Exception& exception)
>     --- End of inner exception stack trace ---
>     at
> System.Net.HttpWebRequest.GetRequestStream()
>     at Nwc.XmlRpc.XmlRpcRequest.Send(String url,
> Int32 timeout)
>     at
> OpenSim.Region.Communications.OGS1.OGS1UserDataPlugin.GetUserProfile(String
>
> name) in
> d:\VW\Opensim\OpenSim\Region\Communications\OGS1\OGS1UserDataPlugin.cs:line
> 193
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


     
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users