8334 starting standalone errors.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

8334 starting standalone errors.

Tom Willans
I have been having a lot of difficulty running OpenSim, the last reliable version I have been running has been version 7935. With the latest version (8334), I copy the example OpenSim.ini and build.
I am on an Intel Mac Book Pro using mono version 2.2. I am running Opensim in runtime mode. I get the following last section of the runtime error message:

Method (wrapper managed-to-native) System.Reflection.MonoMethod:get_name (System.Reflection.MethodBase) emitted at 0x39748d8 to 0x3974927 (code length 79) [Opensim.exe]
Method log4net.Core.LogImpl:ErrorFormat (string,object) emitted at 0x3974958 to 0x3974a18 (code length 192) [Opensim.exe]
Method log4net.Core.LogImpl:get_IsErrorEnabled () emitted at 0x3974a18 to 0x3974a49 (code length 49) [Opensim.exe]
08:57:50 - [APPLICATION]: 
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[System.Object].get_Item (Int32 index) [0x00000] 
  at OpenSim.Region.Framework.Scenes.SceneManager.get_CurrentOrFirstScene () [0x00000] 
  at OpenSim.OpenSimBase.GetHelpTopics () [0x00000] 
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] 
  at OpenSim.OpenSim.StartupSpecific () [0x00000] 
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] 
  at OpenSim.Application.Main (System.String[] args) [0x00000] 

Application is terminating: True

I have yet added this to mantis, assuming it is a real bug.

Any advice would be welcomed.
Thanks




_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: 8334 starting standalone errors.

justincc
Tom Willans wrote:

> I have been having a lot of difficulty running OpenSim, the last
> reliable version I have been running has been version 7935. With the
> latest version (8334), I copy the example OpenSim.ini and build.
> I am on an Intel Mac Book Pro using mono version 2.2. I am running
> Opensim in runtime mode. I get the following last section of the runtime
> error message:
>
> Method (wrapper managed-to-native) System.Reflection.MonoMethod:get_name
> (System.Reflection.MethodBase) emitted at 0x39748d8 to 0x3974927 (code
> length 79) [Opensim.exe]
> Method log4net.Core.LogImpl:ErrorFormat (string,object) emitted at
> 0x3974958 to 0x3974a18 (code length 192) [Opensim.exe]
> Method log4net.Core.LogImpl:get_IsErrorEnabled () emitted at 0x3974a18
> to 0x3974a49 (code length 49) [Opensim.exe]
> 08:57:50 - [APPLICATION]:
> APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs
>
> Exception: System.ArgumentOutOfRangeException: Argument is out of range.
> Parameter name: index
>   at System.Collections.Generic.List`1[System.Object].get_Item (Int32
> index) [0x00000]
>   at
> OpenSim.Region.Framework.Scenes.SceneManager.get_CurrentOrFirstScene ()
> [0x00000]
>   at OpenSim.OpenSimBase.GetHelpTopics () [0x00000]
>   at OpenSim.OpenSimBase.StartupSpecific () [0x00000]
>   at OpenSim.OpenSim.StartupSpecific () [0x00000]
>   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000]
>   at OpenSim.Application.Main (System.String[] args) [0x00000]
>
> Application is terminating: True
>
> I have yet added this to mantis, assuming it is a real bug.
>

The stack trace suggests your regions somehow are not being loaded.  You might want to look at the log file to see if
these are being properly found.

If this doesn't help, then I suggest that you do file a mantis with both these details and your full startup log

--
justincc
Justin Clark-Casey
http://justincc.wordpress.com
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: 8334 starting standalone errors.

Tom Willans
Hi Justin,

Thanks for your help
There was nothing obvious to me within the log files, but that may be my lack of knowledge about this software.
I have filed a Mantis report. At least it is repeatable on my system.

Tom

On 11 Feb 2009, at 15:07, Justin Clark-Casey wrote:

Tom Willans wrote:
I have been having a lot of difficulty running OpenSim, the last 
reliable version I have been running has been version 7935. With the 
latest version (8334), I copy the example OpenSim.ini and build.
I am on an Intel Mac Book Pro using mono version 2.2. I am running 
Opensim in runtime mode. I get the following last section of the runtime 
error message:

Method (wrapper managed-to-native) System.Reflection.MonoMethod:get_name 
(System.Reflection.MethodBase) emitted at 0x39748d8 to 0x3974927 (code 
length 79) [Opensim.exe]
Method log4net.Core.LogImpl:ErrorFormat (string,object) emitted at 
0x3974958 to 0x3974a18 (code length 192) [Opensim.exe]
Method log4net.Core.LogImpl:get_IsErrorEnabled () emitted at 0x3974a18 
to 0x3974a49 (code length 49) [Opensim.exe]
08:57:50 - [APPLICATION]: 
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[System.Object].get_Item (Int32 
index) [0x00000] 
  at 
OpenSim.Region.Framework.Scenes.SceneManager.get_CurrentOrFirstScene () 
[0x00000] 
  at OpenSim.OpenSimBase.GetHelpTopics () [0x00000] 
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] 
  at OpenSim.OpenSim.StartupSpecific () [0x00000] 
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] 
  at OpenSim.Application.Main (System.String[] args) [0x00000] 

Application is terminating: True

I have yet added this to mantis, assuming it is a real bug.


The stack trace suggests your regions somehow are not being loaded.  You might want to look at the log file to see if 
these are being properly found.

If this doesn't help, then I suggest that you do file a mantis with both these details and your full startup log

-- 
justincc
Justin Clark-Casey
_______________________________________________
Opensim-users mailing list

Tom Willans
Managing Director
Bessacarr Publications Ltd
3 Highfield, Hatton Park, Warwick, CV35 7TQ
+44 (0) 1926 402055   +44 (0) 121 288 0281
Registered in England and Wales at the above address.  Company No: 4925067. VAT No:GB 823 9317 24.

This e-mail is confidential and intended solely for the use of the individual to whom it is addressed. Any views or opinions presented are solely those of the author and do not necessarily represent those of Bessacarr Publications Ltd. If you are not the intended recipient you have received this e-mail in error and that any use, dissemination, forwarding, printing or copying of this e-mail is strictly prohibited. Please return it to the sender immediately. The contents of this message may be legally privileged.






_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users