Adding extra regions to Diva Distro [diva-r25084]

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Adding extra regions to Diva Distro [diva-r25084]

Rob.J
This post has NOT been accepted by the mailing list yet.
Adding extra regions to Diva Distro [diva-r25084] (OpenSim 0.8.0 post-fixes)

Hello, I do hope somebody can help me with this.

I have in the past successfully added extra regions to both standard OpenSim, and Diva Distro. With Diva I added the line “CombineContiguousRegions = false” to the MyWorld.ini file, and it worked like a dream.


I am a huge fan of the Diva Distro and would like to carry on using it.

First off, I noticed that the line ‘CombineContiguousRegions = false’ is already in the MyWorld.ini file of the latest Diva version.

However, as soon as I try and add a second region, I get the following red text arriving…

APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.FormatException: Input string was not in the correct format
  at System.UInt32.Parse (System.String s) [0x00000] in <filename unknown>:0
  at System.Convert.ToUInt32 (System.String value) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.RegionInfo.ReadNiniConfig (IConfigSource source, System.String name) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.RegionInfo..ctor (System.String description, System.String filename, Boolean skipConsoleConfig, IConfigSource configSource, System.String configName) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.RegionLoader.Filesystem.RegionLoaderFileSystem.LoadRegions () [0x00000] in <filename unknown>:0
  at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise () [0x00000] in <filename unknown>:0
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in <filename unknown>:0
  at OpenSim.Application.Main (System.String[] args) [0x00000] in <filename unknown>:0

Application is terminating: True

And at this point, the start-up stops dead.

If I remove the new region, everything runs perfectly.

Any help is appreciated!

kind regards,

Rob
Reply | Threaded
Open this post in threaded view
|

Re: Adding extra regions to Diva Distro [diva-r25084]

Rob.J
This post has NOT been accepted by the mailing list yet.
***Resolved***

This is an issue with the text editor in the latest OS X for macs; Yosemite.

The usual way to add regions is to load the RegionConfig.ini into the simple text editor, cut and paste the existing region and make the necessary adjustments in order to create a new region.

For some curious reason the text editor in Yosemite is italicising the quote marks after a cut and paste. It is very hard to spot if you don't have your eyes peeled, but it is enough to throw up the error.