Can Not Connect To Remote Server

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Can Not Connect To Remote Server

outerlimits
This post has NOT been accepted by the mailing list yet.
Hello all,

I just rebuilt my OpenSim setup and have several Esxi hosts ready to setup a new OpenSim in Grid Mode.

All systems looked good when ROBUST booted up with now errors as well as my first simulator.  Looking at the log my avatar is verified and ok but then I get right up to the end and LLogin service fails telling me I am unable to connect to the remote server.

I have setup a NAT Loopback on my pfsense firewall and port forwarded the sim ports as well as the Robust server ports.  I also played around with changing the region forwarded port from the ROBUST server to the OpenSim instance and back to see if that might be it.

Looking at my firewall logs there doesn't seem to be any blocks happening and I am able to ping different servers from each direction as well as get the proper dns listings.

The sim doesn't seem to generate any messages related to the login and all seems fine until the last part of the handshake in the Robust log I am listing now:

2014-12-06 16:50:28,917 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: User Dan Baxter is ok
2014-12-06 16:50:28,917 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: Destination Welcome Center is ok for Dan Baxter
2014-12-06 16:50:28,933 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: Launching Dan Baxter, Teleport Flags: ViaLogin, Godlike
2014-12-06 16:50:29,972 DEBUG - OpenSim.Framework.WebUtil [LOGHTTP]: JSON-RPC request 29 QUERYACCESS to http://outerlimits.kimbletechnologies.com:49651/agent/obfuscatedUUID/ FAILED: Unable to connect to the remote server
2014-12-06 16:50:29,972 DEBUG - OpenSim.Services.HypergridService.UserAgentService [USER AGENT SERVICE]: Unable to login user Dan Baxter to grid http://outerlimits.kimbletechnologies.com:8002/, reason: Service request failed: Unable to connect to the remote server
2014-12-06 16:50:30,031 DEBUG - OpenSim.Services.PresenceService.PresenceService [PRESENCE SERVICE]: LogoutAgent: session obfuscatedUUID, user obfuscatedUUID, region 00000000-0000-0000-0000-000000000000
2014-12-06 16:50:30,061 INFO  - OpenSim.Services.LLLoginService.LLLoginService [LLOGIN SERVICE]: Login failed for Dan Baxter, reason: Service request failed: Unable to connect to the remote server
2014-12-06 16:50:31,432 DEBUG - Diva.Wifi.Services [Wifi]: DefaultRequest
2014-12-06 16:50:31,464 DEBUG - Diva.Wifi.Services [Wifi]: DefaultRequest

Any help or suggestions where to look for problems would be greatly appreciated
I am running my ROBUST server on a server 2012R2 server and my OpenSim Simulator instance is running on an Ubuntu 14.4 LTS.  I have MySQL running on the Server 2012R2 computer and the OpenSim instance is pointing to the MySQL server running on the same computer as the Robust server
Reply | Threaded
Open this post in threaded view
|

RE: Can Not Connect To Remote Server

Randy Pierce
This post has NOT been accepted by the mailing list yet.

Based on recent personal experience and 5 months of looking I found this recent piece of information that was extremely valuable. It allowed me to finally connect multiple servers into the linux Robust and SQL server I had been working on … check this and see that you’re my.cnf is correct in (usually) /etc/mysql/ folder :

 

Replace mysqld Defaults

 

You can either set this up as a new connection or override the default, in this case, I replaced the default connection with my

own remote connection settings:

 

[mysqld]

bind‐address = 255.112.324.12

port = 3306

user = mysql

pid‐file = /var/run/mysqld/mysqld.pid

socket = /var/run/mysqld/mysqld.sock

basedir = /usr

datadir = /var/lib/mysql

tmpdir = /tmp

language = /usr/share/mysql/English

# skip‐networking

# skip‐external‐locking

 

(the last 2 lines getting commented out and your SQL server internal IP address getting placed in the bind-address line took care of my problems.

 

After your done editing, just save and close the file and restart mysql services:

# Ubuntu

service mysql restart

 

 

I would be curious to know whether this works for you, please let me know …

 

 

From: outerlimits [via opensim-users] [mailto:[hidden email]]
Sent: Saturday, December 06, 2014 5:20 PM
To: Randy Pierce
Subject: Can Not Connect To Remote Server

 

Hello all,

I just rebuilt my OpenSim setup and have several Esxi hosts ready to setup a new OpenSim in Grid Mode.

All systems looked good when ROBUST booted up with now errors as well as my first simulator.  Looking at the log my avatar is verified and ok but then I get right up to the end and LLogin service fails telling me I am unable to connect to the remote server.

I have setup a NAT Loopback on my pfsense firewall and port forwarded the sim ports as well as the Robust server ports.  I also played around with changing the region forwarded port from the ROBUST server to the OpenSim instance and back to see if that might be it.

Looking at my firewall logs there doesn't seem to be any blocks happening and I am able to ping different servers from each direction as well as get the proper dns listings.

The sim doesn't seem to generate any messages related to the login and all seems fine until the last part of the handshake in the Robust log I am listing now:

2014-12-06 16:50:28,917 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: User Dan Baxter is ok
2014-12-06 16:50:28,917 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: Destination Welcome Center is ok for Dan Baxter
2014-12-06 16:50:28,933 DEBUG - OpenSim.Services.HypergridService.GatekeeperService [GATEKEEPER SERVICE]: Launching Dan Baxter, Teleport Flags: ViaLogin, Godlike
2014-12-06 16:50:29,972 DEBUG - OpenSim.Framework.WebUtil [LOGHTTP]: JSON-RPC request 29 QUERYACCESS to http://outerlimits.kimbletechnologies.com:49651/agent/obfuscatedUUID/ FAILED: Unable to connect to the remote server
2014-12-06 16:50:29,972 DEBUG - OpenSim.Services.HypergridService.UserAgentService [USER AGENT SERVICE]: Unable to login user Dan Baxter to grid http://outerlimits.kimbletechnologies.com:8002/, reason: Service request failed: Unable to connect to the remote server
2014-12-06 16:50:30,031 DEBUG - OpenSim.Services.PresenceService.PresenceService [PRESENCE SERVICE]: LogoutAgent: session obfuscatedUUID, user obfuscatedUUID, region 00000000-0000-0000-0000-000000000000
2014-12-06 16:50:30,061 INFO  - OpenSim.Services.LLLoginService.LLLoginService [LLOGIN SERVICE]: Login failed for Dan Baxter, reason: Service request failed: Unable to connect to the remote server
2014-12-06 16:50:31,432 DEBUG - Diva.Wifi.Services [Wifi]: DefaultRequest
2014-12-06 16:50:31,464 DEBUG - Diva.Wifi.Services [Wifi]: DefaultRequest

Any help or suggestions where to look for problems would be greatly appreciated
I am running my ROBUST server on a server 2012R2 server and my OpenSim Simulator instance is running on an Ubuntu 14.4 LTS.  I have MySQL running on the Server 2012R2 computer and the OpenSim instance is pointing to the MySQL server running on the same computer as the Robust server


If you reply to this email, your message will be added to the discussion below:

http://opensim-users.2152040.n2.nabble.com/Can-Not-Connect-To-Remote-Server-tp7582008.html

To start a new topic under opensim-users, email [hidden email]
To unsubscribe from opensim-users, click here.
NAML

Changing the world - one prim at a time! The Insight Concepts Grid http://gcse.dyndns.org:8002