Cannot bring up 8553 with osgrid

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot bring up 8553 with osgrid

Frank W Sweet
2009-02-21 13:54:17,945 INFO  -
OpenSim.Region.Communications.OGS1.OGS1GridServices [OGS1 GRID
SERVICES]: Attempting to register region tsor2 with grid at
http://osgrid.org:8001

2009-02-21 13:54:18,326 ERROR - OpenSim.OpenSimBase [STARTUP]:
Registration of region with grid failed, aborting startup -
System.Exception: Unable to connect to grid at <a href="http://osgrid.org:8001:">http://osgrid.org:8001:
Your region service implements OGS1 interface version 3 but this grid
requires that the region implement OGS1 interface version 2 to
connect.  Try changing to OpenSimulator OpenSimulator Server
0.6.2.8449
   at
OpenSim.Region.Communications.OGS1.OGS1GridServices.RegisterRegion(RegionInfo
regionInfo) in c:\Documents and
Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Communications\OGS1\OGS1GridServices.cs:line
171
   at
OpenSim.Region.Communications.Hypergrid.HGGridServicesGridMode.RegisterRegion(RegionInfo
regionInfo) in c:\Documents and
Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Communications\Hypergrid\HGGridServicesGridMode.cs:line
84
   at
OpenSim.Region.Framework.Scenes.SceneCommunicationService.RegisterRegion(IInterregionCommsOut
comms_out, RegionInfo regionInfos) in c:\Documents and
Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Framework\Scenes\SceneCommunicationService.cs:line
102
   at OpenSim.Region.Framework.Scenes.Scene.RegisterRegionWithGrid()
in c:\Documents and
Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Framework\Scenes\Scene.cs:line
1117
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
portadd_flag, Boolean do_post_init) in c:\Documents and
Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Application\OpenSimBase.cs:line
597

Frank W Sweet

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot bring up 8553 with osgrid

Stefan Andersson
Yes, sorry for not e-mailing the list with this; it kind of slipped my mind.
 
I upped the Interface Version today, as we were seeing considerable deterioration of quality of service between new and old regions. In fact, latest regions was reported not to connect or tp at all with 0.6.2 grid services.
 
Since interface version 2, we have done considerable changes in how regions communicate with each others and the grid.
 
Last revision running on version 2 was 8543, so stay on that or earlier until your UGAIM has been updated.
 
To use later revisions than that, the UGAIM, ie, the grid services, has to be updated past that.
 
I have also applied the update to 0.6.3-post-fixes, so 0.6.3 regions cannot connect to pre-0.6.3 grids.
 
I should also take the opportunity to invite you all on a discussion on how we should handle interface version increases. Of course, they should probably be made around version changes, so one indicates another. Sorry to say, that has not happened here, so some confusion should be expected.

Best regards,
Stefan Andersson
Tribal Media AB



 

> From: [hidden email]
> To: [hidden email]
> Date: Sat, 21 Feb 2009 14:02:09 -0500
> Subject: [Opensim-users] Cannot bring up 8553 with osgrid
>
> 2009-02-21 13:54:17,945 INFO -
> OpenSim.Region.Communications.OGS1.OGS1GridServices [OGS1 GRID
> SERVICES]: Attempting to register region tsor2 with grid at
> http://osgrid.org:8001
>
> 2009-02-21 13:54:18,326 ERROR - OpenSim.OpenSimBase [STARTUP]:
> Registration of region with grid failed, aborting startup -
> System.Exception: Unable to connect to grid at http://osgrid.org:8001:
> Your region service implements OGS1 interface version 3 but this grid
> requires that the region implement OGS1 interface version 2 to
> connect. Try changing to OpenSimulator OpenSimulator Server
> 0.6.2.8449
> at
> OpenSim.Region.Communications.OGS1.OGS1GridServices.RegisterRegion(RegionInfo
> regionInfo) in c:\Documents and
> Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Communications\OGS1\OGS1GridServices.cs:line
> 171
> at
> OpenSim.Region.Communications.Hypergrid.HGGridServicesGridMode.RegisterRegion(RegionInfo
> regionInfo) in c:\Documents and
> Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Communications\Hypergrid\HGGridServicesGridMode.cs:line
> 84
> at
> OpenSim.Region.Framework.Scenes.SceneCommunicationService.RegisterRegion(IInterregionCommsOut
> comms_out, RegionInfo regionInfos) in c:\Documents and
> Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Framework\Scenes\SceneCommunicationService.cs:line
> 102
> at OpenSim.Region.Framework.Scenes.Scene.RegisterRegionWithGrid()
> in c:\Documents and
> Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Framework\Scenes\Scene.cs:line
> 1117
> at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
> portadd_flag, Boolean do_post_init) in c:\Documents and
> Settings\fwsweet\Desktop\Opensim\OpenSim\Region\Application\OpenSimBase.cs:line
> 597
>
> Frank W Sweet
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot bring up 8553 with osgrid

Ralf Haifisch
In reply to this post by Frank W Sweet
Heho,

on the osgrid website i see:
**OpenSimulator v0.6.3.8534
** CURRENTLY REQUIRED TO CONNECT TO GRID


in SVN-Tracker:
Rev 8544 - lbsa71

* Upping to interface version 3 - let's see how this goes.


What is needed for osgrid, what is the short time plan ??

Cheers,
Ralf


------------------------------
Date: Sat, 21 Feb 2009 21:52:42 +0100
From: Stefan Andersson <[hidden email]>
Subject: Re: [Opensim-users] Cannot bring up 8553 with osgrid
To: <[hidden email]>, "[hidden email]"
        <[hidden email]>
Message-ID: <[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"


Yes, sorry for not e-mailing the list with this; it kind of slipped my mind.

 

I upped the Interface Version today, as we were seeing considerable
deterioration of quality of service between new and old regions. In fact,
latest regions was reported not to connect or tp at all with 0.6.2 grid
services.

 

Since interface version 2, we have done considerable changes in how regions
communicate with each others and the grid.

 

Last revision running on version 2 was 8543, so stay on that or earlier
until your UGAIM has been updated.

 

To use later revisions than that, the UGAIM, ie, the grid services, has to
be updated past that.

 

I have also applied the update to 0.6.3-post-fixes, so 0.6.3 regions cannot
connect to pre-0.6.3 grids.

 

I should also take the opportunity to invite you all on a discussion on how
we should handle interface version increases. Of course, they should
probably be made around version changes, so one indicates another. Sorry to
say, that has not happened here, so some confusion should be expected.


Best regards,
Stefan Andersson
Tribal Media AB



 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users