Correct Grid Services Configuration for 0.6.6 release version (svn 9993) - UGRM?

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: Welcome web page on V0.6.6

Benjamin Smekens
Well, I can tell you the following, from your mails I have tried to render a webpage locally and it appears to successfully crash the Hippo viewer... No dynamic webpage, just one of the most basic html pages out there and unfortunately it doesn't deliver. As for the root cause of this, in previous responses there can be seen that all that the GridInfo section in the OpenSim.ini file does, is point towards the correct file. This is all neet and dandy BUT, this will point to a LOCAL file. So in either way I now assume that rendering a html page on the system pointing towards a relative (local) file is not possible, simply because the user will not have that local file on its local file system. As said before, install apache ;-)

Cheers,

Ben

On Thu, Sep 10, 2009 at 4:01 PM, Karen Palen <[hidden email]> wrote:
I have to admit that installing Apache and setting it up would be far less work LOL.

HMM - I didn't even know about the grid server folder!

Sadly it didn't help, but I will try a couple of permutations.

My main motivation at this point is wondering if OpenSim has this capability or not.

With Ubuntu I know that installing the latest version of Apache is a matter of about a dozen keystrokes (I have it running on another machine), but it could simplify file and process management later.

Eventually I expect to move this whole project to a remote VPS hosting service using Ubuntu/SSL remote login, but I want things pretty solid before I add the extra complexity.

Right now I am just having fun with standalone :-)

Anyway thanks for the pointer to the folder, I will let everyone know if I do get it working.

--- On Wed, 9/9/09, Benjamin Smekens <[hidden email]> wrote:

> From: Benjamin Smekens <[hidden email]>
> Subject: Re: [Opensim-users] Welcome web page on V0.6.6
> To: [hidden email]
> Date: Wednesday, September 9, 2009, 6:25 PM
> Mhhh, rather than putting a URI in the .ini
> file pointing towards some web-location, I presume that you
> have pointed towards some relative .html file inside the
> grid server folder right? It should just work if you put a
> relative path there. If it doesn't than I guess your
> last resort is to quickly fire up Apache, with current LAMP
> and WAMP packages that should be nothing more than a 5
> minute job either. I wish you the best of luck, but I guess
> that it is probably not worth the time trying to make it
> work with a relative path if it continues to misbehave :-)
> An alternative to setting up your own web server would be to
> just get a free hosting account somewhere and to host it
> from that location.
>
>
> Cheers,
>
> Ben
>
> On Thu, Sep 10, 2009 at 3:43 AM,
> Karen Palen <[hidden email]>
> wrote:
>
>
>
>
>
> --- On Wed, 9/9/09, wallen <[hidden email]>
> wrote:
>
>
>
> > From: wallen <[hidden email]>
>
> > Subject: Re: [Opensim-users] Welcome
> web page on V0.6.6
>
> > To: [hidden email]
>
> > Date: Wednesday, September 9, 2009, 9:59 AM
>
> >
>
> > On Wed, 2009-09-09 at 08:54 -0700, Karen Palen wrote:
>
>
>
> > > There IS a file in bin
> called HttpServer.dll and
>
> > HttpServer_Opensim.dll,
>
> > > but so far I have not been able to get even a
> static
>
> > page to show up on either the Hippo viewer or the
> Meerkat
>
> > viewer.
>
>
>
> > Yes, that was my experience as
> well.  Starting up my
>
> > own Apache server
>
> > and service a static page from that was the only way
> I
>
> > could get it to
>
> > work.
>
>
>
> What frustrates me is that I DID have it running a
> year ago when I first played with OpenSim then put it away
> as being "neat, but too fragile for now"..
>
>
>
> I should have saved the OpenSim.ini file at least :-(
>
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
>
> Opensim-users mailing list
>
> [hidden email]
>
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
>
>
> -----Inline Attachment Follows-----
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>




_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
12