Quantcast

Diva Wifi 0.8.2 on Robust 0.8.2.0 in Windows

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Diva Wifi 0.8.2 on Robust 0.8.2.0 in Windows

Unadecal Arado
Good day,

I run a Robust server in windows which has been very smooth ever since 0.8.0.1. Since the 0.8.1 update I have been unable to upgrade using the new distribution method for Wifi due to the following error. I fall at the first hurdle:

"
C:\OpenSim\robust-0.8.2.0\bin>mautil -reg c:\opensim\addins-registry reg-update
ERROR: Add-in scan operation failed. The runtime may have encountered an error while trying to load an assembly.
ERROR: Add-in scan operation failed (Could not load file or assembly 'file:///C:\OpenSim\robust-0.8.2.0\bin\Mono.Addins.dll' or one
of its dependencies. Operation is not supported. (Exception from HRESULT: 0x80131515))
ERROR: The add-in database could not be updated. It may be due to file corruption. Try running the setup repair utility

C:\OpenSim\robust-0.8.2.0\bin>
"
I then simply added Wifi 0.8.0 tomy 0.8.1.2 robust server and this seems to work at the moment, but having updated all my simulator instances to 0.8.2.0, I am keen to upgrade my Robust server as well.

Adding Wifi 0.8.0 to robust 0.8.2.0 does not work, and neither does manually updating the wifi dlls with the ones from the 0.8.2 Diva distro,

I googled "mono.addins.dll 0x80131515 and I found this article which may have some relevant information, since it mentions a discrepancy between the .Net frameworks used to build the project binaries, but my understanding of this it limited to suspecting that this may be something that needs to be addressed by the Opensim developer team. It is worth noting that I have .Net Framework 3.5 and 4.0 installed.

Can anyone help please?

Many thanks,

Unadecal Arado

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Diva Wifi 0.8.2 on Robust 0.8.2.0 in Windows

aiaustin

>From: Unadecal Arado <[hidden email]>
>I run a Robust server in windows which has been very smooth ever since
>0.8.0.1. Since the 0.8.1 update I have been unable to upgrade using the new
>distribution method for Wifi due to the following error. I fall at the
>first hurdle:
>...
>Can anyone help please?

Hi Unadecal, @Diva's Wifi continues to work fine with all versions
after you get onto the new addon modules setup and take a bit of care
with configuration...

See if this blog post helps...

http://blog.inf.ed.ac.uk/atate/2015/04/06/diva-wifi-on-windows/

There is some messing about I suggest in a Robust grid environment,
versus a standalone, to disable a second copy of Wifi starting up
under OpenSim.exe when using Robust.exe. You can leave it in but its
unnecessary.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Loading...