File not found OpenSim.Region.Environment

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

File not found OpenSim.Region.Environment

Jürgen Hamel

Hi,
SVN 8322 :
I receive this error-message after starting, can someone help me to
solve it ?

---------------------------------------------------------------------------------------------------------
 [ViewerStatsModule]: Loading Shared Module.

** (OpenSim.exe:9471): WARNING **: The following assembly
referenced
from /home/opensim/opensim/8322/bin/OpenSimSearch.Modules.dll could
not be loaded: Assembly:   OpenSim.Region.Environment
(assemblyref_index=1) Version:    0.0.0.0 Public Key: (none) The
assembly was not found in the Global Assembly Cache, a path listed
in the MONO_PATH environment variable, or in the location of the
executing assembly (/home/opensim/opensim/8322/bin).


** (OpenSim.exe:9471): WARNING **: Could not load file or assembly
'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or
one of its dependencies. 15:57:53 - [MODULES]: Could not load types
for [OpenSimSearch.Modules, Version=0.0.0.0, Culture=neutral,
PublicKeyToken=null].  Exception System.IO.FileNotFoundException:
Could not load file or assembly 'OpenSim.Region.Environment,
Version=0.0.0.0, Culture=neutral' or one of its dependencies. File
name: 'OpenSim.Region.Environment, Version=0.0.0.0,
Culture=neutral' at (wrapper managed-to-native)
System.Reflection.Assembly:GetTypes (bool) at
System.Reflection.Assembly.GetTypes () [0x00000] at
OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
dllName) [0x00000] 15:57:53 - [APPLICATION]: APPLICATION EXCEPTION
DETECTED: System.UnhandledExceptionEventArgs

Exception: System.IO.FileNotFoundException: Could not load file or
assembly 'OpenSim.Region.Environment, Version=0.0.0.0,
Culture=neutral' or one of its dependencies. File name:
'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' at
(wrapper managed-to-native) System.Reflection.Assembly:GetTypes
(bool) at System.Reflection.Assembly.GetTypes () [0x00000] at
OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
dllName) [0x00000]

-----------------------------------------------------------------------------------------------------------------------

I try this:
ls -l OpenSim/Region/Environment

and see this:
drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Interfaces
drwxr-xr-x 13 opensim opensim 4096 2009-02-10 15:44 Modules
drwxr-xr-x  5 opensim opensim 4096 2009-02-10 15:44 Scenes
drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Types

Hope, someone can help,

Thanks,
Jürgen
--
Cyrus-Computer GmbH Linux Server Support Jürgen Hamel
Cuon - Warenwirtschaft mit Linux  http://www.cuon.org

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: File not found OpenSim.Region.Environment

Dirk Krause
Did you 'cd' into the '/bin' directory before starting 'mono OpenSim.exe'?



-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Jürgen Hamel
Gesendet: Dienstag, 10. Februar 2009 17:35
An: [hidden email]
Betreff: [Opensim-users] File not found OpenSim.Region.Environment


Hi,
SVN 8322 :
I receive this error-message after starting, can someone help me to solve it ?

---------------------------------------------------------------------------------------------------------
 [ViewerStatsModule]: Loading Shared Module.

** (OpenSim.exe:9471): WARNING **: The following assembly referenced from /home/opensim/opensim/8322/bin/OpenSimSearch.Modules.dll could
not be loaded: Assembly:   OpenSim.Region.Environment
(assemblyref_index=1) Version:    0.0.0.0 Public Key: (none) The
assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/home/opensim/opensim/8322/bin).


** (OpenSim.exe:9471): WARNING **: Could not load file or assembly 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or one of its dependencies. 15:57:53 - [MODULES]: Could not load types for [OpenSimSearch.Modules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null].  Exception System.IO.FileNotFoundException:
Could not load file or assembly 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or one of its dependencies. File
name: 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool) at System.Reflection.Assembly.GetTypes () [0x00000] at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
dllName) [0x00000] 15:57:53 - [APPLICATION]: APPLICATION EXCEPTION
DETECTED: System.UnhandledExceptionEventArgs

Exception: System.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or one of its dependencies. File name:
'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes
(bool) at System.Reflection.Assembly.GetTypes () [0x00000] at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
dllName) [0x00000]

-----------------------------------------------------------------------------------------------------------------------

I try this:
ls -l OpenSim/Region/Environment

and see this:
drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Interfaces drwxr-xr-x 13 opensim opensim 4096 2009-02-10 15:44 Modules drwxr-xr-x  5 opensim opensim 4096 2009-02-10 15:44 Scenes drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Types

Hope, someone can help,

Thanks,
Jürgen
--
Cyrus-Computer GmbH Linux Server Support Jürgen Hamel Cuon - Warenwirtschaft mit Linux  http://www.cuon.org
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: File not found OpenSim.Region.Environment

justincc
In reply to this post by Jürgen Hamel
Jürgen Hamel wrote:
> Hi,
> SVN 8322 :
> I receive this error-message after starting, can someone help me to
> solve it ?

You will need to update OpenSimSearch.Modules.dll or temporarily remove it.

>
> ---------------------------------------------------------------------------------------------------------
>  [ViewerStatsModule]: Loading Shared Module.
>
> ** (OpenSim.exe:9471): WARNING **: The following assembly
> referenced
> from /home/opensim/opensim/8322/bin/OpenSimSearch.Modules.dll could
> not be loaded: Assembly:   OpenSim.Region.Environment
> (assemblyref_index=1) Version:    0.0.0.0 Public Key: (none) The
> assembly was not found in the Global Assembly Cache, a path listed
> in the MONO_PATH environment variable, or in the location of the
> executing assembly (/home/opensim/opensim/8322/bin).
>
>
> ** (OpenSim.exe:9471): WARNING **: Could not load file or assembly
> 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or
> one of its dependencies. 15:57:53 - [MODULES]: Could not load types
> for [OpenSimSearch.Modules, Version=0.0.0.0, Culture=neutral,
> PublicKeyToken=null].  Exception System.IO.FileNotFoundException:
> Could not load file or assembly 'OpenSim.Region.Environment,
> Version=0.0.0.0, Culture=neutral' or one of its dependencies. File
> name: 'OpenSim.Region.Environment, Version=0.0.0.0,
> Culture=neutral' at (wrapper managed-to-native)
> System.Reflection.Assembly:GetTypes (bool) at
> System.Reflection.Assembly.GetTypes () [0x00000] at
> OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
> dllName) [0x00000] 15:57:53 - [APPLICATION]: APPLICATION EXCEPTION
> DETECTED: System.UnhandledExceptionEventArgs
>
> Exception: System.IO.FileNotFoundException: Could not load file or
> assembly 'OpenSim.Region.Environment, Version=0.0.0.0,
> Culture=neutral' or one of its dependencies. File name:
> 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' at
> (wrapper managed-to-native) System.Reflection.Assembly:GetTypes
> (bool) at System.Reflection.Assembly.GetTypes () [0x00000] at
> OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
> dllName) [0x00000]
>
> -----------------------------------------------------------------------------------------------------------------------
>
> I try this:
> ls -l OpenSim/Region/Environment
>
> and see this:
> drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Interfaces
> drwxr-xr-x 13 opensim opensim 4096 2009-02-10 15:44 Modules
> drwxr-xr-x  5 opensim opensim 4096 2009-02-10 15:44 Scenes
> drwxr-xr-x  3 opensim opensim 4096 2009-02-10 15:44 Types
>
> Hope, someone can help,
>
> Thanks,
> Jürgen
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


--
justincc
Justin Clark-Casey
http://justincc.wordpress.com
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: File not found OpenSim.Region.Environment

Jürgen Hamel
On Tue, 10 Feb 2009 16:39:48 +0000
Justin Clark-Casey <[hidden email]> wrote:

> You will need to update OpenSimSearch.Modules.dll or temporarily remove it.

Hi, I remove it and it works, thanks. You write also to update it,
sorry, I was in this svn tree - or ? I look at it before and the
date was 2009-02-10, also today.

but ok, for this time I delete it simple, thanks again.

Jürgen

--
Cyrus-Computer GmbH Linux Server Support Jürgen Hamel
Cuon - Warenwirtschaft mit Linux  http://www.cuon.org

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users

signature.asc (196 bytes) Download Attachment