Fwd: [Opensim-dev] Mono minimum version bump

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: [Opensim-dev] Mono minimum version bump

Teravus Ovares
---------- Forwarded message ----------
From: Melanie <[hidden email]>
Date: Sun, Sep 27, 2009 at 3:43 PM
Subject: [Opensim-dev] Mono minimum version bump
To: [hidden email]


Hello,

after discovering a bug in the 2.0.1 version of mono, which causes
frequent crashing of regions, we have taken the step to bump the
minimum required mono version to 2.4.2+.

This has become necessary because the bug is rather difficult to
isolate and therefore impossible to work around reliably.

We do understand that this may cause difficulties for some people,
who have been relying on packaged binary versions of Mono. Version
2.4.2 is recent enough to have no binary packages, so it will be
necessary to build Mono from source. However, we feel it is
unavoidable at this time, as we can't recommend or endorse a Mono
version that we know to contain a showstopper bug.

On the upside, 2.4.2 has much better performance and stability,
compared to 2.0.1.

Melanie
_______________________________________________
Opensim-dev mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-dev
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: [Opensim-dev] Mono minimum version bump

James Stallings II
There is a binary distribution package for mono 2.4+ on openSUSE, though it is only available as an update to a previously installed 2.0.1 binary distribution package.

Cheers,
James


On Sun, Sep 27, 2009 at 2:44 PM, Teravus Ovares <[hidden email]> wrote:
---------- Forwarded message ----------
From: Melanie <[hidden email]>
Date: Sun, Sep 27, 2009 at 3:43 PM
Subject: [Opensim-dev] Mono minimum version bump
To: [hidden email]


Hello,

after discovering a bug in the 2.0.1 version of mono, which causes
frequent crashing of regions, we have taken the step to bump the
minimum required mono version to 2.4.2+.

This has become necessary because the bug is rather difficult to
isolate and therefore impossible to work around reliably.

We do understand that this may cause difficulties for some people,
who have been relying on packaged binary versions of Mono. Version
2.4.2 is recent enough to have no binary packages, so it will be
necessary to build Mono from source. However, we feel it is
unavoidable at this time, as we can't recommend or endorse a Mono
version that we know to contain a showstopper bug.

On the upside, 2.4.2 has much better performance and stability,
compared to 2.0.1.

Melanie
_______________________________________________
Opensim-dev mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-dev
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



--
===================================
http://osgrid.org
http://del.icio.us/SPQR
http://twitter.com/jstallings2
http://www.linkedin.com/pub/5/770/a49

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: [Opensim-dev] Mono minimum version bump

LaeMi Wang
2.4.2 is in Ubuntu Karmic.

I choose to follow this branch and while mono itself seems quite stable, they
have been fiddling with the boot system recently and I have sometimes been
left with a system that won't even get to a command prompt without some
hacking via my reserve boot partition  (not complaining here, just warning
people - that's what alpha releases are for, and I accept that ;-) ). If you
can get away with just pulling down the needed mono packages you should be
fine - just watch what dependencies it tries to pull in with them!

Karmic should become stable some time next month if Cannonical's release
timetable holds.

LaeMing


On Monday September 28 2009 05:53:18 James Stallings II wrote:

> There is a binary distribution package for mono 2.4+ on openSUSE, though it
> is only available as an update to a previously installed 2.0.1 binary
> distribution package.
> Cheers,
> James
>
> On Sun, Sep 27, 2009 at 2:44 PM, Teravus Ovares <[hidden email]> wrote:
> > ---------- Forwarded message ----------
> > From: Melanie <[hidden email]>
> > Date: Sun, Sep 27, 2009 at 3:43 PM
> > Subject: [Opensim-dev] Mono minimum version bump
> > To: [hidden email]
> >
> >
> > Hello,
> >
> > after discovering a bug in the 2.0.1 version of mono, which causes
> > frequent crashing of regions, we have taken the step to bump the
> > minimum required mono version to 2.4.2+.
> >
> > This has become necessary because the bug is rather difficult to
> > isolate and therefore impossible to work around reliably.
> >
> > We do understand that this may cause difficulties for some people,
> > who have been relying on packaged binary versions of Mono. Version
> > 2.4.2 is recent enough to have no binary packages, so it will be
> > necessary to build Mono from source. However, we feel it is
> > unavoidable at this time, as we can't recommend or endorse a Mono
> > version that we know to contain a showstopper bug.
> >
> > On the upside, 2.4.2 has much better performance and stability,
> > compared to 2.0.1.
> >
> > Melanie
> > _______________________________________________
> > Opensim-dev mailing list
> > [hidden email]
> > https://lists.berlios.de/mailman/listinfo/opensim-dev
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > https://lists.berlios.de/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users