Fwd: Regions being deleted from the database

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Fwd: Regions being deleted from the database

pcerioli
Today a few regions started to disappear from the regions database. I
turned them offline, but I was not expecting them to be automatically
deleted from the database.

After I looked at the opensim code, it looks that there is a
configuration settings for the [GridService] that you can add :
DeleteOnUnregister = "False"
to prevent them from being deleted from the database when offline.

I find it odd that it is an undocumented setting. And also why would
anybody want the regions to be actually deleted from the database?
They still have the other associated data in the other tables ( I
think), but now I don't remember which regions they were based on the
UUID.
Luckily I still have the configuration files, so I can re-create them.

I was planning to run individual instance of the simulator by loading
the configuration from the URL, instead of the Region.ini, but if the
data get deleted it is a bit unsafe.

I run Opensim 0.8.1 / Mono 3.10 / Ubuntu 14.04 on a multi-server configuration.

Is there anything else that I am missing?

Thank you in advance.
Paola
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Fwd: Regions being deleted from the database

R.Gunther
Oh good, the finbaly fixt that bug with maptiles that don't get deleted
? I guess if it's removed from the database the maptiles are finaly gone
too.
A long standing annoying bug that shutdown where not really shutdown.

And yes, if you shutdown the region the correct behavior must be that it
get deleted from the database.
If it stay in the database you get so many weird problem with maptiles
and teleports etc. the fail because the region is not there.
But the region you see in the map. SO i hope it's really what i think it is.

On 2015-06-06 04:54, Paola Cerioli wrote:

> Today a few regions started to disappear from the regions database. I
> turned them offline, but I was not expecting them to be automatically
> deleted from the database.
>
> After I looked at the opensim code, it looks that there is a
> configuration settings for the [GridService] that you can add :
> DeleteOnUnregister = "False"
> to prevent them from being deleted from the database when offline.
>
> I find it odd that it is an undocumented setting. And also why would
> anybody want the regions to be actually deleted from the database?
> They still have the other associated data in the other tables ( I
> think), but now I don't remember which regions they were based on the
> UUID.
> Luckily I still have the configuration files, so I can re-create them.
>
> I was planning to run individual instance of the simulator by loading
> the configuration from the URL, instead of the Region.ini, but if the
> data get deleted it is a bit unsafe.
>
> I run Opensim 0.8.1 / Mono 3.10 / Ubuntu 14.04 on a multi-server configuration.
>
> Is there anything else that I am missing?
>
> Thank you in advance.
> Paola
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users