Gridmode set up

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Gridmode set up

Mervyn Beamish
I cannot get OpenSim into Gridmode on my computer - the User server runs
up to the MSSQLUserData plugin and stops:

2009-04-28 01:18:16,421 INFO  - OpenSim.Grid.UserServer.OpenUser_Main
Launching UserServer...
2009-04-28 01:18:16,437 INFO  -
OpenSim.Framework.Servers.BaseOpenSimServer [STARTUP]: Beginning startup
processing
2009-04-28 01:18:16,437 INFO  -
OpenSim.Framework.Servers.BaseOpenSimServer [STARTUP]: Version:
OpenSimulator Server  0.6.4.9205

2009-04-28 01:19:22,968 INFO  - OpenSim.Grid.UserServer.OpenUser_Main
[STARTUP]: Establishing data connection
2009-04-28 01:19:22,984 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Initializing addin manager
2009-04-28 01:19:24,578 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim.Data
2009-04-28 01:19:24,593 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim
2009-04-28 01:19:24,625 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Loading extension point /OpenSim/UserData
2009-04-28 01:19:24,640 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/NHibernateUserData
2009-04-28 01:19:24,640 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/SQLiteUserData
2009-04-28 01:19:24,640 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/MySQLUserData
2009-04-28 01:19:24,656 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim.Data.MySQL
2009-04-28 01:19:24,656 INFO  - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/MSSQLUserData

the Opensim data source entry is:

storage_connection_string="Data Source=localhost;Database=opensim;User
ID=root;Password=[MySql password];";

Opensim works in standalone mode. I have the latest MySql version
installed- OS Windows XP pro



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Gridmode set up

Willem Huisman
Did you check OpenSim.ini properly to use either MySQL or MSSQL only ? If you try to start running OpenSim using MySQL , there should be no need for
MSSQL-components to be loaded ...

----- Original Message -----
From: "Mervyn Beamish"
To: [hidden email]
Subject: [Opensim-users] Gridmode set up
Date: Tue, 28 Apr 2009 07:19:58 +0800


I cannot get OpenSim into Gridmode on my computer - the User server runs
up to the MSSQLUserData plugin and stops:

2009-04-28 01:18:16,421 INFO - OpenSim.Grid.UserServer.OpenUser_Main
Launching UserServer...
2009-04-28 01:18:16,437 INFO -
OpenSim.Framework.Servers.BaseOpenSimServer [STARTUP]: Beginning startup
processing
2009-04-28 01:18:16,437 INFO -
OpenSim.Framework.Servers.BaseOpenSimServer [STARTUP]: Version:
OpenSimulator Server 0.6.4.9205

2009-04-28 01:19:22,968 INFO - OpenSim.Grid.UserServer.OpenUser_Main
[STARTUP]: Establishing data connection
2009-04-28 01:19:22,984 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Initializing addin manager
2009-04-28 01:19:24,578 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim.Data
2009-04-28 01:19:24,593 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim
2009-04-28 01:19:24,625 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Loading extension point /OpenSim/UserData
2009-04-28 01:19:24,640 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/NHibernateUserData
2009-04-28 01:19:24,640 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/SQLiteUserData
2009-04-28 01:19:24,640 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/MySQLUserData
2009-04-28 01:19:24,656 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Plugin Loaded: OpenSim.Data.MySQL
2009-04-28 01:19:24,656 INFO - OpenSim.Framework.PluginLoader`1
[PLUGINS]: Trying plugin /OpenSim/UserData/MSSQLUserData

the Opensim data source entry is:

storage_connection_string="Data Source=localhost;Database=opensim;User
ID=root;Password=[MySql password];";

Opensim works in standalone mode. I have the latest MySql version
installed- OS Windows XP pro



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



__________
WiLLuMPJuH

--
It's News. It's Reviews. It's Interviews. It's Free. What Are You Waiting For?
www.movieline.com!

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Gridmode set up

Tarak Kutther
Oooops! It seems I shouldn't have attached that file.  I have checked and I am only using MySQL - I also did a search on MSSQL lines to make sure they were commented out.

2009/4/28 Tarak Kutther <[hidden email]>
Will, Thanks for the reply - I have checked a couple of times - I pretty sure the Opensim only uses MySQL. Attached a copy of the ini.

2009/4/28 Willem Huisman <[hidden email]>
Did you check OpenSim.ini properly to use either MySQL or MSSQL only ? If you try to start running OpenSim using MySQL , there should be no need for
MSSQL-components to be loaded ...



__________
WiLLuMPJuH

--
It's News. It's Reviews. It's Interviews. It's Free. What Are You Waiting For?
www.movieline.com!

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users




_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Gridmode set up

Willem Huisman
In reply to this post by Mervyn Beamish
Lol. Ok.  Don't know your MySQL settings, don't wanna know them.

What your userserver should do when launching succesfully is the following :

02:41:16 - Launching UserServer...
02:41:16 - [STARTUP]: Beginning startup processing
02:41:16 - [STARTUP]: Version: OpenSimulator Server  0.6.4.9323
02:41:16 - [STARTUP]: Establishing data connection
02:41:16 - [PLUGINS]: Initializing addin manager
02:41:18 - [PLUGINS]: Loading extension point /OpenSim/UserData
02:41:18 - [PLUGINS]: Trying plugin /OpenSim/UserData/MSSQLUserData
02:41:18 - [PLUGINS]: Trying plugin /OpenSim/UserData/MySQLUserData
02:41:18 - [PLUGINS]: Plugin Loaded: OpenSim.Data.MySQL
02:41:18 - [PLUGINS]: Trying plugin /OpenSim/UserData/NHibernateUserData
02:41:18 - [PLUGINS]: Trying plugin /OpenSim/UserData/SQLiteUserData
02:41:18 - [MYSQL]: Connection established

.. so my guess is your connection from OpenSim to your MySQL data is not established properly since starting up in grid-mode.
Which ofc should not happen by just switching to gridmode.

Just the 2 cents I can spare you... :|
----- Original Message -----
From: "Tarak Kutther"
To: [hidden email]
Subject: Re: [Opensim-users] Gridmode set up
Date: Tue, 28 Apr 2009 10:17:31 +0800

Oooops! It seems I shouldn't have attached that file.  I have checked and I am only using MySQL - I also did a search on MSSQL lines to make sure they were commented out.

2009/4/28 Tarak Kutther <[hidden email]>
Will, Thanks for the reply - I have checked a couple of times - I pretty sure the Opensim only uses MySQL. Attached a copy of the ini.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
__________
WiLLuMPJuH

--
It's News. It's Reviews. It's Interviews. It's Free. What Are You Waiting For?
www.movieline.com!

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Gridmode set up

Tarak Kutther
Thanks for your 2 cents worth - It seems I should reinstall MySQL - it was a b@#@@%d to intall in the first place - have a good day
(lol - all passwords etc in the file werre examples only)

2009/4/28 Willem Huisman <[hidden email]>
Lol. Ok.  Don't know your MySQL settings, don't wanna know them.


----- Original Message -----
From: "Tarak Kutther"
To: [hidden email]
Subject: Re: [Opensim-users] Gridmode set up
Date: Tue, 28 Apr 2009 10:17:31 +0800

Oooops! It seems I shouldn't have attached that file.  I have checked and I am only using MySQL - I also did a search on MSSQL lines to make sure they were commented out.

2009/4/28 Tarak Kutther <[hidden email]>
Will, Thanks for the reply - I have checked a couple of times - I pretty sure the Opensim only uses MySQL. Attached a copy of the ini.
_______________________________________________
__________
WiLLuMPJuH

--
It's News. It's Reviews. It's Interviews. It's Free. What Are You Waiting For?
www.movieline.com!

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users