HG1.5 Tests - Arielle Popstar

classic Classic list List threaded Threaded
26 messages Options
12
Reply | Threaded
Open this post in threaded view
|

HG1.5 Tests - Arielle Popstar

aiaustin
Hi Arielle, I am posting this here on the assumption you might be on
opensim-users mailing list.

I see your attempts to do a test to Openvue GHrid.  its failing at
the point where my grid tries to verify you, as your address is set
to Arielle Popstar@127.0.0.1

You need I think to make sure your machine has an address where the
Hypergrid location you want to connect to can call back to verify you.

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
Thank you Ai. I did change the addresses in standalonecommon.ini to my external hostname but still wasn't  able to hypergrid with the new configuration. More reading required.
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
In reply to this post by aiaustin
Still not able to Hg to other standalone regions.

What I have changed from default so far is in opensim.ini I changed http_listener_port=9010. In Architecture uncommented Include-HGStandalone and commented out Include-Standalone.

In Config-include folder removed .example from standaloneCommon.ini and inside of it changed Region_Inventory_Island=*DefaultRegion, FallbackRegion"

Login Service section changed the 127.0.0.1:9000 to bound2.dyndns.org:9010 in all instances.

Gatekeeper Service:

ExternalName= "http://bound2.dyndns.org:9010"

In Region.ini

[Inventory Island]
Region UUid=*************
Location= 5010,5010
InternalAddress= 0.0.0.0.0  (tried internal IP too)
InternalPort= 9010
AllowAlternatePorts= False
ExternalHostname= bound2.dyndns.org

Home location was set in world.

Port 9010 tcp and Udp verified open.

Every attempt at HG to various regions fail whether  the other region is standalone or gridmode.

The last message i see on my region console is from Entity transfer Module: Sending new CAPS seed url http://*****.**** to client ********
After that -Grid Service: region Inventory Island has 0 neighbours

Viewer message: Could not teleport. Problems connecting to destination.


Anything I have missed on the configuration or other potential issues I would be glad to hear about it.

Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Diva Canto
Check your useraccounts table. The ServiceURLs need to either be correct
or empty.

On 7/27/2010 8:51 AM, Arielle_P wrote:

> Still not able to Hg to other standalone regions.
>
> What I have changed from default so far is in opensim.ini I changed
> http_listener_port=9010. In Architecture uncommented Include-HGStandalone
> and commented out Include-Standalone.
>
> In Config-include folder removed .example from standaloneCommon.ini and
> inside of it changed Region_Inventory_Island=*DefaultRegion, FallbackRegion"
>
> Login Service section changed the 127.0.0.1:9000 to bound2.dyndns.org:9010
> in all instances.
>
> Gatekeeper Service:
>
> ExternalName= "http://bound2.dyndns.org:9010"
>
> In Region.ini
>
> [Inventory Island]
> Region UUid=*************
> Location= 5010,5010
> InternalAddress= 0.0.0.0.0  (tried internal IP too)
> InternalPort= 9010
> AllowAlternatePorts= False
> ExternalHostname= bound2.dyndns.org
>
> Home location was set in world.
>
> Port 9010 tcp and Udp verified open.
>
> Every attempt at HG to various regions fail whether  the other region is
> standalone or gridmode.
>
> The last message i see on my region console is from Entity transfer Module:
> Sending new CAPS seed url http://*****.**** to client ********
> After that -Grid Service: region Inventory Island has 0 neighbours
>
> Viewer message: Could not teleport. Problems connecting to destination.
>
>
> Anything I have missed on the configuration or other potential issues I
> would be glad to hear about it.
>
>
>    

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
In the ServiceURL section I  have- HomeURI= GatekeeperURI= InventoryServerURI= AssetServerURI=

It is a fresh install with nothing brought from an older region. 2 user accounts both containing the above entry on seperate lines.


Diva Canto wrote
Check your useraccounts table. The ServiceURLs need to either be correct
or empty.
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Marck-2
I also have "HomeURI= GatekeeperURI= InventoryServerURI= AssetServerURI=" in the ServiceURLs field of the UserAccounts table (SQLite), and I do not have any problems with doing hypergrid teleports to other grids or standalones, including Arielle's.

Arielle_P wrote:

>
> In the ServiceURL section I  have- HomeURI= GatekeeperURI=
> InventoryServerURI= AssetServerURI=
>
> It is a fresh install with nothing brought from an older region. 2 user
> accounts both containing the above entry on seperate lines.
>
>
>
> Diva Canto wrote:
>>
>> Check your useraccounts table. The ServiceURLs need to either be correct
>> or empty.
>>
>>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

aiaustin
In reply to this post by aiaustin

>From: Arielle_P <[hidden email]>
>Still not able to Hg to other standalone regions.
>
>What I have changed from default so far is in opensim.ini I changed
>http_listener_port=9010. In Architecture uncommented Include-HGStandalone
>and commented out Include-Standalone.
>
>In Config-include folder removed .example from standaloneCommon.ini and
>inside of it changed Region_Inventory_Island=*DefaultRegion, FallbackRegion"
>
>Login Service section changed the 127.0.0.1:9000 to bound2.dyndns.org:9010
>in all instances.


I think you are ALMOST there Arielle.  I can see you log in attempts
on my consoles and logs... I think the problem might be that the
external address is not reachable through your firewalls to
authenticate you. You must have the port open for incoming traffics
at your ISP (they may block it), router and computer firewalls.

Here is a typical log of a log in attempt from you to the Openvue
grid.. which we know works fine if you are configured correctly. You
are gettign this error...

[Scene]: User Client Verification for Ari.Pop
@http://bound2.dyndns.org:9010 in Openvue returned false

If you get here try taking copies of the TWO test objects - a simple
one and one with contents and internal scripts and see if you can rez
them on your home setup from inventory when you return home. You
should be ale to if all is well.

16:00:24 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue to send
SendCreateChildAgent
16:00:24 - [CONNECTION BEGIN]: Region Openvue told of incoming child
agent Ari.Pop @http://bound2.dyndns.org:9010 
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 (circuitcode 1027021349,
teleportflags 128)
16:00:24 - [CONNECTION BEGIN]: Region Openvue authenticated and
authorized incoming child agent Ari.Pop
@http://bound2.dyndns.org:9010 e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
(circuit code 1027021349)
16:00:24 - [CAPS]: Reregistering caps for agent
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872.  Old caps path
d730cb93-9152-4798-bb18-85bb3a4ef2c3, new caps path
8514913f-6ea5-4c0f-bb1e-a633e13c6a15.
16:00:24 - [CAPS]: Registered seed capability
/CAPS/8514913f-6ea5-4c0f-bb1e-a633e13c6a150000/ for
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
16:00:24 - [OBJECTADD]: /CAPS/OA/299895fe-2519-4569-a888-b5a2cd86162b/
16:00:24 - [EVENTQUEUE]: Found Existing UUID!
16:00:24 - [FreeSwitchVoice]: OnRegisterCaps: agentID
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps OpenSim.Framework.Capabilities.Caps
16:00:24 - [VC]: OnRegisterCaps: agentID
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps OpenSim.Framework.Capabilities.Caps
16:00:24 - [GETTEXTURE]: /CAPS/7bc7faa6-33af-43a8-93a9-a4bf7d1460b3
16:00:25 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue
1099511628032000 to send AgentUpdate
16:00:25 - [LLUDPSERVER]: Handling UseCircuitCode packet from 174.91.122.5:2346
16:00:25 - [LLUDPSERVER]: Ignoring a repeated UseCircuitCode from
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 at 174.91.122.5:2346 for circuit
1027021349
16:00:25 - [SCENE]: Incoming child agent update for
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 in Openvue
16:00:26 - [CAPS]: Seed Caps Request in region: Openvue
16:00:26 - [Scene]: Incoming client Ari.Pop
@http://bound2.dyndns.org:9010 in region Openvue via Login
16:00:27 - [Scene]: User Client Verification for Ari.Pop
@http://bound2.dyndns.org:9010 in Openvue returned false
16:00:27 - [CAPS]: Unauthorized CAPS client
16:00:35 - [LLUDPSERVER]: Handling UseCircuitCode packet from 174.91.122.5:2346
16:00:35 - [LLUDPSERVER]: Connection request for client
e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 connecting with unnotified
circuit code 1027021349 from 174.91.122.5:2346
16:00:55 -  >>> DoDelete action:; RegionID:9c8b6f8f-8178-4a69-92dc-9feba4646e6b
16:00:55 - [AGENT HANDLER]: Agent Released/Deleted.

Best of luck, Ai



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Diva Canto
On 7/27/2010 11:40 AM, Ai Austin wrote:
> 16:00:27 - [CAPS]: Unauthorized CAPS client

There.
This is one of the new security devices in HG 1.5.
It happens when your TCP Address (where your client is) is different as
presented to your grid and the other grid. This address must be exactly
the same throughout a session, to all the grids you visit, in order to
prevent impersonations.
So you have some nastiness in your network involving the machine where
the viewer is, not your grid machines.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Marck-2
Could the logging output be changed to be more explanatory in this particular case, like reporting what addresses did not match and thus made the verification fail? This could help users with locating and correcting the problem.

Diva Canto wrote:

> On 7/27/2010 11:40 AM, Ai Austin wrote:
>> 16:00:27 - [CAPS]: Unauthorized CAPS client
>
> There.
> This is one of the new security devices in HG 1.5.
> It happens when your TCP Address (where your client is) is different as
> presented to your grid and the other grid. This address must be exactly
> the same throughout a session, to all the grids you visit, in order to
> prevent impersonations.
> So you have some nastiness in your network involving the machine where
> the viewer is, not your grid machines.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Ken Grunke
In Linux you can set the debug flag:
mono --debug OpenSim.exe
 but when I tried it spewed a huge amount of red text in my Ubuntu
install without even being logged in
.
<sarcasm>Could something be wrong with my setup?</sarcasm>

I don't know, but after turning it back off, everything seems to be
ok. Just offering this as a possible answer to Marck's question. I'm
in kind of the same boat as Arielle, I can recieve hypergid visits but
can't seem to get out except for one brief moment which crashed my
viewer. And after relogging, no luck getting back to that particular
sim, or anywhere.

Ken aka Key Gruin


On Tue, Jul 27, 2010 at 2:47 PM, Marck <[hidden email]> wrote:

> Could the logging output be changed to be more explanatory in this
> particular case, like reporting what addresses did not match and thus made
> the verification fail? This could help users with locating and correcting
> the problem.
>
> Diva Canto wrote:
>>
>> On 7/27/2010 11:40 AM, Ai Austin wrote:
>>>
>>> 16:00:27 - [CAPS]: Unauthorized CAPS client
>>
>> There.
>> This is one of the new security devices in HG 1.5.
>> It happens when your TCP Address (where your client is) is different as
>> presented to your grid and the other grid. This address must be exactly
>> the same throughout a session, to all the grids you visit, in order to
>> prevent impersonations.
>> So you have some nastiness in your network involving the machine where
>> the viewer is, not your grid machines.
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Diva Canto
The thing to have in mind is that the viewer's presented TCP address
must be the same throughout the entire session, to all grids,
independent of the relation between the viewer machine and the grids. If
ppl have  networking setups where a viewer presents an address to a grid
inside the same network, and another address to another grid outside
that network, HG TPs between those grids will fail.

This may still require some tuning on my part for 0.7.1, so I would be
interested in finding out more technical details of the network setups
of these cases that are failing -- are these dyndns cases only?  Etc.
Please use mantis for reporting those technical details. Thanks.

On 7/27/2010 1:55 PM, Ken G. wrote:

> In Linux you can set the debug flag:
> mono --debug OpenSim.exe
>   but when I tried it spewed a huge amount of red text in my Ubuntu
> install without even being logged in
> .
> <sarcasm>Could something be wrong with my setup?</sarcasm>
>
> I don't know, but after turning it back off, everything seems to be
> ok. Just offering this as a possible answer to Marck's question. I'm
> in kind of the same boat as Arielle, I can recieve hypergid visits but
> can't seem to get out except for one brief moment which crashed my
> viewer. And after relogging, no luck getting back to that particular
> sim, or anywhere.
>
> Ken aka Key Gruin
>
>
> On Tue, Jul 27, 2010 at 2:47 PM, Marck<[hidden email]>  wrote:
>    
>> Could the logging output be changed to be more explanatory in this
>> particular case, like reporting what addresses did not match and thus made
>> the verification fail? This could help users with locating and correcting
>> the problem.
>>
>> Diva Canto wrote:
>>      
>>> On 7/27/2010 11:40 AM, Ai Austin wrote:
>>>        
>>>> 16:00:27 - [CAPS]: Unauthorized CAPS client
>>>>          
>>> There.
>>> This is one of the new security devices in HG 1.5.
>>> It happens when your TCP Address (where your client is) is different as
>>> presented to your grid and the other grid. This address must be exactly
>>> the same throughout a session, to all the grids you visit, in order to
>>> prevent impersonations.
>>> So you have some nastiness in your network involving the machine where
>>> the viewer is, not your grid machines.
>>> _______________________________________________
>>> Opensim-users mailing list
>>> [hidden email]
>>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>>
>>>        
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
>>      
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>    

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
Diva Canto wrote
This may still require some tuning on my part for 0.7.1, so I would be
interested in finding out more technical details of the network setups
of these cases that are failing -- are these dyndns cases only?  Etc.
Please use mantis for reporting those technical details. Thanks.
The address presented to both grids by the viewer has to be the same for .7 since I have been unable to log into my standalone through the internal address as i am able to do with previous standalone hypergrids i have setup in past. The 174.91.122.5 ip in Ai's log is the match for my bond2.dyndns.org hostname so they are not in actual fact 2 different IP's. For the record port 9010 is forwarded and verified working with PFPortchecker for both tcp and udp and there are no firewalls on either the region server machine or the viewer machine which are both on the same network.

Here is a log of a typical HG attempt:

16:12:49 - [USER AGENT CONNECTOR]: Posted CreateAgent request to remote sim http
://bound2.dyndns.org:9010/homeagent/e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872/, regio
n Openvue, x=256000 y=256000
16:12:49 - [USER AGENT SERVICE]: Request to login user Ari Pop to grid virtual.a
iai.ed.ac.uk:8002
16:12:49 - [REMOTE SIMULATION CONNECTOR]: Posted CreateAgent request to remote s
im http://129.215.219.138:8002/foreignagent/e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
/, region Openvue, x=256000 y=256000
16:12:50 - [USER AGENT SERVICE]: Verifying agent token http://virtual.aiai.ed.ac
.uk:8002;e7a0dbc3-41e0-45b7-867e-707590047636 against http://virtual.aiai.ed.ac.
uk:8002;e7a0dbc3-41e0-45b7-867e-707590047636
16:12:51 - [REMOTE SIMULATION CONNECTOR]: DoCreateChildAgentCall reply was {"suc
cess":true}
16:12:51 - [USER AGENT CONNECTOR]: DoCreateChildAgentCall reply was {"success":t
rue}
16:12:51 - [PRESENCE SERVICE]: Session 558efa83-b99b-4fd4-b1ab-8aefa31bbd01 logo
ut
16:12:51 - [SCENE PRESENCE]: Closing child agents. Checking 1 regions in Invento
ry Island
16:12:53 - [USER AGENT SERVICE]: Verifying Client session 558efa83-b99b-4fd4-b1a
b-8aefa31bbd01 with token 174.91.122.5
16:13:01 - [REMOTE SIMULATION CONNECTOR]: exception on reply of ChilAgentUpdate
The operation has timed out
16:13:01 - [ENTITY TRANSFER MODULE]: Sending new CAPS seed url http://virtual.ai
ai.ed.ac.uk:9000/CAPS/b7f752cc-16b7-423f-b5c5-43dfcd09fd250000/ to client e4d3a0
c1-7ba8-448a-b393-1d2c8a8cd872
16:13:21 - [GRID SERVICE]: region Inventory Island has 0 neighours
Region (Inventory Island) #


Is there perhaps a port i need to open for the viewers themselves in this release?
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

James Stallings II
In reply to this post by aiaustin
Hi AI,

Concerning the test objects, I was able to obtain both and bring them back to my point of origin - contents were intact, though after clearing my cache, all creator/prev owner attribution reverted to '(loading)'.

Just FYI! Thanks for the interop test opportunity :)

Cheers!
James
SimHost.com


On Tue, Jul 27, 2010 at 1:40 PM, Ai Austin <[hidden email]> wrote:

From: Arielle_P <[hidden email]>

Still not able to Hg to other standalone regions.

What I have changed from default so far is in opensim.ini I changed
http_listener_port=9010. In Architecture uncommented Include-HGStandalone
and commented out Include-Standalone.

In Config-include folder removed .example from standaloneCommon.ini and
inside of it changed Region_Inventory_Island=*DefaultRegion, FallbackRegion"

Login Service section changed the 127.0.0.1:9000 to bound2.dyndns.org:9010
in all instances.


I think you are ALMOST there Arielle.  I can see you log in attempts on my consoles and logs... I think the problem might be that the external address is not reachable through your firewalls to authenticate you. You must have the port open for incoming traffics at your ISP (they may block it), router and computer firewalls.

Here is a typical log of a log in attempt from you to the Openvue grid.. which we know works fine if you are configured correctly. You are gettign this error...

[Scene]: User Client Verification for Ari.Pop @http://bound2.dyndns.org:9010 in Openvue returned false

If you get here try taking copies of the TWO test objects - a simple one and one with contents and internal scripts and see if you can rez them on your home setup from inventory when you return home. You should be ale to if all is well.

16:00:24 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue to send SendCreateChildAgent
16:00:24 - [CONNECTION BEGIN]: Region Openvue told of incoming child agent Ari.Pop @http://bound2.dyndns.org:9010 e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 (circuitcode 1027021349, teleportflags 128)
16:00:24 - [CONNECTION BEGIN]: Region Openvue authenticated and authorized incoming child agent Ari.Pop @http://bound2.dyndns.org:9010 e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 (circuit code 1027021349)
16:00:24 - [CAPS]: Reregistering caps for agent e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872.  Old caps path d730cb93-9152-4798-bb18-85bb3a4ef2c3, new caps path 8514913f-6ea5-4c0f-bb1e-a633e13c6a15.
16:00:24 - [CAPS]: Registered seed capability /CAPS/8514913f-6ea5-4c0f-bb1e-a633e13c6a150000/ for e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
16:00:24 - [OBJECTADD]: /CAPS/OA/299895fe-2519-4569-a888-b5a2cd86162b/
16:00:24 - [EVENTQUEUE]: Found Existing UUID!
16:00:24 - [FreeSwitchVoice]: OnRegisterCaps: agentID e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps OpenSim.Framework.Capabilities.Caps
16:00:24 - [VC]: OnRegisterCaps: agentID e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps OpenSim.Framework.Capabilities.Caps
16:00:24 - [GETTEXTURE]: /CAPS/7bc7faa6-33af-43a8-93a9-a4bf7d1460b3
16:00:25 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue 1099511628032000 to send AgentUpdate
16:00:25 - [LLUDPSERVER]: Handling UseCircuitCode packet from 174.91.122.5:2346
16:00:25 - [LLUDPSERVER]: Ignoring a repeated UseCircuitCode from e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 at 174.91.122.5:2346 for circuit 1027021349
16:00:25 - [SCENE]: Incoming child agent update for e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 in Openvue
16:00:26 - [CAPS]: Seed Caps Request in region: Openvue
16:00:26 - [Scene]: Incoming client Ari.Pop @http://bound2.dyndns.org:9010 in region Openvue via Login
16:00:27 - [Scene]: User Client Verification for Ari.Pop @http://bound2.dyndns.org:9010 in Openvue returned false
16:00:27 - [CAPS]: Unauthorized CAPS client
16:00:35 - [LLUDPSERVER]: Handling UseCircuitCode packet from 174.91.122.5:2346
16:00:35 - [LLUDPSERVER]: Connection request for client e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 connecting with unnotified circuit code 1027021349 from 174.91.122.5:2346
16:00:55 -  >>> DoDelete action:; RegionID:9c8b6f8f-8178-4a69-92dc-9feba4646e6b
16:00:55 - [AGENT HANDLER]: Agent Released/Deleted.

Best of luck, Ai




_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



--
===================================
http://osgrid.org
http://twitter.com/jstallings2
http://www.linkedin.com/pub/5/770/a49

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Teravus Ovares
Another thing that I have found to work but be risky technically is to
have your OpenSim machine and your grid services on the DMZ of your
router then set your External IP as your Hostname for each.   I think
it would also work for domain name in that scenario.   The key here is
that, for incoming requests that your router doesn't have a matching
outgoing request for, via NAT, it will pipe to the interface set as
the DMZ.   This allows routers that don't support NAT loopback
directly to work.   There are some important security considerations.
  If your box is a Linux box, make sure to only have the services that
you need installed on it and that you keep up with bugtraq and CERT
advisories ( http://seclists.org/ )   If your box is a windows box,
keep up with Windows Update patches.   Even then, there's a chance
that something could get through so be careful.  You might consider
putting a hardware firewall between your router and your machine in
the DMZ to limit your machine's exposure to only the ports that
OpenSimulator uses.

Regards

Teravus

On Tue, Jul 27, 2010 at 8:55 PM, James Stallings II
<[hidden email]> wrote:

> Hi AI,
> Concerning the test objects, I was able to obtain both and bring them back
> to my point of origin - contents were intact, though after clearing my
> cache, all creator/prev owner attribution reverted to '(loading)'.
> Just FYI! Thanks for the interop test opportunity :)
> Cheers!
> James
> SimHost.com
>
> On Tue, Jul 27, 2010 at 1:40 PM, Ai Austin <[hidden email]> wrote:
>>
>>> From: Arielle_P <[hidden email]>
>>> Still not able to Hg to other standalone regions.
>>>
>>> What I have changed from default so far is in opensim.ini I changed
>>> http_listener_port=9010. In Architecture uncommented Include-HGStandalone
>>> and commented out Include-Standalone.
>>>
>>> In Config-include folder removed .example from standaloneCommon.ini and
>>> inside of it changed Region_Inventory_Island=*DefaultRegion,
>>> FallbackRegion"
>>>
>>> Login Service section changed the 127.0.0.1:9000 to
>>> bound2.dyndns.org:9010
>>> in all instances.
>>
>>
>> I think you are ALMOST there Arielle.  I can see you log in attempts on my
>> consoles and logs... I think the problem might be that the external address
>> is not reachable through your firewalls to authenticate you. You must have
>> the port open for incoming traffics at your ISP (they may block it), router
>> and computer firewalls.
>>
>> Here is a typical log of a log in attempt from you to the Openvue grid..
>> which we know works fine if you are configured correctly. You are gettign
>> this error...
>>
>> [Scene]: User Client Verification for Ari.Pop
>> @http://bound2.dyndns.org:9010 in Openvue returned false
>>
>> If you get here try taking copies of the TWO test objects - a simple one
>> and one with contents and internal scripts and see if you can rez them on
>> your home setup from inventory when you return home. You should be ale to if
>> all is well.
>>
>> 16:00:24 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue to send
>> SendCreateChildAgent
>> 16:00:24 - [CONNECTION BEGIN]: Region Openvue told of incoming child agent
>> Ari.Pop @http://bound2.dyndns.org:9010 e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
>> (circuitcode 1027021349, teleportflags 128)
>> 16:00:24 - [CONNECTION BEGIN]: Region Openvue authenticated and authorized
>> incoming child agent Ari.Pop @http://bound2.dyndns.org:9010
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 (circuit code 1027021349)
>> 16:00:24 - [CAPS]: Reregistering caps for agent
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872.  Old caps path
>> d730cb93-9152-4798-bb18-85bb3a4ef2c3, new caps path
>> 8514913f-6ea5-4c0f-bb1e-a633e13c6a15.
>> 16:00:24 - [CAPS]: Registered seed capability
>> /CAPS/8514913f-6ea5-4c0f-bb1e-a633e13c6a150000/ for
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872
>> 16:00:24 - [OBJECTADD]: /CAPS/OA/299895fe-2519-4569-a888-b5a2cd86162b/
>> 16:00:24 - [EVENTQUEUE]: Found Existing UUID!
>> 16:00:24 - [FreeSwitchVoice]: OnRegisterCaps: agentID
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps
>> OpenSim.Framework.Capabilities.Caps
>> 16:00:24 - [VC]: OnRegisterCaps: agentID
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 caps
>> OpenSim.Framework.Capabilities.Caps
>> 16:00:24 - [GETTEXTURE]: /CAPS/7bc7faa6-33af-43a8-93a9-a4bf7d1460b3
>> 16:00:25 - [LOCAL SIMULATION CONNECTOR]: Found region Openvue
>> 1099511628032000 to send AgentUpdate
>> 16:00:25 - [LLUDPSERVER]: Handling UseCircuitCode packet from
>> 174.91.122.5:2346
>> 16:00:25 - [LLUDPSERVER]: Ignoring a repeated UseCircuitCode from
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 at 174.91.122.5:2346 for circuit
>> 1027021349
>> 16:00:25 - [SCENE]: Incoming child agent update for
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 in Openvue
>> 16:00:26 - [CAPS]: Seed Caps Request in region: Openvue
>> 16:00:26 - [Scene]: Incoming client Ari.Pop @http://bound2.dyndns.org:9010
>> in region Openvue via Login
>> 16:00:27 - [Scene]: User Client Verification for Ari.Pop
>> @http://bound2.dyndns.org:9010 in Openvue returned false
>> 16:00:27 - [CAPS]: Unauthorized CAPS client
>> 16:00:35 - [LLUDPSERVER]: Handling UseCircuitCode packet from
>> 174.91.122.5:2346
>> 16:00:35 - [LLUDPSERVER]: Connection request for client
>> e4d3a0c1-7ba8-448a-b393-1d2c8a8cd872 connecting with unnotified circuit code
>> 1027021349 from 174.91.122.5:2346
>> 16:00:55 -  >>> DoDelete action:;
>> RegionID:9c8b6f8f-8178-4a69-92dc-9feba4646e6b
>> 16:00:55 - [AGENT HANDLER]: Agent Released/Deleted.
>>
>> Best of luck, Ai
>>
>>
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
>
> --
> ===================================
> http://osgrid.org
> http://twitter.com/jstallings2
> http://www.linkedin.com/pub/5/770/a49
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

aiaustin
In reply to this post by aiaustin

>From: Diva Canto <[hidden email]>
>
>The thing to have in mind is that the viewer's presented TCP address
>must be the same throughout the entire session, to all grids,
>independent of the relation between the viewer machine and the grids. If
>ppl have  networking setups where a viewer presents an address to a grid
>inside the same network, and another address to another grid outside
>that network, HG TPs between those grids will fail.
>
>This may still require some tuning on my part for 0.7.1, so I would be
>interested in finding out more technical details of the network setups
>of these cases that are failing -- are these dyndns cases only?  Etc.

We should try to ensure that IP number, DNS name and any alias will
all work and be treated as a valid check.  not try to only directly
match what is presented.  As we note Opensim uses numbers sometimes
even where configurations give DNS names.

So one thing we ought to check is that the tests are not trying to
limit the verification check to a DNS name where its given in some
parts of Opensim versus an IP address where Opensim uses that in
another context.  We note IP numbers for the machines we run our grid
and sims on are often presented as IP numbers in the Opensim.log
whereas we always use a DNS name such as virtual.aiai.ed.ac.uk in our
config files throughout, including in region.ini files.  So Opensim
is getting the underlying IP number and using it in some way even
where the config gives a DNS name.

Of course the DNS name must be reverse lookupable from the number and
vice versa, we understand that.  In fact we always use "service"
aliases which are again reverse lookupable.  The underlying machine
name has these are aliases.

See our example by using
      nslookup virtual.aiai.ed.ac.uk

Name:    killegray.aiai.ed.ac.uk
Address:  129.215.219.138
Aliases:  virtual.aiai.ed.ac.uk

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
In reply to this post by Diva Canto


Diva Canto wrote:
>
> The thing to have in mind is that the viewer's presented TCP address
> must be the same throughout the entire session, to all grids,
> independent of the relation between the viewer machine and the grids. If
> ppl have  networking setups where a viewer presents an address to a grid
> inside the same network, and another address to another grid outside
> that network, HG TPs between those grids will fail.
>

This morning i tested the setup after removing all references to my dyndns
hostname and put in my current dynamic ip in both the viewer and region
configs. Tried running the viewer both locally and from another machine on
the network. Forwarded all ports from 8000-9010. Tried the region server in
both Xp and Win7 in different partitions on the same machine. Tried the
region software on a different machine.
 
Downloaded a fresh copy of .7, reconfigured for HGStandalone, new region
setup, avatar, etc. Still no luck.

--
View this message in context: http://opensim-users.2152040.n2.nabble.com/HG1-5-Tests-Arielle-Popstar-tp5338326p5345686.html
Sent from the opensim-users mailing list archive at Nabble.com.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

HG1.5

Christopher Holden
In reply to this post by aiaustin
I must say I was a little disappointed having updated to 0.7 to discover
that not only is HG1.5 not backwardly compatible with the old version,
but the move to 0.7 amongst other grids seems to be some way off to say
the least... HG is one of the most exciting developments within OS yet
it's reason for existence is negated by the fact that the upgrade
effectively disconnects you from the hypergriddes world at large!

I hope we see grids updating to 0.7 soon, and future HG developments not
causing such situations to arise again as it becomes more mature.

In the meantime, anyone with a HG1.5 grid or standalone sim in a vaguely
Euro timezone wants to try some tests let me know!

Chris.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5

Diva Canto
HG 1.5 is incompatible with 1.0 on purpose. 1.0 is completely insecure
across trust boundaries. It puts users' identities and inventories at risk.

Incompatible improvements to OpenSim will happen again when they are
needed, such as for security reasons.


Christopher Holden wrote:

> I must say I was a little disappointed having updated to 0.7 to discover
> that not only is HG1.5 not backwardly compatible with the old version,
> but the move to 0.7 amongst other grids seems to be some way off to say
> the least... HG is one of the most exciting developments within OS yet
> it's reason for existence is negated by the fact that the upgrade
> effectively disconnects you from the hypergriddes world at large!
>
> I hope we see grids updating to 0.7 soon, and future HG developments not
> causing such situations to arise again as it becomes more mature.
>
> In the meantime, anyone with a HG1.5 grid or standalone sim in a vaguely
> Euro timezone wants to try some tests let me know!
>
> Chris.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Arielle_P
In reply to this post by Diva Canto
Diva Canto wrote
The thing to have in mind is that the viewer's presented TCP address
must be the same throughout the entire session, to all grids,
independent of the relation between the viewer machine and the grids. If
ppl have  networking setups where a viewer presents an address to a grid
inside the same network, and another address to another grid outside
that network, HG TPs between those grids will fail.
This morning i tested the setup after removing all references to my dyndns hostname and put in my current dynamic ip in both the viewer and region configs. Tried running the viewer both locally and from another machine on the network. Forwarded all ports from 8000-9010. Tried the region server in both Xp and Win7 in different partitions on the same machine. Tried the region software on a different machine.
 
Downloaded a fresh copy of .7, reconfigured for HGStandalone, new region setup, avatar, etc. Still no luck.
Reply | Threaded
Open this post in threaded view
|

Re: HG1.5 Tests - Arielle Popstar

Diva Canto
It's completely ineffective to diagnose these kinds of problems over
email. You asked here, you got the answers that belong here.
If you're interested in trying to understand better what is going on in
your network -- and, more importantly, help identify situations that may
arise in other people's networks -- please file an issue report, and
we'll diagnose things there.

http://opensimulator.org/mantis/view_all_bug_page.php

There are things that you can do, and debug messages that you should be
paying attention to, but I'm not going to have that kind of interaction
over email.


Arielle_P wrote:

>
> Diva Canto wrote:
>> The thing to have in mind is that the viewer's presented TCP address
>> must be the same throughout the entire session, to all grids,
>> independent of the relation between the viewer machine and the grids. If
>> ppl have  networking setups where a viewer presents an address to a grid
>> inside the same network, and another address to another grid outside
>> that network, HG TPs between those grids will fail.
>>
>
> This morning i tested the setup after removing all references to my dyndns
> hostname and put in my current dynamic ip in both the viewer and region
> configs. Tried running the viewer both locally and from another machine on
> the network. Forwarded all ports from 8000-9010. Tried the region server in
> both Xp and Win7 in different partitions on the same machine. Tried the
> region software on a different machine.
>  
> Downloaded a fresh copy of .7, reconfigured for HGStandalone, new region
> setup, avatar, etc. Still no luck.
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
12