Help finding bad scripted object

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Help finding bad scripted object

tringate
I run several regions.  Two are 4 by 4 VAR residential regions for OSgrid residents.

Region 1 is having a problem where it is using 28% of the server CPU where Region 2 is only using 4% of it’s server CPU.

The two servers are essentially identical.  However region 1 is the only region or application running in it’s server.

I have determined that the issue is one or more scripts because if I use “debug” in “estates” and turn off scripts the CPU utilization on region 1 drops to 2%.

Unfortunately for some reason the same tool can not be used to disable individual scripts.  I know this use to work back many releases of opensim ago but I was also
running individual 256 by 256 standard regions back then.  It could be a VAR region issue.  Another difference is that now I have the residents living on islands which
are individual parcels.  I notice the estates/debug tool is not able to determine what parcel a item is on because that column shows “unknown” for every item in the list.

Hence my problem of not being able to find the script or scripts that are using up the server CPU cycles other than to disable them all.

Here is some information from the “status” tool which confirms a huge difference in script CPU usage between the two regions.

Region 1
Objects 39,049
scripts 5,653
script events per/s 700-1100
script time 7.7ms

Region 2
Objects 34,426
scripts 3,427
script events per/s 65
script time 0.2ms

These measurements were taken with no other avatars on the region other than me.  The regions were essentially idle.  I watched the measurements for a few minutes on each region
and they remained fairly stable on both regions.  Only the “script events per second” changed a few 100 while I was watching and that was only on region 1.

While there are 2200 more scripts on region 1, the events per second is through the roof and so is the total continuous
idle” usage of 7.7ms vs 0.2ms

There has to be some bad scripts on region 1 but how do you find them when the debug tool does not let you disable individual scripts?

Any ideas?

I came up with one idea which is to clone region 1 to my desktop computer and run it as a standalone region.  Then go about deleting things from the region a few at a time.

I doubt I can delete items by individual owner/resident since when I port like that I believe I end up being the owner of everything.

I would really appreciate some other minds suggesting different ways to find the needle in this rather large haystack.

Thank goodness the “disable scripts” function works so well.  At lease it told me the issue was a script and not something else.  I wish the individual disable worked.

If it helps or makes any difference I am running the Singularity Alpha viewer.  If the disable issue is with the viewer I certainly will switch to another viewer to find this issue.

The version of opensim is the latest version OSgrid released to accommodate their servers moving last Tuesday/Wednesday.  This problem existed prior to that change.  

Thanks for reading this and hopefully someone has a better solution to finding the offending scripts so I can remove those objects.

My suspicion is it is probably only a single resident who has a bunch of bad scripts or has something very unusual.

Tom


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users