Help interpreting OpenSim crash console output

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Help interpreting OpenSim crash console output

riebling
Hey, I've got an instance of OpenSim running on Ubuntu 9.04
with MONO 2.0.1 (the default), ODE physics, and
MONO_THREADS_PER_CPU set to 50.  I experienced a crash right
after someone sent an IM in-world, with this console report.
(The last 2 lines keep repeating ["New Thread..."])

I'm just seeking help interpreting the output, if it's possible
to determine what might have gone wrong.  (Or an easy fix like
using a different MONO or threads per cpu setting)

Region (root) # Stacktrace:

  at (wrapper managed-to-native) Ode.NET.d.WorldQuickStep (intptr,single) <0x00004>
  at (wrapper managed-to-native) Ode.NET.d.WorldQuickStep (intptr,single) <0xffffffff>
  at OpenSim.Region.Physics.OdePlugin.OdeScene.Simulate (single) <0x01500>
  at OpenSim.Region.Framework.Scenes.SceneGraph.UpdatePhysics (double) <0x00036>
  at OpenSim.Region.Framework.Scenes.Scene.Update () <0x00456>
  at OpenSim.Region.Framework.Scenes.Scene.Heartbeat (object) <0x0000b>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void__this___object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

        mono [0x806d944]
        mono [0x808616b]
        [0xb7f02410]
        ./libode.so(_Z14dxQuickStepperP7dxWorldPKP6dxBodyiPKP7dxJointif+0x127c) [0xb5972f7c]
        ./libode.so(_Z16dxProcessIslandsP7dxWorldfPFvS0_PKP6dxBodyiPKP7dxJointifE+0x1bf) [0xb597c70f]
        ./libode.so(dWorldQuickStep+0x2e) [0xb596ea2e]
        [0xb33427ba]
        [0xb333f989]
        [0xb333e45f]
        [0xb333d457]
        [0xb6413f7c]
        [0xb640ee6e]
        mono(mono_runtime_delegate_invoke+0x34) [0x80b8974]
        mono [0x80f76bf]
        mono [0x81653b6]
        mono [0x8183355]
        /lib/tls/i686/cmov/libpthread.so.0 [0xb7e114ff]
        /lib/tls/i686/cmov/libc.so.6(clone+0x5e) [0xb7d6649e]

Debug info from gdb:

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb7c4e6e0 (LWP 26391)]
[New Thread 0xb1ee7b90 (LWP 31133)]
...


--
Eric Riebling  GHC 6713,  LTI,   SCS,  CMU
412.268.9872   http://www.cs.cmu.edu/~er1k
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users