Hypergrid 1.5 jumps over 6K reproducible

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Hypergrid 1.5 jumps over 6K reproducible

Dolma Dollinger
I cant hyperjump directly to Openvue directly (from 7000,7000 to 1000,1000)

In Hypergridlinker.cs there is a snippet of code that checks for it

if (!Check4096(handle, out x, out y))
            {
                RemoveHyperlinkRegion(regInfo.RegionID);
                reason = "Region is too far (" + x + ", " + y + ")";
                m_log.Info("[HYPERGRID LINKER]: Unable to link, region
is too far (" + x + ", " + y + ")");
                return false;
            }


However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
then to virtual.aiai.ed.ac.uk:8002:openvue

Then I can teleport home.

I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
displayed, but I can move it around and even teleport within my grid.
the sim I teleported too isnt displayed, but all other sims in my metagrid are.
No prims rezz however.
Seems the client missed some messages to build up the scene
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Diva Canto
Dolma,

What you are describing is exactly the situation of the 4096 bug. We
could always teleport; things just don't rez and the viewer generally
seems confused. It looks like it hasn't been fixed in that viewer.
https://jira.secondlife.com/browse/SVC-2941

I'm leaving the constraint in the code until at least one viewer fixes this.

Crista

On 6/28/2010 8:48 PM, Dolma Dollinger wrote:

> I cant hyperjump directly to Openvue directly (from 7000,7000 to 1000,1000)
>
> In Hypergridlinker.cs there is a snippet of code that checks for it
>
> if (!Check4096(handle, out x, out y))
>              {
>                  RemoveHyperlinkRegion(regInfo.RegionID);
>                  reason = "Region is too far (" + x + ", " + y + ")";
>                  m_log.Info("[HYPERGRID LINKER]: Unable to link, region
> is too far (" + x + ", " + y + ")");
>                  return false;
>              }
>
>
> However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
> then to virtual.aiai.ed.ac.uk:8002:openvue
>
> Then I can teleport home.
>
> I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
> displayed, but I can move it around and even teleport within my grid.
> the sim I teleported too isnt displayed, but all other sims in my metagrid are.
> No prims rezz however.
> Seems the client missed some messages to build up the scene
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>    

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Bob Wellman
Diva
 
What we seem to have, with this 4096 jump issue, is an impasse. Some viewers actually put possible a fix into thier code for this some time ago, but were unable to test it because of the server side constraint. The server constraint wont be removed until at least one viewer has it working. So no testing/progress is possible.
 
Could I suggest that an opensim.ini setting be added so this constraint can be varied for viewer testing purposes. Something like below would seem good to me.
 
JumpDistanceLimit = 4096
 
This would allow most grid operators to keep their grids safe, whilst also allowing others to test viewer jump distance fixes.
 
PS. Its hard to find 2 regions that far apart in SL (easy in OS) so testing must happen in OS I think.
 
 

> Date: Tue, 29 Jun 2010 04:45:31 -0700
> From: [hidden email]
> To: [hidden email]
> Subject: Re: [Opensim-users] Hypergrid 1.5 jumps over 6K reproducible
>
> Dolma,
>
> What you are describing is exactly the situation of the 4096 bug. We
> could always teleport; things just don't rez and the viewer generally
> seems confused. It looks like it hasn't been fixed in that viewer.
> https://jira.secondlife.com/browse/SVC-2941
>
> I'm leaving the constraint in the code until at least one viewer fixes this.
>
> Crista
>
> On 6/28/2010 8:48 PM, Dolma Dollinger wrote:
> > I cant hyperjump directly to Openvue directly (from 7000,7000 to 1000,1000)
> >
> > In Hypergridlinker.cs there is a snippet of code that checks for it
> >
> > if (!Check4096(handle, out x, out y))
> > {
> > RemoveHyperlinkRegion(regInfo.RegionID);
> > reason = "Region is too far (" + x + ", " + y + ")";
> > m_log.Info("[HYPERGRID LINKER]: Unable to link, region
> > is too far (" + x + ", " + y + ")");
> > return false;
> > }
> >
> >
> > However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
> > then to virtual.aiai.ed.ac.uk:8002:openvue
> >
> > Then I can teleport home.
> >
> > I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
> > displayed, but I can move it around and even teleport within my grid.
> > the sim I teleported too isnt displayed, but all other sims in my metagrid are.
> > No prims rezz however.
> > Seems the client missed some messages to build up the scene
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > https://lists.berlios.de/mailman/listinfo/opensim-users
> >
> >
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


Get a new e-mail account with Hotmail - Free. Sign-up now.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Dolma Dollinger
Well I solved one problem but got another.
The Imprudence Developers withdrew the patch
https://jira.secondlife.com/browse/SVC-2941 in Imprudence 1.3.0,
because that solves a problem with prims only partly rezzing an a
Hypergrid jump (http://redmine.imprudenceviewer.org/issues/239)
Imprudence 1.2.2 still had the patch.
So I used imprudence 1.2.2. And that worked! I teleported back over 6K
to my home grid, arrived at a normal spot with normal camera
orientation.
Only on every Hypergrid Teleport I had the partly rezzing problem.
So it seems to me we can be close to a working long range Hypergrid Teleport


On Tue, Jun 29, 2010 at 4:55 PM, Bob Wellman <[hidden email]> wrote:

> Diva
>
> What we seem to have, with this 4096 jump issue, is an impasse. Some viewers
> actually put possible a fix into thier code for this some time ago, but were
> unable to test it because of the server side constraint. The server
> constraint wont be removed until at least one viewer has it working. So no
> testing/progress is possible.
>
> Could I suggest that an opensim.ini setting be added so this constraint can
> be varied for viewer testing purposes. Something like below would seem good
> to me.
>
> JumpDistanceLimit = 4096
>
> This would allow most grid operators to keep their grids safe, whilst
> also allowing others to test viewer jump distance fixes.
>
> PS. Its hard to find 2 regions that far apart in SL (easy in OS) so testing
> must happen in OS I think.
>
>
>> Date: Tue, 29 Jun 2010 04:45:31 -0700
>> From: [hidden email]
>> To: [hidden email]
>> Subject: Re: [Opensim-users] Hypergrid 1.5 jumps over 6K reproducible
>>
>> Dolma,
>>
>> What you are describing is exactly the situation of the 4096 bug. We
>> could always teleport; things just don't rez and the viewer generally
>> seems confused. It looks like it hasn't been fixed in that viewer.
>> https://jira.secondlife.com/browse/SVC-2941
>>
>> I'm leaving the constraint in the code until at least one viewer fixes
>> this.
>>
>> Crista
>>
>> On 6/28/2010 8:48 PM, Dolma Dollinger wrote:
>> > I cant hyperjump directly to Openvue directly (from 7000,7000 to
>> > 1000,1000)
>> >
>> > In Hypergridlinker.cs there is a snippet of code that checks for it
>> >
>> > if (!Check4096(handle, out x, out y))
>> > {
>> > RemoveHyperlinkRegion(regInfo.RegionID);
>> > reason = "Region is too far (" + x + ", " + y + ")";
>> > m_log.Info("[HYPERGRID LINKER]: Unable to link, region
>> > is too far (" + x + ", " + y + ")");
>> > return false;
>> > }
>> >
>> >
>> > However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
>> > then to virtual.aiai.ed.ac.uk:8002:openvue
>> >
>> > Then I can teleport home.
>> >
>> > I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
>> > displayed, but I can move it around and even teleport within my grid.
>> > the sim I teleported too isnt displayed, but all other sims in my
>> > metagrid are.
>> > No prims rezz however.
>> > Seems the client missed some messages to build up the scene
>> > _______________________________________________
>> > Opensim-users mailing list
>> > [hidden email]
>> > https://lists.berlios.de/mailman/listinfo/opensim-users
>> >
>> >
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>
> ________________________________
> Get a new e-mail account with Hotmail - Free. Sign-up now.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Jeroen van Veen
That's good news. How about teleporting locally to really large 100K+ regions?
This always returns "Region doesn't exist anymore'. It works normally when
logging in to the region.

kind regards,

Jeroen

On Wednesday 30 June 2010 07:49:15 Dolma Dollinger wrote:

> Well I solved one problem but got another.
> The Imprudence Developers withdrew the patch
> https://jira.secondlife.com/browse/SVC-2941 in Imprudence 1.3.0,
> because that solves a problem with prims only partly rezzing an a
> Hypergrid jump (http://redmine.imprudenceviewer.org/issues/239)
> Imprudence 1.2.2 still had the patch.
> So I used imprudence 1.2.2. And that worked! I teleported back over 6K
> to my home grid, arrived at a normal spot with normal camera
> orientation.
> Only on every Hypergrid Teleport I had the partly rezzing problem.
> So it seems to me we can be close to a working long range Hypergrid
> Teleport
>
> On Tue, Jun 29, 2010 at 4:55 PM, Bob Wellman <[hidden email]>
wrote:

> > Diva
> >
> > What we seem to have, with this 4096 jump issue, is an impasse. Some
> > viewers actually put possible a fix into thier code for this some time
> > ago, but were unable to test it because of the server side constraint.
> > The server constraint wont be removed until at least one viewer has it
> > working. So no testing/progress is possible.
> >
> > Could I suggest that an opensim.ini setting be added so this constraint
> > can be varied for viewer testing purposes. Something like below would
> > seem good to me.
> >
> > JumpDistanceLimit = 4096
> >
> > This would allow most grid operators to keep their grids safe, whilst
> > also allowing others to test viewer jump distance fixes.
> >
> > PS. Its hard to find 2 regions that far apart in SL (easy in OS) so
> > testing must happen in OS I think.
> >
> >> Date: Tue, 29 Jun 2010 04:45:31 -0700
> >> From: [hidden email]
> >> To: [hidden email]
> >> Subject: Re: [Opensim-users] Hypergrid 1.5 jumps over 6K reproducible
> >>
> >> Dolma,
> >>
> >> What you are describing is exactly the situation of the 4096 bug. We
> >> could always teleport; things just don't rez and the viewer generally
> >> seems confused. It looks like it hasn't been fixed in that viewer.
> >> https://jira.secondlife.com/browse/SVC-2941
> >>
> >> I'm leaving the constraint in the code until at least one viewer fixes
> >> this.
> >>
> >> Crista
> >>
> >> On 6/28/2010 8:48 PM, Dolma Dollinger wrote:
> >> > I cant hyperjump directly to Openvue directly (from 7000,7000 to
> >> > 1000,1000)
> >> >
> >> > In Hypergridlinker.cs there is a snippet of code that checks for it
> >> >
> >> > if (!Check4096(handle, out x, out y))
> >> > {
> >> > RemoveHyperlinkRegion(regInfo.RegionID);
> >> > reason = "Region is too far (" + x + ", " + y + ")";
> >> > m_log.Info("[HYPERGRID LINKER]: Unable to link, region
> >> > is too far (" + x + ", " + y + ")");
> >> > return false;
> >> > }
> >> >
> >> >
> >> > However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
> >> > then to virtual.aiai.ed.ac.uk:8002:openvue
> >> >
> >> > Then I can teleport home.
> >> >
> >> > I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
> >> > displayed, but I can move it around and even teleport within my grid.
> >> > the sim I teleported too isnt displayed, but all other sims in my
> >> > metagrid are.
> >> > No prims rezz however.
> >> > Seems the client missed some messages to build up the scene
> >> > _______________________________________________
> >> > Opensim-users mailing list
> >> > [hidden email]
> >> > https://lists.berlios.de/mailman/listinfo/opensim-users
> >>
> >> _______________________________________________
> >> Opensim-users mailing list
> >> [hidden email]
> >> https://lists.berlios.de/mailman/listinfo/opensim-users
> >
> > ________________________________
> > Get a new e-mail account with Hotmail - Free. Sign-up now.
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > https://lists.berlios.de/mailman/listinfo/opensim-users
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Diva Canto
Clarification:

The 4096-limit bug has nothing to do with the Hypergrid. You bump into
this same limitation by having two regions on the same grid that are
separated by more than 4096 map cells in either axis. So, for testing if
viewers have fixed this or not, simply have two regions, one at
1000,1000 and the other at, say 7000,7000. If you can TP between the 2,
and things look normal upon arrival, then the bug is fixed in that
viewer. Let me know when that happens.

The reason why this bug got highlighted in HG TPs is that in the HG
people don't have any control over the absolute coordinates where other
grids place the regions; specifically, OSGrid is placed around 10,000
whereas standalones, by default, are placed around 1000.(Whereas within
one grid operators usually place the regions very close, and those long
jumps simply don't exist.) In order to avoid a series of issue reports
of the kind "TPs not working in HG -- nothing rezzes upon arrival", I
added that check to prevent those long jumps in HG TPs.

As soon as someone confirms that viewers have fixed this, I will remove
the check in HG TPs.

On 6/30/2010 12:25 AM, Jeroen van Veen wrote:

> That's good news. How about teleporting locally to really large 100K+ regions?
> This always returns "Region doesn't exist anymore'. It works normally when
> logging in to the region.
>
> kind regards,
>
> Jeroen
>
> On Wednesday 30 June 2010 07:49:15 Dolma Dollinger wrote:
>    
>> Well I solved one problem but got another.
>> The Imprudence Developers withdrew the patch
>> https://jira.secondlife.com/browse/SVC-2941 in Imprudence 1.3.0,
>> because that solves a problem with prims only partly rezzing an a
>> Hypergrid jump (http://redmine.imprudenceviewer.org/issues/239)
>> Imprudence 1.2.2 still had the patch.
>> So I used imprudence 1.2.2. And that worked! I teleported back over 6K
>> to my home grid, arrived at a normal spot with normal camera
>> orientation.
>> Only on every Hypergrid Teleport I had the partly rezzing problem.
>> So it seems to me we can be close to a working long range Hypergrid
>> Teleport
>>
>> On Tue, Jun 29, 2010 at 4:55 PM, Bob Wellman<[hidden email]>
>>      
> wrote:
>    
>>> Diva
>>>
>>> What we seem to have, with this 4096 jump issue, is an impasse. Some
>>> viewers actually put possible a fix into thier code for this some time
>>> ago, but were unable to test it because of the server side constraint.
>>> The server constraint wont be removed until at least one viewer has it
>>> working. So no testing/progress is possible.
>>>
>>> Could I suggest that an opensim.ini setting be added so this constraint
>>> can be varied for viewer testing purposes. Something like below would
>>> seem good to me.
>>>
>>> JumpDistanceLimit = 4096
>>>
>>> This would allow most grid operators to keep their grids safe, whilst
>>> also allowing others to test viewer jump distance fixes.
>>>
>>> PS. Its hard to find 2 regions that far apart in SL (easy in OS) so
>>> testing must happen in OS I think.
>>>
>>>        
>>>> Date: Tue, 29 Jun 2010 04:45:31 -0700
>>>> From: [hidden email]
>>>> To: [hidden email]
>>>> Subject: Re: [Opensim-users] Hypergrid 1.5 jumps over 6K reproducible
>>>>
>>>> Dolma,
>>>>
>>>> What you are describing is exactly the situation of the 4096 bug. We
>>>> could always teleport; things just don't rez and the viewer generally
>>>> seems confused. It looks like it hasn't been fixed in that viewer.
>>>> https://jira.secondlife.com/browse/SVC-2941
>>>>
>>>> I'm leaving the constraint in the code until at least one viewer fixes
>>>> this.
>>>>
>>>> Crista
>>>>
>>>> On 6/28/2010 8:48 PM, Dolma Dollinger wrote:
>>>>          
>>>>> I cant hyperjump directly to Openvue directly (from 7000,7000 to
>>>>> 1000,1000)
>>>>>
>>>>> In Hypergridlinker.cs there is a snippet of code that checks for it
>>>>>
>>>>> if (!Check4096(handle, out x, out y))
>>>>> {
>>>>> RemoveHyperlinkRegion(regInfo.RegionID);
>>>>> reason = "Region is too far (" + x + ", " + y + ")";
>>>>> m_log.Info("[HYPERGRID LINKER]: Unable to link, region
>>>>> is too far (" + x + ", " + y + ")");
>>>>> return false;
>>>>> }
>>>>>
>>>>>
>>>>> However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
>>>>> then to virtual.aiai.ed.ac.uk:8002:openvue
>>>>>
>>>>> Then I can teleport home.
>>>>>
>>>>> I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
>>>>> displayed, but I can move it around and even teleport within my grid.
>>>>> the sim I teleported too isnt displayed, but all other sims in my
>>>>> metagrid are.
>>>>> No prims rezz however.
>>>>> Seems the client missed some messages to build up the scene
>>>>> _______________________________________________
>>>>> Opensim-users mailing list
>>>>> [hidden email]
>>>>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>>>>            
>>>> _______________________________________________
>>>> Opensim-users mailing list
>>>> [hidden email]
>>>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>>>          
>>> ________________________________
>>> Get a new e-mail account with Hotmail - Free. Sign-up now.
>>> _______________________________________________
>>> Opensim-users mailing list
>>> [hidden email]
>>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>>        
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>      
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>    

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Hypergrid 1.5 jumps over 6K reproducible

Jeroen van Veen
i thought it would have been fixed in snowglobe/sl viewer 2, because it uses  
maps with potentially bigger ranges(the s3 map), but same problem there. Maybe
ask the imprudence people for a fix :-)

Jeroen

On Wednesday 30 June 2010 11:21:25 Diva Canto wrote:

> Clarification:
>
> The 4096-limit bug has nothing to do with the Hypergrid. You bump into
> this same limitation by having two regions on the same grid that are
> separated by more than 4096 map cells in either axis. So, for testing if
> viewers have fixed this or not, simply have two regions, one at
> 1000,1000 and the other at, say 7000,7000. If you can TP between the 2,
> and things look normal upon arrival, then the bug is fixed in that
> viewer. Let me know when that happens.
>
> The reason why this bug got highlighted in HG TPs is that in the HG
> people don't have any control over the absolute coordinates where other
> grids place the regions; specifically, OSGrid is placed around 10,000
> whereas standalones, by default, are placed around 1000.(Whereas within
> one grid operators usually place the regions very close, and those long
> jumps simply don't exist.) In order to avoid a series of issue reports
> of the kind "TPs not working in HG -- nothing rezzes upon arrival", I
> added that check to prevent those long jumps in HG TPs.
>
> As soon as someone confirms that viewers have fixed this, I will remove
> the check in HG TPs.
>
> On 6/30/2010 12:25 AM, Jeroen van Veen wrote:
> > That's good news. How about teleporting locally to really large 100K+
> > regions? This always returns "Region doesn't exist anymore'. It works
> > normally when logging in to the region.
> >
> > kind regards,
> >
> > Jeroen
> >
> > On Wednesday 30 June 2010 07:49:15 Dolma Dollinger wrote:
> >> Well I solved one problem but got another.
> >> The Imprudence Developers withdrew the patch
> >> https://jira.secondlife.com/browse/SVC-2941 in Imprudence 1.3.0,
> >> because that solves a problem with prims only partly rezzing an a
> >> Hypergrid jump (http://redmine.imprudenceviewer.org/issues/239)
> >> Imprudence 1.2.2 still had the patch.
> >> So I used imprudence 1.2.2. And that worked! I teleported back over 6K
> >> to my home grid, arrived at a normal spot with normal camera
> >> orientation.
> >> Only on every Hypergrid Teleport I had the partly rezzing problem.
> >> So it seems to me we can be close to a working long range Hypergrid
> >> Teleport
> >>
> >> On Tue, Jun 29, 2010 at 4:55 PM, Bob Wellman<[hidden email]>
> >
> > wrote:
> >>> Diva
> >>>
> >>> What we seem to have, with this 4096 jump issue, is an impasse. Some
> >>> viewers actually put possible a fix into thier code for this some time
> >>> ago, but were unable to test it because of the server side constraint.
> >>> The server constraint wont be removed until at least one viewer has it
> >>> working. So no testing/progress is possible.
> >>>
> >>> Could I suggest that an opensim.ini setting be added so this constraint
> >>> can be varied for viewer testing purposes. Something like below would
> >>> seem good to me.
> >>>
> >>> JumpDistanceLimit = 4096
> >>>
> >>> This would allow most grid operators to keep their grids safe, whilst
> >>> also allowing others to test viewer jump distance fixes.
> >>>
> >>> PS. Its hard to find 2 regions that far apart in SL (easy in OS) so
> >>> testing must happen in OS I think.
> >>>
> >>>> Date: Tue, 29 Jun 2010 04:45:31 -0700
> >>>> From: [hidden email]
> >>>> To: [hidden email]
> >>>> Subject: Re: [Opensim-users] Hypergrid 1.5 jumps over 6K reproducible
> >>>>
> >>>> Dolma,
> >>>>
> >>>> What you are describing is exactly the situation of the 4096 bug. We
> >>>> could always teleport; things just don't rez and the viewer generally
> >>>> seems confused. It looks like it hasn't been fixed in that viewer.
> >>>> https://jira.secondlife.com/browse/SVC-2941
> >>>>
> >>>> I'm leaving the constraint in the code until at least one viewer fixes
> >>>> this.
> >>>>
> >>>> Crista
> >>>>
> >>>> On 6/28/2010 8:48 PM, Dolma Dollinger wrote:
> >>>>> I cant hyperjump directly to Openvue directly (from 7000,7000 to
> >>>>> 1000,1000)
> >>>>>
> >>>>> In Hypergridlinker.cs there is a snippet of code that checks for it
> >>>>>
> >>>>> if (!Check4096(handle, out x, out y))
> >>>>> {
> >>>>> RemoveHyperlinkRegion(regInfo.RegionID);
> >>>>> reason = "Region is too far (" + x + ", " + y + ")";
> >>>>> m_log.Info("[HYPERGRID LINKER]: Unable to link, region
> >>>>> is too far (" + x + ", " + y + ")");
> >>>>> return false;
> >>>>> }
> >>>>>
> >>>>>
> >>>>> However I can hyperjump to dev.germangrid.de:8002 (at 4000,4000) and
> >>>>> then to virtual.aiai.ed.ac.uk:8002:openvue
> >>>>>
> >>>>> Then I can teleport home.
> >>>>>
> >>>>> I arrive with my camera fixed and centered at (0,0,0), My avatar isnt
> >>>>> displayed, but I can move it around and even teleport within my grid.
> >>>>> the sim I teleported too isnt displayed, but all other sims in my
> >>>>> metagrid are.
> >>>>> No prims rezz however.
> >>>>> Seems the client missed some messages to build up the scene
> >>>>> _______________________________________________
> >>>>> Opensim-users mailing list
> >>>>> [hidden email]
> >>>>> https://lists.berlios.de/mailman/listinfo/opensim-users
> >>>>
> >>>> _______________________________________________
> >>>> Opensim-users mailing list
> >>>> [hidden email]
> >>>> https://lists.berlios.de/mailman/listinfo/opensim-users
> >>>
> >>> ________________________________
> >>> Get a new e-mail account with Hotmail - Free. Sign-up now.
> >>> _______________________________________________
> >>> Opensim-users mailing list
> >>> [hidden email]
> >>> https://lists.berlios.de/mailman/listinfo/opensim-users
> >>
> >> _______________________________________________
> >> Opensim-users mailing list
> >> [hidden email]
> >> https://lists.berlios.de/mailman/listinfo/opensim-users
> >
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > https://lists.berlios.de/mailman/listinfo/opensim-users
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users