Installing OpenSim on Ubuntu 9.04

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing OpenSim on Ubuntu 9.04

Robert Klein
Hey Everyone, I installed 0.6.4 on Ubuntu 9.04 and everything compiled with no errors. Getting NHibernate errors and the server crashes when running in standalone mode and SQLite. Everything is fine on Ubuntu 8.10. Anyone successfully running on Jaunty?

Thanks,

-Robert
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

John Sheridan
Robert,
  Just a hunch but did you upgrade to the latest version of Mono?  I'm
running Jaunty on my grid and as of about a month or so ago I had to
remove the default mono and compile / install 2.4 from source.  There's
some info on how to do this both here:
http://www.centriment.com/2009/04/01/building-mono-24-from-source-on-ubuntu-810/ 
and here: http://osgrid.org/forums/viewtopic.php?f=14&t=539 .

Hope this helps! :)

 - John Sheridan


Robert Klein wrote:
> Hey Everyone, I installed 0.6.4 on Ubuntu 9.04 and everything compiled with
> no errors. Getting NHibernate errors and the server crashes when running in
> standalone mode and SQLite. Everything is fine on Ubuntu 8.10. Anyone
> successfully running on Jaunty?
>
> Thanks,
>
> -Robert
>  

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

Dave Coyle
In reply to this post by Robert Klein
On 2009-06-25 14:17:33 -0400, [hidden email] wrote:
> Hey Everyone, I installed 0.6.4 on Ubuntu 9.04 and everything
> compiled with no errors. Getting NHibernate errors and the server
> crashes when running in standalone mode and SQLite. Everything is
> fine on Ubuntu 8.10. Anyone successfully running on Jaunty?

I've run a number of revisions/releases on Jaunty, but don't recall if
I've done so with 0.6.4 specifically.  Can you cut-and-paste the
error(s) from your log and/or console?

-coyled
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

Dave Coyle
In reply to this post by John Sheridan
On 2009-06-25 17:06:58 -0400, [hidden email] wrote:
>   Just a hunch but did you upgrade to the latest version of Mono?  I'm
> running Jaunty on my grid and as of about a month or so ago I had to
> remove the default mono and compile / install 2.4 from source.

I compiled OpenSim head on Jaunty with the stock Mono 2.0.1 packages
just this morning...  perhaps you're thinking of Mono 1.9.1 in
Intrepid which can no longer build OpenSim as of a month or so ago?

FWIW you can also install the Mono 2.4 .debs from Debian sid on
Jaunty.  I did it by hand with dpkg; dunno if there's an easier/faster
way.

/me slaps himself for not writing up a doc on how to do that.

-coyled
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

Robert Klein
I am using the stock 2.0.1 Mono packages. Here is the last entries from the log file:

2009-06-25 22:01:50,807 INFO  - OpenSim.OpenSimBase [MODULES]: Loading Region's modules
2009-06-25 22:01:51,541 ERROR - OpenSim.Region.Framework.ModuleLoader [MODULES]: Could not load types for [NHibernate, Versio
n=2.0.1.4000, Culture=neutral, PublicKeyToken=aa95f207798dfdb4].  Exception System.Reflection.ReflectionTypeLoadException: Th
e classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String dllName) [0x00000]
2009-06-25 22:01:51,547 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String dllName) [0x00000]

Application is terminating: True

-Robert

Dave Coyle wrote
On 2009-06-25 17:06:58 -0400, john@pseudospace.net wrote:
>   Just a hunch but did you upgrade to the latest version of Mono?  I'm
> running Jaunty on my grid and as of about a month or so ago I had to
> remove the default mono and compile / install 2.4 from source.

I compiled OpenSim head on Jaunty with the stock Mono 2.0.1 packages
just this morning...  perhaps you're thinking of Mono 1.9.1 in
Intrepid which can no longer build OpenSim as of a month or so ago?

FWIW you can also install the Mono 2.4 .debs from Debian sid on
Jaunty.  I did it by hand with dpkg; dunno if there's an easier/faster
way.

/me slaps himself for not writing up a doc on how to do that.

-coyled
_______________________________________________
Opensim-users mailing list
Opensim-users@lists.berlios.de
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

Mikko Pallari
Have you installed all the required dependencies mentioned here: http://opensimulator.org/wiki/Dependencies

I'm currently running Ubuntu 9.04 with stock mono without any errors.

Cheers,
Mikko

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Robert Klein
Sent: 26. kesäkuuta 2009 6:07
To: [hidden email]
Subject: Re: [Opensim-users] Installing OpenSim on Ubuntu 9.04


I am using the stock 2.0.1 Mono packages. Here is the last entries from the
log file:

2009-06-25 22:01:50,807 INFO  - OpenSim.OpenSimBase [MODULES]: Loading
Region's modules
2009-06-25 22:01:51,541 ERROR - OpenSim.Region.Framework.ModuleLoader
[MODULES]: Could not load types for [NHibernate, Versio
n=2.0.1.4000, Culture=neutral, PublicKeyToken=aa95f207798dfdb4].  Exception
System.Reflection.ReflectionTypeLoadException: Th
e classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String
dllName) [0x00000]
2009-06-25 22:01:51,547 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.Reflection.ReflectionTypeLoadException: The classes in the
module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.Strrm ing
dllName) [0x00000]

Application is terminating: True

-Robert


Dave Coyle wrote:

>
> On 2009-06-25 17:06:58 -0400, [hidden email] wrote:
>>   Just a hunch but did you upgrade to the latest version of Mono?  I'm
>> running Jaunty on my grid and as of about a month or so ago I had to
>> remove the default mono and compile / install 2.4 from source.
>
> I compiled OpenSim head on Jaunty with the stock Mono 2.0.1 packages
> just this morning...  perhaps you're thinking of Mono 1.9.1 in
> Intrepid which can no longer build OpenSim as of a month or so ago?
>
> FWIW you can also install the Mono 2.4 .debs from Debian sid on
> Jaunty.  I did it by hand with dpkg; dunno if there's an easier/faster
> way.
>
> /me slaps himself for not writing up a doc on how to do that.
>
> -coyled
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>

--
View this message in context: http://n2.nabble.com/Installing-OpenSim-on-Ubuntu-9.04-tp3156777p3159384.html
Sent from the opensim-users mailing list archive at Nabble.com.

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

Robert Klein
Well that fixed it! I guess some dependencies were missing, not sure how, but I am happy to be running again. Scripts seem to be acting a little strange right now, will have to debug when I get some time. I basically saved my regions as oars from my Ubuntu 8.10 setup and loaded them into the new one. Thanks Mikko and everyone else for wanting to help solve this!!

-Robert

Mikko Pallari wrote
Have you installed all the required dependencies mentioned here: http://opensimulator.org/wiki/Dependencies

I'm currently running Ubuntu 9.04 with stock mono without any errors.

Cheers,
Mikko
Reply | Threaded
Open this post in threaded view
|

Re: Installing OpenSim on Ubuntu 9.04

M.E. Verhagen
To get all the dependacies in on ubuntu use the repo on the wiki:

http://opensimulator.org/wiki/UnofficialDebPackages

When you want to compile opensim your selve use should enable the source repo so all the dependacies for compiling are installed.




2009/6/26 Robert Klein <[hidden email]>

Well that fixed it! I guess some dependencies were missing, not sure how, but
I am happy to be running again. Scripts seem to be acting a little strange
right now, will have to debug when I get some time. I basically saved my
regions as oars from my Ubuntu 8.10 setup and loaded them into the new one.
Thanks Mikko and everyone else for wanting to help solve this!!

-Robert


Mikko Pallari wrote:
>
> Have you installed all the required dependencies mentioned here:
> http://opensimulator.org/wiki/Dependencies
>
> I'm currently running Ubuntu 9.04 with stock mono without any errors.
>
> Cheers,
> Mikko
>
>
>

--
View this message in context: http://n2.nabble.com/Installing-OpenSim-on-Ubuntu-9.04-tp3156777p3163845.html
Sent from the opensim-users mailing list archive at Nabble.com.

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users