Inventory Woes: Region Server ignoring repeated requests for inventory.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Inventory Woes: Region Server ignoring repeated requests for inventory.

Timmy.Stewart
Random users will not have access to their inventory. When logging into the region effected the inventory sometime has folders but items never load. The region server responds with either can not fint root folder for that user or ignoring repeated requests. When the user moves to a region that is not being effected their inventory will load and they can rez objects from it, when returning to the effected region the inventory is there but cannot use it and Recieving the error in the region server that it cannot find root folder for that user. While one person may experience this in a region anouther user in that region may have use of inventory. This gererally happens to a user when they log to a region, the region server sends a request to the inventory server the inventory server responds and the region server dose not receive that response and times out, this takes but a matter of seconds for the timeout. Once this happens that region is tainted for that user as far as inventory goes. Sometimes, if I reset the region the problem goes away for that user and they have use of their inventory in that region. This does not happen to all users and all regions and may not happen but once to one user while other users multiple times. If this was persistent with all users and a particular region I would assume it was a communication problem due to a bad ini setting, but since this is random it has me puzzled to what the cause of this problem is. The closest problem i could find in the mantis on this is issue 0000151 but to different from this problem to cluster with it. Things that may be factors? Happens to those that use Second Inventory to upload items with, and to those using Merkat to upload items. I am not sure if this has happened to users that do not use these programs. Effected users generally have inventories above 4000 items and appears that those with more items it effect more frequent, although it could also be that these people are on the grid more frequent increasing the chances of probability it will happen to them  lol :)
It seams to me that the region server or simulator is timeing out to quickly when waiting for a response from the inventory server and/or it just doesnt receive that response for some reason, therefore it is waiting for an original response that it will never get because it was already sent, and in turn ignores all responses for inventory for that agent, until the simulator is reset. I have also noticed the larger the users inventory the more frequent it will happen to them. If this is the problem then we need a way to allow for duplicate inquirys or a timer that will reset the get inventory routine.
 
Passing this along to everyone on the OSU list in hopes of finding an answer to this problem.
I have made a Mantis report of this, it is number 0004164 LINK> http://opensimulator.org/mantis/view.php?id=4164

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users