Megaregions and normal regions together

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

Megaregions and normal regions together

Jessica Pixel
I currently have a 4 sim megaregion set-up using D2.  I would like to add a single, normal region sandbox.  I added the appropriate info to /bin/Regions/RegionConfig.ini and the region shows up when I teleport to it, but I'm stuck at <0,0,21> and don't seem to be able to move from that spot (other than flying straight up).  If I fly or run as hard as I can, or right-click the ground and choose 'Sit here', I can get a few meters out, but eventually I get pushed back to <0,0,21>.

Right-clicking the ground and choosing 'Go here' gives an error in the console (typo included!):
13:46:54 - [LLCLIENTVIEW]: Exeception when handling generic message Region with id 3618823b-86de-4e16-9c23-8b86160826fc not found at OpenSim.Region.RegionCombinerModule.RegionCombinerModule.GetSizeOfMegaregion(UUID regionId)

Is it not possible to have both megaregions and normal regions?  The error makes it sound like it's attempting to treat this single region like a megaregion and failing.  Is there some work around?

-----

If anyone is curious, here's what else happened to me while I was testing this out.  I attempted to teleport home using ctrl+shift+h and was plummeted into the depths of the ocean with the following console messages:

13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel aaa658c2-6fd2-4845-a251-e893703fd80a home
13:51:23 - [HG ENTITY TRANSFER MODULE]: User is local
13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel aaa658c2-6fd2-4845-a251-e893703fd80a home
13:51:23 - [ENTITY TRANSFER MODULE]: Home region of Jessica Pixel is PixelPlanetSW (7662-7557)
13:51:23 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to <937601.2, 910710.6, 41.49851> within Sandbox
13:51:23 - [ENTITY TRANSFER STATE MACHINE]: Agent aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox

Now, I'm currently sinking into the ocean at about -100 meters a second!  I tried to fly after I reached around <0,0,-5000> and I was teleported to <0,0,4>, still within the sandbox region with this console message:

13:55:02 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to <-0.0625, -0.0625, 6.688429E+09> within Sandbox
13:55:02 - [ENTITY TRANSFER STATE MACHINE]: Agent aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox

That's a really big number!  From there, I could fly up until I popped up from under the ground, but I still can't move forward.  I opened my map and typed in the name of my root region, and was still sent to the bottom of the ocean.  I logged out of my viewer and logged back in to my home and I was delivered there, but without avatar textures (attachments were fine and textured).  However, the other three regions in the megaregion had no terrain, just ocean and lots of objects hovering above the water.

So, I logged out, shutdown OpenSim and removed the sandbox region info from RegionConfig.ini.  After starting OpenSim back up, everything was back to normal.
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

James Hughes
On 06/18/2013 09:43 PM, Jessica Pixel wrote:

> I currently have a 4 sim megaregion set-up using D2.  I would like to add a
> single, normal region sandbox.  I added the appropriate info to
> /bin/Regions/RegionConfig.ini and the region shows up when I teleport to it,
> but I'm stuck at<0,0,21>  and don't seem to be able to move from that spot
> (other than flying straight up).  If I fly or run as hard as I can, or
> right-click the ground and choose 'Sit here', I can get a few meters out,
> but eventually I get pushed back to<0,0,21>.
>
> Right-clicking the ground and choosing 'Go here' gives an error in the
> console (typo included!):
> 13:46:54 - [LLCLIENTVIEW]: Exeception when handling generic message Region
> with id 3618823b-86de-4e16-9c23-8b86160826fc not found at
> OpenSim.Region.RegionCombinerModule.RegionCombinerModule.GetSizeOfMegaregion(UUID
> regionId)
>
> Is it not possible to have both megaregions and normal regions?  The error
> makes it sound like it's attempting to treat this single region like a
> megaregion and failing.  Is there some work around?
>
> -----
>
> If anyone is curious, here's what else happened to me while I was testing
> this out.  I attempted to teleport home using ctrl+shift+h and was plummeted
> into the depths of the ocean with the following console messages:
>
> 13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel
> aaa658c2-6fd2-4845-a251-e893703fd80a home
> 13:51:23 - [HG ENTITY TRANSFER MODULE]: User is local
> 13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel
> aaa658c2-6fd2-4845-a251-e893703fd80a home
> 13:51:23 - [ENTITY TRANSFER MODULE]: Home region of Jessica Pixel is
> PixelPlanetSW (7662-7557)
> 13:51:23 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to
> <937601.2, 910710.6, 41.49851>  within Sandbox
> 13:51:23 - [ENTITY TRANSFER STATE MACHINE]: Agent
> aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox
>
> Now, I'm currently sinking into the ocean at about -100 meters a second!  I
> tried to fly after I reached around<0,0,-5000>  and I was teleported to
> <0,0,4>, still within the sandbox region with this console message:
>
> 13:55:02 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to<-0.0625,
> -0.0625, 6.688429E+09>  within Sandbox
> 13:55:02 - [ENTITY TRANSFER STATE MACHINE]: Agent
> aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox
>
> That's a really big number!  From there, I could fly up until I popped up
> from under the ground, but I still can't move forward.  I opened my map and
> typed in the name of my root region, and was still sent to the bottom of the
> ocean.  I logged out of my viewer and logged back in to my home and I was
> delivered there, but without avatar textures (attachments were fine and
> textured).  However, the other three regions in the megaregion had no
> terrain, just ocean and lots of objects hovering above the water.
>
> So, I logged out, shutdown OpenSim and removed the sandbox region info from
> RegionConfig.ini.  After starting OpenSim back up, everything was back to
> normal.
>
>
>

You will need to attach the SW corner region of the Mega to your normal
region.

-BlueWall
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Melanie
As far as I know, you can't do that. To get mega and normal regions
you will need to set up a grid (Robust) server and run the megas in
one process and the singles in another process.

Melanie

On 19/06/2013 11:24, James Hughes wrote:

> On 06/18/2013 09:43 PM, Jessica Pixel wrote:
>> I currently have a 4 sim megaregion set-up using D2.  I would like to add a
>> single, normal region sandbox.  I added the appropriate info to
>> /bin/Regions/RegionConfig.ini and the region shows up when I teleport to it,
>> but I'm stuck at<0,0,21>  and don't seem to be able to move from that spot
>> (other than flying straight up).  If I fly or run as hard as I can, or
>> right-click the ground and choose 'Sit here', I can get a few meters out,
>> but eventually I get pushed back to<0,0,21>.
>>
>> Right-clicking the ground and choosing 'Go here' gives an error in the
>> console (typo included!):
>> 13:46:54 - [LLCLIENTVIEW]: Exeception when handling generic message Region
>> with id 3618823b-86de-4e16-9c23-8b86160826fc not found at
>> OpenSim.Region.RegionCombinerModule.RegionCombinerModule.GetSizeOfMegaregion(UUID
>> regionId)
>>
>> Is it not possible to have both megaregions and normal regions?  The error
>> makes it sound like it's attempting to treat this single region like a
>> megaregion and failing.  Is there some work around?
>>
>> -----
>>
>> If anyone is curious, here's what else happened to me while I was testing
>> this out.  I attempted to teleport home using ctrl+shift+h and was plummeted
>> into the depths of the ocean with the following console messages:
>>
>> 13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel
>> aaa658c2-6fd2-4845-a251-e893703fd80a home
>> 13:51:23 - [HG ENTITY TRANSFER MODULE]: User is local
>> 13:51:23 - [ENTITY TRANSFER MODULE]: Request to teleport Jessica Pixel
>> aaa658c2-6fd2-4845-a251-e893703fd80a home
>> 13:51:23 - [ENTITY TRANSFER MODULE]: Home region of Jessica Pixel is
>> PixelPlanetSW (7662-7557)
>> 13:51:23 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to
>> <937601.2, 910710.6, 41.49851>  within Sandbox
>> 13:51:23 - [ENTITY TRANSFER STATE MACHINE]: Agent
>> aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox
>>
>> Now, I'm currently sinking into the ocean at about -100 meters a second!  I
>> tried to fly after I reached around<0,0,-5000>  and I was teleported to
>> <0,0,4>, still within the sandbox region with this console message:
>>
>> 13:55:02 - [ENTITY TRANSFER MODULE]: Teleport for Jessica Pixel to<-0.0625,
>> -0.0625, 6.688429E+09>  within Sandbox
>> 13:55:02 - [ENTITY TRANSFER STATE MACHINE]: Agent
>> aaa658c2-6fd2-4845-a251-e893703fd80a cleared from transit in Sandbox
>>
>> That's a really big number!  From there, I could fly up until I popped up
>> from under the ground, but I still can't move forward.  I opened my map and
>> typed in the name of my root region, and was still sent to the bottom of the
>> ocean.  I logged out of my viewer and logged back in to my home and I was
>> delivered there, but without avatar textures (attachments were fine and
>> textured).  However, the other three regions in the megaregion had no
>> terrain, just ocean and lots of objects hovering above the water.
>>
>> So, I logged out, shutdown OpenSim and removed the sandbox region info from
>> RegionConfig.ini.  After starting OpenSim back up, everything was back to
>> normal.
>>
>>
>>
>
> You will need to attach the SW corner region of the Mega to your normal
> region.
>
> -BlueWall
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

James Hughes
On 06/19/2013 11:36 AM, Melanie wrote:
> As far as I know, you can't do that. To get mega and normal regions
> you will need to set up a grid (Robust) server and run the megas in
> one process and the singles in another process.
>
> Melanie
>

Yeah - I was thinking Robust/Grid when I read it.

-BlueWall
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Jessica Pixel
In reply to this post by James Hughes
I would like to have the sandbox at 4xxx,4xxx and my megaregion at 7xxx,7xxx so this wouldn't be ideal, but I could do it if I had to.  Thanks. :]
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Jessica Pixel
In reply to this post by Melanie
I was afraid this was going to be the case.  I guess it's time to learn some new things!  I eventually want to set up one megaregion and three single regions (a sandbox and two hypergates) and my current megaregion is already running in grid mode, so hopefully it won't be too hard to figure out how to run another opensim instance.

Thanks for the info!
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

R.Gunther
You say megaregion is running in grid mode.
The term grid is many times wrong used. Are you useing diva ?
Otherwise without robust , there's not a grid but standalone region
(with HG optional)

On 2013-06-20 00:13, Jessica Pixel wrote:

> I was afraid this was going to be the case.  I guess it's time to learn some
> new things!  I eventually want to set up one megaregion and three single
> regions (a sandbox and two hypergates) and my current megaregion is already
> running in grid mode, so hopefully it won't be too hard to figure out how to
> run another opensim instance.
>
> Thanks for the info!
>
>
>
> -----
> -*-*-*-
> Jessica Pixel
> http://liftedpixel.net/pixelplanet
> --
> View this message in context: http://opensim-users.2152040.n2.nabble.com/Megaregions-and-normal-regions-together-tp7580156p7580161.html
> Sent from the opensim-users mailing list archive at Nabble.com.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Jessica Pixel
This post was updated on .
I am using the diva distro, so maybe I'm not running in grid mode, but standalone with HG enabled?  I'm still pretty new at this, so I'm not 100% clear on all of the different setups.  How can I know for sure?

If I understand correctly, I should be able to set up a second instance of OpenSim, and give it the same details for the database and whatnot as the first instance?  Everything is running from the same computer.

Edit: I started digging around the wiki some and got to here
http://opensimulator.org/wiki/Configuration#Standalone_vs._Grid

It looks like I was thinking the wrong thing, but it shouldn't be too hard to get grid mode running.
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Melanie
No. You need to set up a ROBUST server and run the instances as grid
clients. You can still do all of this on a single machine.

On 20/06/2013 20:20, Jessica Pixel wrote:

> I am using the diva distro, so maybe I'm not running in grid mode, but
> standalone with HG enabled?  I'm still pretty new at this, so I'm not 100%
> clear on all of the different setups.  How can I know for sure?
>
> If I understand correctly, I should be able to set up a second instance of
> OpenSim, and give it the same details for the database and whatnot as the
> first instance?  Everything is running from the same computer.
>
>
>
> -----
> -*-*-*-
> Jessica Pixel
> http://liftedpixel.net/pixelplanet
> --
> View this message in context: http://opensim-users.2152040.n2.nabble.com/Megaregions-and-normal-regions-together-tp7580156p7580163.html
> Sent from the opensim-users mailing list archive at Nabble.com.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Fleep Tuque
In reply to this post by Jessica Pixel
I don't run Diva Distro, so I don't know if that can be run in grid (ROBUST) mode?  

If not, then you'll need to go to http://opensimulator.org/wiki/Download and download the latest version of opensim and follow the instructions at http://opensimulator.org/wiki/Configuration#Running_OpenSimulator_in_Grid_mode.  That page also has some nice diagrams explaining the difference between standalone and grid mode.  I could be mistaken, but I think Diva Distro can only be run in standalone mode.. ?

Though I should say, before doing ANYTHING, make sure you take a good backup of your database, and I personally take OAR snapshots of all of my regions before I upgrade or test any new configuration.

Regarding "instances", I found it very confusing at first when people talked about running simulators in different instances, I didn't understand what that meant.  Essentially, you copy all your opensim files into another directory, edit your regions.ini file in the new directory to only include the regions to run on that "instance" (and of course edit your old regions.ini file to remove the regions you're going to run on the new instance), and then start the opensim.exe process in both the old and the new directory.  So for FleepGrid, as an example, my file structure looks like this:

-opensim_0.7.4
  - addon-modules
  - bin
  - doc
  - share
  - ThirdParty
  - ThirdPartyLicenses
  - WifiPages
-opensim2_0.7.4
-opensim3_0.7.4
-opensim4_0.7.4
-opensim5_0.7.4

In each of those directories, in the /bin/regions.ini file, I have one region listed for that "instance", and then to start up the grid, I first start ROBUST, then start the opensim.exe process in each of those directories.  Does that make sense?

Feel free to ask more questions on the list, and if it's any help, I keep a change log for FleepGrid with all the details and example ini files etc. on my wiki at:  http://fleep.wikispaces.com/FleepGrid.

Good luck!

- Chris/Fleep



Chris M. Collins (Avatar: Fleep Tuque)
Center for Simulations & Virtual Environments Research (UCSIM)
UCIT Instructional & Research Computing
University of Cincinnati
406A Zimmer Hall
315 College Drive
PO BOX 210088
Cincinnati, OH 45221-0088
(513) 556-3018


On Thu, Jun 20, 2013 at 2:20 PM, Jessica Pixel <[hidden email]> wrote:
I am using the diva distro, so maybe I'm not running in grid mode, but
standalone with HG enabled?  I'm still pretty new at this, so I'm not 100%
clear on all of the different setups.  How can I know for sure?

If I understand correctly, I should be able to set up a second instance of
OpenSim, and give it the same details for the database and whatnot as the
first instance?  Everything is running from the same computer.



-----
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
--
View this message in context: http://opensim-users.2152040.n2.nabble.com/Megaregions-and-normal-regions-together-tp7580156p7580163.html
Sent from the opensim-users mailing list archive at Nabble.com.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Jessica Pixel
Running more than one instance of OpenSim makes sense to me.  I'll just have one instance for the megaregion and one for the three single regions that are both pointing to the same ROBUST server.  I already do nightly MySQL dumps and have a console script written to easily export my regions and inventory in case there's a database problem.

Looks like I have a weekend project on my hands!  Thanks for all your help. I'll be sure to ask if I have any questions. :]
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

M.E. Verhagen
In reply to this post by Fleep Tuque
you don't need to make copies of the entire opensim dirs to run different instances.

I make a copy of opensim.ini with a different name and give it the location of the region xml files to use in that file.
And fire up an instance of opensim like this:

screen -S Zee -d -m mono ./OpenSim.exe -inifile=OpenSimZee.ini

wich is a 3x3 megaregion wich runs nice along other opensim instances wich are not megaregions.



2013/6/21 Fleep Tuque <[hidden email]>
I don't run Diva Distro, so I don't know if that can be run in grid (ROBUST) mode?  

If not, then you'll need to go to http://opensimulator.org/wiki/Download and download the latest version of opensim and follow the instructions at http://opensimulator.org/wiki/Configuration#Running_OpenSimulator_in_Grid_mode.  That page also has some nice diagrams explaining the difference between standalone and grid mode.  I could be mistaken, but I think Diva Distro can only be run in standalone mode.. ?

Though I should say, before doing ANYTHING, make sure you take a good backup of your database, and I personally take OAR snapshots of all of my regions before I upgrade or test any new configuration.

Regarding "instances", I found it very confusing at first when people talked about running simulators in different instances, I didn't understand what that meant.  Essentially, you copy all your opensim files into another directory, edit your regions.ini file in the new directory to only include the regions to run on that "instance" (and of course edit your old regions.ini file to remove the regions you're going to run on the new instance), and then start the opensim.exe process in both the old and the new directory.  So for FleepGrid, as an example, my file structure looks like this:

-opensim_0.7.4
  - addon-modules
  - bin
  - doc
  - share
  - ThirdParty
  - ThirdPartyLicenses
  - WifiPages
-opensim2_0.7.4
-opensim3_0.7.4
-opensim4_0.7.4
-opensim5_0.7.4

In each of those directories, in the /bin/regions.ini file, I have one region listed for that "instance", and then to start up the grid, I first start ROBUST, then start the opensim.exe process in each of those directories.  Does that make sense?

Feel free to ask more questions on the list, and if it's any help, I keep a change log for FleepGrid with all the details and example ini files etc. on my wiki at:  http://fleep.wikispaces.com/FleepGrid.

Good luck!

- Chris/Fleep



Chris M. Collins (Avatar: Fleep Tuque)
Center for Simulations & Virtual Environments Research (UCSIM)
UCIT Instructional & Research Computing
University of Cincinnati
406A Zimmer Hall
315 College Drive
PO BOX 210088
Cincinnati, OH 45221-0088
<a href="tel:%28513%29%20556-3018" value="+15135563018" target="_blank">(513) 556-3018


On Thu, Jun 20, 2013 at 2:20 PM, Jessica Pixel <[hidden email]> wrote:
I am using the diva distro, so maybe I'm not running in grid mode, but
standalone with HG enabled?  I'm still pretty new at this, so I'm not 100%
clear on all of the different setups.  How can I know for sure?

If I understand correctly, I should be able to set up a second instance of
OpenSim, and give it the same details for the database and whatnot as the
first instance?  Everything is running from the same computer.



-----
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
--
View this message in context: http://opensim-users.2152040.n2.nabble.com/Megaregions-and-normal-regions-together-tp7580156p7580163.html
Sent from the opensim-users mailing list archive at Nabble.com.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



--
Groningen en Hannover Opensims:   secondlife://meverhagen.nl:8002:Hannover ZW/ 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Megaregions and normal regions together

Fleep Tuque
I remember someone else saying that you don't need to copy all the files for a new instance, but I don't think I ever saw a definitive list of what does need to be included, so I've defaulted to just copying everything.  Does anyone have a reference or know for sure which files are required?  

- Chris/Fleep


Chris M. Collins (Avatar: Fleep Tuque)
Center for Simulations & Virtual Environments Research (UCSIM)
UCIT Instructional & Research Computing
University of Cincinnati
406A Zimmer Hall
315 College Drive
PO BOX 210088
Cincinnati, OH 45221-0088
(513) 556-3018

http://ucsim.uc.edu 

On Fri, Jun 21, 2013 at 4:14 AM, M.E. Verhagen <[hidden email]> wrote:
you don't need to make copies of the entire opensim dirs to run different instances.

I make a copy of opensim.ini with a different name and give it the location of the region xml files to use in that file.
And fire up an instance of opensim like this:

screen -S Zee -d -m mono ./OpenSim.exe -inifile=OpenSimZee.ini

wich is a 3x3 megaregion wich runs nice along other opensim instances wich are not megaregions.



2013/6/21 Fleep Tuque <[hidden email]>
I don't run Diva Distro, so I don't know if that can be run in grid (ROBUST) mode?  

If not, then you'll need to go to http://opensimulator.org/wiki/Download and download the latest version of opensim and follow the instructions at http://opensimulator.org/wiki/Configuration#Running_OpenSimulator_in_Grid_mode.  That page also has some nice diagrams explaining the difference between standalone and grid mode.  I could be mistaken, but I think Diva Distro can only be run in standalone mode.. ?

Though I should say, before doing ANYTHING, make sure you take a good backup of your database, and I personally take OAR snapshots of all of my regions before I upgrade or test any new configuration.

Regarding "instances", I found it very confusing at first when people talked about running simulators in different instances, I didn't understand what that meant.  Essentially, you copy all your opensim files into another directory, edit your regions.ini file in the new directory to only include the regions to run on that "instance" (and of course edit your old regions.ini file to remove the regions you're going to run on the new instance), and then start the opensim.exe process in both the old and the new directory.  So for FleepGrid, as an example, my file structure looks like this:

-opensim_0.7.4
  - addon-modules
  - bin
  - doc
  - share
  - ThirdParty
  - ThirdPartyLicenses
  - WifiPages
-opensim2_0.7.4
-opensim3_0.7.4
-opensim4_0.7.4
-opensim5_0.7.4

In each of those directories, in the /bin/regions.ini file, I have one region listed for that "instance", and then to start up the grid, I first start ROBUST, then start the opensim.exe process in each of those directories.  Does that make sense?

Feel free to ask more questions on the list, and if it's any help, I keep a change log for FleepGrid with all the details and example ini files etc. on my wiki at:  http://fleep.wikispaces.com/FleepGrid.

Good luck!

- Chris/Fleep



Chris M. Collins (Avatar: Fleep Tuque)
Center for Simulations & Virtual Environments Research (UCSIM)
UCIT Instructional & Research Computing
University of Cincinnati
406A Zimmer Hall
315 College Drive
PO BOX 210088
Cincinnati, OH 45221-0088
<a href="tel:%28513%29%20556-3018" value="+15135563018" target="_blank">(513) 556-3018


On Thu, Jun 20, 2013 at 2:20 PM, Jessica Pixel <[hidden email]> wrote:
I am using the diva distro, so maybe I'm not running in grid mode, but
standalone with HG enabled?  I'm still pretty new at this, so I'm not 100%
clear on all of the different setups.  How can I know for sure?

If I understand correctly, I should be able to set up a second instance of
OpenSim, and give it the same details for the database and whatnot as the
first instance?  Everything is running from the same computer.



-----
-*-*-*-
Jessica Pixel
http://liftedpixel.net/pixelplanet
--
View this message in context: http://opensim-users.2152040.n2.nabble.com/Megaregions-and-normal-regions-together-tp7580156p7580163.html
Sent from the opensim-users mailing list archive at Nabble.com.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



--
Groningen en Hannover Opensims:   secondlife://meverhagen.nl:8002:Hannover ZW/ 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users