Need help with a serious LAG problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Need help with a serious LAG problem

Seth Nygard
This is a known problem, and one that has been previously reported.  See the following Mantis bug report;  http://opensimulator.org/mantis/view.php?id=7393

I invite you to add your experiences to the Mantis report, and ideally if you can collect any data and provide it back to the devs it could be a big help in identifying what specifically is going on.  The more data that shows what is happening the better chance they have of finding the cause.

I have seen this issue happen when users visit a sim, and they have poor network connections, such as those using satellite or tethered cell phones.  We have also seen this with some visitors from university dorms where there appears to be throttling on their end, as well as others to varying degrees.  I have been monitoring this long enough I know of several visitors that when they arrive I know problems are likely to follow soon.

As you have seen, this problem seems grow worse as the number of avis in the region increases.  For a while things will be ok, but if you have console access and monitor the throttles that is generally one of the early indicators that problems may arise.  If things clear up quick enough the sim will recover with little to no visible impact in the region.  However once things go on past a certain point, then you will see SimFPS and time dilation affected, this is then when chat lag and movement within the region are affected for everyone.  If the problems are bad enough then threads get stalled and you sill see a large number of avis get kicked out at the same time due to timeouts.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Need help with a serious LAG problem

tringate
Seth,
I read your mantis and made a comment in it.  I will do some more looking now that I understand the problem and make sure my issue is indeed the same thing.
 
For some reason removing my domain name and using my IP address in it’s place on one server appears to have helped but that could be a false impression I got since things were working fairly well before I did that.
 
My experience to date is that until I reboot my servers they stay in a messed up state and lots of thing go wrong like IM’s get totally dropped, and tp’s stop working even between regions on the same server with messages saying they can not establish a connection.  Oddly enough I can usually tp to LBSA and often then get to the failed region.  If I reboot everything, then it is back to normal until this happens again.
 
Sometimes I find the regions already like this when I log on.
 
Tom
 
 
Sent: Tuesday, March 17, 2015 10:20 PM
Subject: [Opensim-users] Need help with a serious LAG problem
 
This is a known problem, and one that has been previously reported.  See the following Mantis bug report;  http://opensimulator.org/mantis/view.php?id=7393
 
I invite you to add your experiences to the Mantis report, and ideally if you can collect any data and provide it back to the devs it could be a big help in identifying what specifically is going on.  The more data that shows what is happening the better chance they have of finding the cause.

I have seen this issue happen when users visit a sim, and they have poor network connections, such as those using satellite or tethered cell phones.  We have also seen this with some visitors from university dorms where there appears to be throttling on their end, as well as others to varying degrees.  I have been monitoring this long enough I know of several visitors that when they arrive I know problems are likely to follow soon.

As you have seen, this problem seems grow worse as the number of avis in the region increases.  For a while things will be ok, but if you have console access and monitor the throttles that is generally one of the early indicators that problems may arise.  If things clear up quick enough the sim will recover with little to no visible impact in the region.  However once things go on past a certain point, then you will see SimFPS and time dilation affected, this is then when chat lag and movement within the region are affected for everyone.  If the problems are bad enough then threads get stalled and you sill see a large number of avis get kicked out at the same time due to timeouts.


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Need help with a serious LAG problem

Dahlia Trimble
You may want to double check all of your network configurations for your regions and on your local lan and firewall to make sure nothing is sharing the same ports and IP addresses.

I've also found that sometimes some home routers are just not all that robust and an occasional reboot works wonders towards keeping things running smoothly.

On Tue, Mar 17, 2015 at 10:05 PM, Thomas Ringate <[hidden email]> wrote:
Seth,
I read your mantis and made a comment in it.  I will do some more looking now that I understand the problem and make sure my issue is indeed the same thing.
 
For some reason removing my domain name and using my IP address in it’s place on one server appears to have helped but that could be a false impression I got since things were working fairly well before I did that.
 
My experience to date is that until I reboot my servers they stay in a messed up state and lots of thing go wrong like IM’s get totally dropped, and tp’s stop working even between regions on the same server with messages saying they can not establish a connection.  Oddly enough I can usually tp to LBSA and often then get to the failed region.  If I reboot everything, then it is back to normal until this happens again.
 
Sometimes I find the regions already like this when I log on.
 
Tom
 
 
Sent: Tuesday, March 17, 2015 10:20 PM
Subject: [Opensim-users] Need help with a serious LAG problem
 
This is a known problem, and one that has been previously reported.  See the following Mantis bug report;  http://opensimulator.org/mantis/view.php?id=7393
 
I invite you to add your experiences to the Mantis report, and ideally if you can collect any data and provide it back to the devs it could be a big help in identifying what specifically is going on.  The more data that shows what is happening the better chance they have of finding the cause.

I have seen this issue happen when users visit a sim, and they have poor network connections, such as those using satellite or tethered cell phones.  We have also seen this with some visitors from university dorms where there appears to be throttling on their end, as well as others to varying degrees.  I have been monitoring this long enough I know of several visitors that when they arrive I know problems are likely to follow soon.

As you have seen, this problem seems grow worse as the number of avis in the region increases.  For a while things will be ok, but if you have console access and monitor the throttles that is generally one of the early indicators that problems may arise.  If things clear up quick enough the sim will recover with little to no visible impact in the region.  However once things go on past a certain point, then you will see SimFPS and time dilation affected, this is then when chat lag and movement within the region are affected for everyone.  If the problems are bad enough then threads get stalled and you sill see a large number of avis get kicked out at the same time due to timeouts.


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users