Offline Messages

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Offline Messages

Zane Legion
I'm trying to configure Offline Messages using OpenSimWI and I receive the following eror message when the offline user logs in and retreives messages.

I'm running in grid mode using the OpenSim 0.66 build. I've followed the instructions in http://opensimulator.org/wiki/Offline_Messaging.

The offline message seems to be stored in the database OK and it is being removed correctly when the user logs in, but the message is never delivered to the target user and the user is forcibly logged out due to the error.

Anyone know where I should look to dig a little deeper and try and work this out?

Error message:
01:50:32 - [CLIENT]: Client thread for User One 7aecf430-e476-457f-bfab-e746dd74a
213 crashed.  Logging them out.
01:50:32 - System.NullReferenceException: Object reference not set to an instanc
e of an object.
   at OpenSim.Region.CoreModules.Avatar.InstantMessage.OfflineMessageModule.Retr
ieveInstantMessages(IClientAPI client)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket(Packet P
ack)
   at OpenSim.Region.ClientStack.LindenUDP.LLPacketHandler.ProcessInPacket(LLQue
Item item)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ClientLoop()
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.RunUserSession()
Reply | Threaded
Open this post in threaded view
|

Re: Offline Messages

Zane Legion
Oh, looks like I might be running into this problem: http://opensimulator.org/mantis/view.php?id=4117
Might have to wait for the next release.

Zane Legion wrote
I'm trying to configure Offline Messages using OpenSimWI and I receive the following eror message when the offline user logs in and retreives messages.

I'm running in grid mode using the OpenSim 0.66 build. I've followed the instructions in http://opensimulator.org/wiki/Offline_Messaging.

The offline message seems to be stored in the database OK and it is being removed correctly when the user logs in, but the message is never delivered to the target user and the user is forcibly logged out due to the error.

Anyone know where I should look to dig a little deeper and try and work this out?

Error message:
01:50:32 - [CLIENT]: Client thread for User One 7aecf430-e476-457f-bfab-e746dd74a
213 crashed.  Logging them out.
01:50:32 - System.NullReferenceException: Object reference not set to an instanc
e of an object.
   at OpenSim.Region.CoreModules.Avatar.InstantMessage.OfflineMessageModule.Retr
ieveInstantMessages(IClientAPI client)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket(Packet P
ack)
   at OpenSim.Region.ClientStack.LindenUDP.LLPacketHandler.ProcessInPacket(LLQue
Item item)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ClientLoop()
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.RunUserSession()