OpenSim.ini and external email

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSim.ini and external email

Randy Pierce

I have had great success to this point to get 0.8 up and running. The only things lacking right now of high importance are: (1) an economy, and (2) external email capability for servers.

What I am currently getting for a message is: “DefaultEmailModule Exception: Could not connect to 127.0.0.1:25”

My port 25 is open on the primary computer (I am running 4 systems, with primary running robust, initial OpenSim instance, and MySQL) on TCP as well as UDP.

 

 

I have the following OpenSim.ini (extraction of the [SMTP] part and email/passwords have been removed):

 

[SMTP]

    ;; The SMTP server enabled the email module to send email to external

    ;; destinations.

 

    ;# {enabled} {[Startup]emailmodule:DefaultEmailModule} {Enable SMTP service?} {true false} false

    ;; Enable sending email via SMTP

    enabled = true

 

    ;# {internal_object_host} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Host name to treat as internal (object to object) email?} {} lsl.opensim.local

    internal_object_host = lsl.opensim.local

 

    ;# {host_domain_header_from} {[Startup]emailmodule:DefaultEmailModule enabled:true} {From address to use in the sent email header?} {} 127.0.0.1

    host_domain_header_from = "127.0.0.1"

 

    ;# {email_pause_time} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Period in seconds to delay after an email is sent.} {} 20

    email_pause_time = 20

 

    ;# {email_max_size} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Maximum total size of email in bytes.} {} 4096

    email_max_size = 4096

 

    ;# {SMTP_SERVER_HOSTNAME} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server name?} {} 127.0.0.1

 

     SMTP_SERVER_HOSTNAME = "127.0.0.1"

 

    ;# {SMTP_SERVER_PORT} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server name?} {SMTP server port?} {} 25

    SMTP_SERVER_PORT = 25

 

    ;# {SMTP_SERVER_LOGIN} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server user name?} {}

    SMTP_SERVER_LOGIN = "ihavereplaced this"

 

    ;# {SMTP_SERVER_PASSWORD} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server password} {}

    SMTP_SERVER_PASSWORD = "ihavereplacedthis"

 

;; end of [SMTP] module

 

 

So now for my questions:

 

(1)    What IP should be in the SMTP_SERVER_HOSTNAME line?

(2)    Should the login and password be the same as my regular personal mail?

 

Looking forward to a resolve here. I have checked other forums for an answer, but nothing can get as good as the OpenSim Users group.


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Changing the world - one prim at a time! The Insight Concepts Grid http://gcse.dyndns.org:8002
Reply | Threaded
Open this post in threaded view
|

Re: OpenSim.ini and external email

James Stallings II
Assuming that this is actually completely functional, one would need an SMTP service running on port 25 at the address specified in the SMTP_SERVER_HOSTNAME line (or alternatively, the fully qualified DNS name of a server running such a service on port 25).

The login/password would be for accessing the SMTP service; this can be fairly simple or fairly complicated depending on how the SMTP service is configured.

This is not really a great place to get into deep explanations of SMTP services, but that's the nuts and bolts of what you need. If you want to tackle setting up such a service, google up 'sendmail' and have a good read :)

Cheers
James



On Fri, Jul 11, 2014 at 12:01 PM, The Pierce Family <[hidden email]> wrote:

I have had great success to this point to get 0.8 up and running. The only things lacking right now of high importance are: (1) an economy, and (2) external email capability for servers.

What I am currently getting for a message is: “DefaultEmailModule Exception: Could not connect to 127.0.0.1:25”

My port 25 is open on the primary computer (I am running 4 systems, with primary running robust, initial OpenSim instance, and MySQL) on TCP as well as UDP.

 

 

I have the following OpenSim.ini (extraction of the [SMTP] part and email/passwords have been removed):

 

[SMTP]

    ;; The SMTP server enabled the email module to send email to external

    ;; destinations.

 

    ;# {enabled} {[Startup]emailmodule:DefaultEmailModule} {Enable SMTP service?} {true false} false

    ;; Enable sending email via SMTP

    enabled = true

 

    ;# {internal_object_host} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Host name to treat as internal (object to object) email?} {} lsl.opensim.local

    internal_object_host = lsl.opensim.local

 

    ;# {host_domain_header_from} {[Startup]emailmodule:DefaultEmailModule enabled:true} {From address to use in the sent email header?} {} 127.0.0.1

    host_domain_header_from = "127.0.0.1"

 

    ;# {email_pause_time} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Period in seconds to delay after an email is sent.} {} 20

    email_pause_time = 20

 

    ;# {email_max_size} {[Startup]emailmodule:DefaultEmailModule enabled:true} {Maximum total size of email in bytes.} {} 4096

    email_max_size = 4096

 

    ;# {SMTP_SERVER_HOSTNAME} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server name?} {} 127.0.0.1

 

     SMTP_SERVER_HOSTNAME = "127.0.0.1"

 

    ;# {SMTP_SERVER_PORT} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server name?} {SMTP server port?} {} 25

    SMTP_SERVER_PORT = 25

 

    ;# {SMTP_SERVER_LOGIN} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server user name?} {}

    SMTP_SERVER_LOGIN = "ihavereplaced this"

 

    ;# {SMTP_SERVER_PASSWORD} {[Startup]emailmodule:DefaultEmailModule enabled:true} {SMTP server password} {}

    SMTP_SERVER_PASSWORD = "ihavereplacedthis"

 

;; end of [SMTP] module

 

 

So now for my questions:

 

(1)    What IP should be in the SMTP_SERVER_HOSTNAME line?

(2)    Should the login and password be the same as my regular personal mail?

 

Looking forward to a resolve here. I have checked other forums for an answer, but nothing can get as good as the OpenSim Users group.


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users




--

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users