OpenSimulator dev builds using .NET 4.0 - Status of addon modules

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSimulator dev builds using .NET 4.0 - Status of addon modules

aiaustin
Another point, just so myself and others using addon modules know
where we stand and know what work will be involved in moving from
r/24020 on .NET 3.5 to r/23021 on .NET 4.0....

I have an add-on module for Diva's Wifi in our setup, and can use the
current compiled .dlls from the latest 0.7.5 release or compile up to
r/24020 from her latest sources which are only stated as valid up to
0.7.5 reelase.

Will the old compiled 0.7.5 .NET 3.5 related .dlls continue to work
in the new .NET 4.0 framework systems, or will a recompilation be
necessary, or will they just not work until a new 0.8.0 release
version is created?

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator dev builds using .NET 4.0 - Status of addon modules

justincc
As far as I know, DLLs built on an older versions of the .NET framework should continue to work when referenced by an
exe or DLL built on a newer version of the framework.

In this case, the vast majority of DLLs built under .NET 3.5 (e.g. region modules) should continue to work just fine
with the development branch now using .NET 4.0.  There are a few migrations issues [1] but I would be surprised if any
DLLs created for OpenSimulator run into them.

[1] http://msdn.microsoft.com/en-us/library/ee941656%28v=vs.100%29.aspx

On 09/11/13 15:55, Ai Austin wrote:

> Another point, just so myself and others using addon modules know where we stand and know what work will be involved in
> moving from r/24020 on .NET 3.5 to r/23021 on .NET 4.0....
>
> I have an add-on module for Diva's Wifi in our setup, and can use the current compiled .dlls from the latest 0.7.5
> release or compile up to r/24020 from her latest sources which are only stated as valid up to 0.7.5 reelase.
>
> Will the old compiled 0.7.5 .NET 3.5 related .dlls continue to work in the new .NET 4.0 framework systems, or will a
> recompilation be necessary, or will they just not work until a new 0.8.0 release version is created?
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
Justin Clark-Casey (justincc)
OSVW Consulting
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users