Problem Registering Region w/ grid setup

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem Registering Region w/ grid setup

spambox@tooniverse.info
My opensim v0.6.8 grid installation simulator is having problems registering itself with the rest of the grid. Below are the logs:

OpenSim.32BitLaunch.exe log file just before the crash

2009-12-26 23:17:16,790 INFO  - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer [MAPTILE]: Generating Maptile Step 1: Terrain
2009-12-26 23:18:56,821 DEBUG - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer Fetched texture b8d3965a-ad78-bf43-699b-bff8eca6c975, found: False
2009-12-26 23:20:36,836 DEBUG - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer Fetched texture abb783e6-3e93-26c0-248a-247666855da3, found: False
2009-12-26 23:22:16,852 DEBUG - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer Fetched texture 179cdabd-398a-9b6b-1391-4dc333ba321f, found: False
2009-12-26 23:23:56,868 DEBUG - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer Fetched texture beb169c7-11ea-fff2-efe5-0f24dc881df2, found: False
2009-12-26 23:23:56,915 INFO  - OpenSim.Region.CoreModules.World.WorldMap.TexturedMapTileRenderer [MAPTILE]: Generating Maptile Step 1: Done in 400125 ms
2009-12-26 23:23:56,922 INFO  - OpenSim.Region.CoreModules.World.WorldMap.MapImageModule [MAPTILE]: Generating Maptile Step 2: Object Volume Profile
2009-12-26 23:23:56,922 INFO  - OpenSim.Region.CoreModules.World.WorldMap.MapImageModule [MAPTILE]: Generating Maptile Step 2: Done in 0 ms
2009-12-26 23:23:56,969 DEBUG - OpenSim.Region.CoreModules.World.WorldMap.WorldMapModule [MAPTILE]: STORING MAPTILE IMAGE
2009-12-26 23:25:37,235 DEBUG - OpenSim.Region.Framework.Scenes.Scene [SCENE]: Registering with InterregionCommsIn
2009-12-26 23:25:37,243 DEBUG - OpenSim.Services.GridService.GridService [GRID SERVICE]: Region Rehal (ca567597-203f-45d9-b607-69cd0ed950c0) registered successfully at 256000-256000
2009-12-26 23:25:37,282 DEBUG - OpenSim.Services.Connectors.GridServicesConnector [GRID CONNECTOR]: unexpected result Failure
2009-12-26 23:25:37,282 ERROR - OpenSim.OpenSimBase [STARTUP]: Registration of region with grid failed, aborting startup -    at OpenSim.Region.Framework.Scenes.Scene.RegisterRegionWithGrid() in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Region\Framework\Scenes\Scene.cs:line 1546
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Region\Application\OpenSimBase.cs:line 393

The last few lines of my OpenSim.Server log file:

2009-12-26 23:22:16,875 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: OnRequest() failed with Object reference not set to an instance of an object.    at OpenSim.Server.Handlers.Asset.AssetServerGetHandler.Handle(String path, Stream request, OSHttpRequest httpRequest, OSHttpResponse httpResponse) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Server\Handlers\Asset\AssetServerGetHandler.cs:line 105
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleRequest(OSHttpRequest request, OSHttpResponse response) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 382
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnHandleRequestIOThread(IHttpClientContext context, IHttpRequest request) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 323
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnRequest(Object source, RequestEventArgs args) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 310
2009-12-26 23:23:58,227 ERROR - OpenSim.Framework.Servers.HttpServer.BaseHttpServer [BASE HTTP SERVER]: OnRequest() failed with Object reference not set to an instance of an object.    at OpenSim.Server.Handlers.Asset.AssetServerPostHandler.Handle(String path, Stream request, OSHttpRequest httpRequest, OSHttpResponse httpResponse) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Server\Handlers\Asset\AssetServerPostHandler.cs:line 73
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleRequest(OSHttpRequest request, OSHttpResponse response) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 382
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnHandleRequestIOThread(IHttpClientContext context, IHttpRequest request) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 323
   at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnRequest(Object source, RequestEventArgs args) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Framework\Servers\HttpServer\BaseHttpServer.cs:line 310
2009-12-26 23:25:37,274 DEBUG - OpenSim.Server.Handlers.Grid.GridServerPostHandler [GRID HANDLER]: Exception System.NullReferenceException: Object reference not set to an instance of an object.
   at OpenSim.Server.Handlers.Grid.GridServerPostHandler.Register(Dictionary`2 request) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Server\Handlers\Grid\GridServerPostHandler.cs:line 161
   at OpenSim.Server.Handlers.Grid.GridServerPostHandler.Handle(String path, Stream requestData, OSHttpRequest httpRequest, OSHttpResponse httpResponse) in c:\Users\tberg\Documents\opensim-0.6.8-release\opensim-0.6.8-release\OpenSim\Server\Handlers\Grid\GridServerPostHandler.cs:line 83


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users