Problem with RemoteAdmin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with RemoteAdmin

Olli Aro
Administrator

Hi all,

 

I am trying to use the XML-RPC interface in order to add a new region to OpenSim (version 0.6.6). Everything seems to work fine and I can create a new region and populate it from OAR file, however the new region does not seem to persist and after OpenSim restart it has disappeared.

 

I am using the following calls to achieve the above:

 

admin_create_region

admin_load_oar

 

Should I do something extra in order to persist the region or is there a bug in the RemoteAdmin?

 

Regards,

 

Olli

 

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RemoteAdmin

Charles Krinke-3
Dear Olli:

I am going to guess that you probably have not setup sqlite or mysql to store the data for persistence. The details of how to set that up are on the wiki.

Charles


From: Olli Aro <[hidden email]>
To: [hidden email]
Sent: Tue, November 17, 2009 10:05:57 AM
Subject: [Opensim-users] Problem with RemoteAdmin

Hi all,

 

I am trying to use the XML-RPC interface in order to add a new region to OpenSim (version 0.6.6). Everything seems to work fine and I can create a new region and populate it from OAR file, however the new region does not seem to persist and after OpenSim restart it has disappeared.

 

I am using the following calls to achieve the above:

 

admin_create_region

admin_load_oar

 

Should I do something extra in order to persist the region or is there a bug in the RemoteAdmin?

 

Regards,

 

Olli

 

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RemoteAdmin

fsiola
Olli,

In the wiki page for RemoteAdmin - http://opensimulator.org/wiki/RemoteAdmin - the parameters described to the call admin_create_region are: region_name, region_id (optional), region_master_first, region_master_last, region_master_uuid (optional), region_master_password, listen_ip, listen_port (integer), external_address, region_x (integer), region_y (integer), persist (optional).

Make sure you make the XMLRPC with the parameters "persist" with the value "true".

[]s
Felipe


2009/11/17 Charles Krinke <[hidden email]>
Dear Olli:

I am going to guess that you probably have not setup sqlite or mysql to store the data for persistence. The details of how to set that up are on the wiki.

Charles


From: Olli Aro <[hidden email]>
To: [hidden email]
Sent: Tue, November 17, 2009 10:05:57 AM
Subject: [Opensim-users] Problem with RemoteAdmin

Hi all,

 

I am trying to use the XML-RPC interface in order to add a new region to OpenSim (version 0.6.6). Everything seems to work fine and I can create a new region and populate it from OAR file, however the new region does not seem to persist and after OpenSim restart it has disappeared.

 

I am using the following calls to achieve the above:

 

admin_create_region

admin_load_oar

 

Should I do something extra in order to persist the region or is there a bug in the RemoteAdmin?

 

Regards,

 

Olli

 

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RemoteAdmin

Olli Aro
Administrator

Ahh, so it does. How did I manage to miss that…

 

One annoying thing with the Wiki. Loads of useful stuff there but the search engine is either broken or I cannot figure out how to use it, so really difficult to locate anything.

 

Thanks for your help and such a quick response,

 

Olli

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Felipe Siola
Sent: 17 November 2009 19:30
To: [hidden email]
Subject: Re: [Opensim-users] Problem with RemoteAdmin

 

Olli,

In the wiki page for RemoteAdmin - http://opensimulator.org/wiki/RemoteAdmin - the parameters described to the call admin_create_region are: region_name, region_id (optional), region_master_first, region_master_last, region_master_uuid (optional), region_master_password, listen_ip, listen_port (integer), external_address, region_x (integer), region_y (integer), persist (optional).

Make sure you make the XMLRPC with the parameters "persist" with the value "true".

[]s
Felipe

2009/11/17 Charles Krinke <[hidden email]>

Dear Olli:

I am going to guess that you probably have not setup sqlite or mysql to store the data for persistence. The details of how to set that up are on the wiki.

Charles

 


From: Olli Aro <[hidden email]>
To: [hidden email]
Sent: Tue, November 17, 2009 10:05:57 AM
Subject: [Opensim-users] Problem with RemoteAdmin

 

Hi all,

 

I am trying to use the XML-RPC interface in order to add a new region to OpenSim (version 0.6.6). Everything seems to work fine and I can create a new region and populate it from OAR file, however the new region does not seem to persist and after OpenSim restart it has disappeared.

 

I am using the following calls to achieve the above:

 

admin_create_region

admin_load_oar

 

Should I do something extra in order to persist the region or is there a bug in the RemoteAdmin?

 

Regards,

 

Olli

 

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem with RemoteAdmin

Charles Krinke-3

Dear Olli:

Another thing that will probably help you. We have a robust group on the #opensim IRC channel and is great to speak with and share successes (and failures). So, I would encourage you to join that channel.

Charles



From: Olli Aro <[hidden email]>
To: [hidden email]
Sent: Tue, November 17, 2009 11:38:21 AM
Subject: Re: [Opensim-users] Problem with RemoteAdmin

Ahh, so it does. How did I manage to miss that…

 

One annoying thing with the Wiki. Loads of useful stuff there but the search engine is either broken or I cannot figure out how to use it, so really difficult to locate anything.

 

Thanks for your help and such a quick response,

 

Olli

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Felipe Siola
Sent: 17 November 2009 19:30
To: [hidden email]
Subject: Re: [Opensim-users] Problem with RemoteAdmin

 

Olli,

In the wiki page for RemoteAdmin - http://opensimulator.org/wiki/RemoteAdmin - the parameters described to the call admin_create_region are: region_name, region_id (optional), region_master_first, region_master_last, region_master_uuid (optional), region_master_password, listen_ip, listen_port (integer), external_address, region_x (integer), region_y (integer), persist (optional).

Make sure you make the XMLRPC with the parameters "persist" with the value "true".

[]s
Felipe

2009/11/17 Charles Krinke <[hidden email]>

Dear Olli:

I am going to guess that you probably have not setup sqlite or mysql to store the data for persistence. The details of how to set that up are on the wiki.

Charles

 


From: Olli Aro <[hidden email]>
To: [hidden email]
Sent: Tue, November 17, 2009 10:05:57 AM
Subject: [Opensim-users] Problem with RemoteAdmin

 

Hi all,

 

I am trying to use the XML-RPC interface in order to add a new region to OpenSim (version 0.6.6). Everything seems to work fine and I can create a new region and populate it from OAR file, however the new region does not seem to persist and after OpenSim restart it has disappeared.

 

I am using the following calls to achieve the above:

 

admin_create_region

admin_load_oar

 

Should I do something extra in order to persist the region or is there a bug in the RemoteAdmin?

 

Regards,

 

Olli

 

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users