Re: Building NET 4 projects with Nant

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

justincc
On 22/01/12 11:42, DutchGlory wrote:
> Building .NET 4 projects with Nant... a big wish for a lot of linux users.
> here i found some information about this
> my question, would it be possible to add this to opensimulator.??  it would
> be a big step forward....
>
> http://stackoverflow.com/questions/1215731/building-net-4-projects-with-nant
> building net 4 projects with nant

The changes described by that page are all done in the nant directory, not in OpenSim itself as far as I can see.

--
Justin Clark-Casey (justincc)
http://justincc.org/blog
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

Opensimfan
This post was updated on .
thanks for reply..

ahaa..  good to know...  although mono 2.10 (witch i use)  
does support .net 4.0, but maybe for the far future,
first make opensimulator stable (enough) with .net 3.5

thanks..
_________________________________________
OpenSimFan

My Opensim/Second Life Blog
http://verwijs.wordpress.com

(Dutch, basic hardware/software help windows, Mac, Linux)
http://verwijs-pc.nl

My Twitter Page:
http://twitter.com/OpenSimFan

My Facebook page (be my friend, please )
http://www.facebook.com/andre.verwijs

My Google+ page (follow me please )
André Verwijs - Google+
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

R.Gunther
On 2012-01-24 03:49, OpenSimFan wrote:
> thanks for reply..
>
> ahaa..  so this is for nant compilation...  good to know...
> although mono 2.10 (witch i use)  does support .net 4.0,
> but maybe for the far future, first make opensimulator
> stable (enough) with .net 3.5
>
> thanks..
>

Curious, descripe stable ?
Because opensim with linux opensuse and mono 2.10.5 or higher is already
damn stable.
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

Klaus-E. Klingner
Which OpenSuSE version are you using? with 11.4 I have had problems
with the ODE-physics (reproducable on three different installatitions).

Regards,

Klaus


On 24.01.2012 15:10, R.Gunther wrote:

> On 2012-01-24 03:49, OpenSimFan wrote:
>> thanks for reply..
>>
>> ahaa..  so this is for nant compilation...  good to know...
>> although mono 2.10 (witch i use)  does support .net 4.0,
>> but maybe for the far future, first make opensimulator
>> stable (enough) with .net 3.5
>>
>> thanks..
>>
>
> Curious, descripe stable ?
> Because opensim with linux opensuse and mono 2.10.5 or higher is
> already damn stable.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

R.Gunther
On 2012-01-24 15:15, Klaus-E. Klingner wrote:
> Which OpenSuSE version are you using? with 11.4 I have had problems
> with the ODE-physics (reproducable on three different installatitions).

Most i still use opensuse 11.3 64bit. cant remember if 11.4 is in  use
here, newer ones have weird problems anyway for me.
Im compiling opensim and mono myself.  Also use ubuntu server edition,
version i need to check.


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

Opensimfan
This post was updated on .
In reply to this post by R.Gunther
  opensimulator still needs a bit of work.  mostly warnings.  on windows its pretty stable.
especially if you use MSBUILD  to compile. on linux you will a lot more warnings with

"The variable ...... is assigned but its value is never used"  
 "The compiler for "Mono 4.0 Profile" does not support limiting the platform on which the compiled code can run."

They don't break compilation, but still not realy stable...

 
 
_________________________________________
OpenSimFan

My Opensim/Second Life Blog
http://verwijs.wordpress.com

(Dutch, basic hardware/software help windows, Mac, Linux)
http://verwijs-pc.nl

My Twitter Page:
http://twitter.com/OpenSimFan

My Facebook page (be my friend, please )
http://www.facebook.com/andre.verwijs

My Google+ page (follow me please )
André Verwijs - Google+
Reply | Threaded
Open this post in threaded view
|

Re: Building NET 4 projects with Nant

M.E. Verhagen
hmmzzz windows does not warn when variables are assigned and use a little memory but not used ?

That sounds like 'I do not see an issue so there isn't an issue' ?

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users