Re: Opensim-users Digest, Vol 30, Issue 47

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Opensim-users Digest, Vol 30, Issue 47

TaraDesoto
 There isnt an Opensim.server.ini.example
 
 
 file in the  0.6.8 download that I recieved .  I noticed that descrepancy when I was looking over the files and  I also did noticed that there are two files  Opensim.server.ini and  Opensim.ini ..  The file that is not working correctly is  Opensim.server.ini ....  the file itself appears fine , but for some reason  OpenSim.server.exe wont read the file .  I am running Windows Server 2008 and I know my way around DOS  and config files in general , but for some reason  Opensim.server.ini wont read on my system
 
Any Help would be very much appreciated since this appears to be my last step until I have a proper deployment
 
Thanks Much !
 
Tara

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Opensim-users Digest, Vol 30, Issue 47

John Mieske
do you have google talk or can I email you and I can help you with that
John

On Tue, Feb 16, 2010 at 5:53 PM, Tara Desoto <[hidden email]> wrote:
 There isnt an Opensim.server.ini.example
 
 
 file in the  0.6.8 download that I recieved .  I noticed that descrepancy when I was looking over the files and  I also did noticed that there are two files  Opensim.server.ini and  Opensim.ini ..  The file that is not working correctly is  Opensim.server.ini ....  the file itself appears fine , but for some reason  OpenSim.server.exe wont read the file .  I am running Windows Server 2008 and I know my way around DOS  and config files in general , but for some reason  Opensim.server.ini wont read on my system
 
Any Help would be very much appreciated since this appears to be my last step until I have a proper deployment
 
Thanks Much !
 
Tara

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users




--
John Mieske / Winword Exonar
http://johnmieske.org
Space Grid Station

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Opensim-users Digest, Vol 30, Issue 47

John Mieske
I'll just post it here.
Here is what I use.. Change the Password=password to your password and then change http://yourserver:8002 to your IP or domain name.
-------------------------------------------

; * The startup section lists all the connectors to start up in this server
; * instance. This may be only one, or it may be the entire server suite.
; * Multiple connectors should be seaprated by commas.
; *
; * These are the IN connectors the server uses, the in connectors
; * read this config file and load the needed OUT and database connectors
; *
; * Add "OpenSim.Server.Handlers.dll:AuthenticationServiceConnector" to
; * enable the experimental authentication service
; *
[Startup]
ServiceConnectors = "OpenSim.Server.Handlers.dll:AssetServiceConnector,OpenSim.Server.Handlers.dll:InventoryServiceInConnector,OpenSim.Server.Handlers.dll:FreeswitchServerConnector,OpenSim.Server.Handlers.dll:GridServiceConnector"

; * This is common for all services, it's the network setup for the entire
; * server instance
; *
[Network]
port = 8003

; * The following are for the remote console
; * They have no effect for the local or basic console types
; * Leave commented to diable logins to the console
;ConsoleUser = Test
;ConsolePass = secret

; * As an example, the below configuration precisely mimicks the legacy
; * asset server. It is read by the asset IN connector (defined above)
; * and it then loads the OUT connector (a local database module). That,
; * in turn, reads the asset loader and database connection information
; *
[AssetService]
LocalServiceModule = "OpenSim.Services.AssetService.dll:AssetService"
DefaultAssetLoader = "OpenSim.Framework.AssetLoader.Filesystem.dll"
AssetLoaderArgs = "assets/AssetSets.xml"
StorageProvider = "OpenSim.Data.MySQL.dll"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=root;Password=password;"

; * This configuration loads the inventory server modules. It duplicates
; * the function of the legacy inventory server
; *
[InventoryService]
LocalServiceModule = "OpenSim.Services.InventoryService.dll:InventoryService"
UserServerURI = "http://yourserver:8002"
SessionAuthentication = "false"
StorageProvider = "OpenSim.Data.MySQL.dll"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=root;Password=password;"

; * This is the configuration for the freeswitch server in grid mode
[FreeswitchService]
LocalServiceModule = "OpenSim.Services.FreeswitchService.dll:FreeswitchService"

; * This is the new style authentication service. Currently, only MySQL
; * is implemented. "Realm" is the table that is used for user lookup.
; * By setting it to "users", you can use the old style users table
; * as an authentication source.
; *
[AuthenticationService]
AuthenticationServiceModule = "OpenSim.Services.AuthenticationService.dll:PasswordAuthenticationService"
StorageProvider = "OpenSim.Data.MySQL.dll"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=root;Password=password;"
; Realm = "users"

; * This is the new style user service.
; * "Realm" is the table that is used for user lookup.
; * It defaults to "users", which uses the legacy tables
; *
[UserAccountService]
AuthenticationServiceModule = "OpenSim.Services.UserService.dll:UserAccountService"
StorageProvider = "OpenSim.Data.MySQL.dll"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=root;Password=password;"
; Realm = "users"

; * This is the new style grid service.
; * "Realm" is the table that is used for user lookup.
; * It defaults to "regions", which uses the legacy tables
; *
[GridService]
LocalServiceModule = "OpenSim.Services.GridService.dll:GridService"
StorageProvider = "OpenSim.Data.MySQL.dll:MySqlRegionData"
ConnectionString = "Data Source=localhost;Database=opensim;User ID=root;Password=password;"
Realm = "regions"

----------------------------------------- 
John Mieske / Winword Exonar
http://johnmieske.org
Space Grid Station

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Opensim-users Digest, Vol 30, Issue 47

justincc
In reply to this post by TaraDesoto
Tara Desoto wrote:

>  There isnt an Opensim.server.ini.example
>  
>  
>  file in the  0.6.8 download that I recieved .  I noticed that
> descrepancy when I was looking over the files and  I also did noticed
> that there are two files  Opensim.server.ini and  Opensim.ini ..  The
> file that is not working correctly is  Opensim.server.ini ....  the file
> itself appears fine , but for some reason  OpenSim.server.exe wont read
> the file .  I am running Windows Server 2008 and I know my way around
> DOS  and config files in general , but for some reason  
> Opensim.server.ini wont read on my system

I'm curious to know which download you received.  The official one from the OpenSim site

http://dist.opensimulator.org/opensim-0.6.8-binaries.zip

has an OpenSim.Server.ini.example but not an OpenSim.Sever.ini

>  
> Any Help would be very much appreciated since this appears to be my last
> step until I have a proper deployment
>  
> Thanks Much !
>  
> Tara
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


--
Justin Clark-Casey (justincc)
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users