Remote Admin default_appearance.xml (Eugenio Passacantilli)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Remote Admin default_appearance.xml (Eugenio Passacantilli)

emperorstarfinder
I am not sure if this will help any, but I saw eugene's post about  
creating a default_appearance with remote console.

In grid mode I used diva's wifi (her current version for wifi for  
robust is 0.7.3.1.  I created the default avatars Female Avatar, Male  
Avatar, Neutral Avatar through the wifi.  Then I logged each one in  
and did their shapes, skin, hair, eyes, outfits, etc.  Now when new  
users register via the wifi they will get the default_appearance set  
to the default avatars.  Diva's wifi seems to be the only front end  
component that actually works without to much frustration currently.  
You can get her wifi for robust at  
http://metaverseink.com/Downloads.html.  I hope that might help a bit  
at least.

Emperor

Quoting [hidden email]:

> Send Opensim-users mailing list submissions to
> [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://lists.berlios.de/mailman/listinfo/opensim-users
> or, via email, send a message with subject or body 'help' to
> [hidden email]
>
> You can reach the person managing the list at
> [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Opensim-users digest..."
>
>
> Today's Topics:
>
>    1. Remote Admin default_appearance.xml (Eugenio Passacantilli)
>    2. Re: Got profiles working (Emperor Starfinder)
>    3. Re: Kinect motion capture date (Justin Clark-Casey)
>    4. Re: Remote Admin default_appearance.xml (Justin Clark-Casey)
>    5. Re: Kinect motion capture date (Chibo Ryder)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 24 Jan 2013 12:29:10 +0100
> From: Eugenio Passacantilli <[hidden email]>
> To: [hidden email]
> Subject: [Opensim-users] Remote Admin default_appearance.xml
> Message-ID:
> <[hidden email]>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi all,
> I have created new avatar using opensim remote api through PHP app..
> All work fine, but I log in with the user created with remote api the
> avatar looks like the "classic" red cloud and it doesn't load the default
> avatar..
> I've read, within the Opensim.ini file, that the XML default_appearance
> file is required to get the default avatar when using remote api avatar
> creation.
> With this config I've created new user from OpenSim server console with
> perfect results.
> So I think the problem is related to the remote api.
> Could you please tell me how to solve this issue?
>
> Thanks a lot,
>
> --
> Eugenio
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:  
> <https://lists.berlios.de/pipermail/opensim-users/attachments/20130124/92db50c0/attachment-0001.html>
>
> ------------------------------
>
> Message: 2
> Date: Thu, 24 Jan 2013 06:44:33 -0500
> From: Emperor Starfinder <[hidden email]>
> To: [hidden email]
> Subject: Re: [Opensim-users] Got profiles working
> Message-ID: <20130124064433.52546ubal423c1og@74.50.85.33>
> Content-Type: text/plain; charset=ISO-8859-1; DelSp="Yes";
> format="flowed"
>
> I usually don't have a problem posting something that might be helpful
> to others.  I haven't tried using any opensim instances on Linux yet
> but from what I have heard the best Linux versions that work well for
> opensim are Ubantu and Debian (LL uses Debian so I am told).  One of
> these days I will get bored with nothing to do perhaps and will
> rebuild an old tower I have and fire up Linux on it and see what
> happens with opensim on it.  Right now though so much work to do to
> get my grid fully going.  Might post some pictures so everyone can see
> what is up in galaxy (in world for those who are more familiar with SL
> lingo).
>
> Thanks
>
> Emperor
>
> Quoting [hidden email]:
>
>> Send Opensim-users mailing list submissions to
>> [hidden email]
>>
>> To subscribe or unsubscribe via the World Wide Web, visit
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>> or, via email, send a message with subject or body 'help' to
>> [hidden email]
>>
>> You can reach the person managing the list at
>> [hidden email]
>>
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of Opensim-users digest..."
>>
>>
>> Today's Topics:
>>
>>    1. Re: Got profiles working (ssm2017)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Thu, 24 Jan 2013 03:20:47 +0100
>> From: ssm2017 <[hidden email]>
>> To: [hidden email]
>> Subject: Re: [Opensim-users] Got profiles working
>> Message-ID:
>> <CAE2ni0HGDdod8-yJYQ7WC=C4cwQuDL5qhoG=[hidden email]>
>> Content-Type: text/plain; charset="iso-8859-1"
>>
>> im not using windows, but i thought that it could be a good idea to keep a
>> track and help other people on the same situation as yours.
>> thanks you to you for sharing your experience :)
>>
>>
>> 2013/1/24 Emperor Starfinder <[hidden email]>
>>
>>> Okay I have added the tutorial to the opensim wiki.  Thanks for the idea
>>> ssm2017.
>>>
>>>
>>> Thanks
>>>
>>> Emperor
>>>
>>> Quoting
>>> opensim-users-request@lists.**berlios.de<[hidden email]>
>>> :
>>>
>>>  Send Opensim-users mailing list submissions to
>>>>         [hidden email]
>>>>
>>>> To subscribe or unsubscribe via the World Wide Web, visit
>>>>
>>>> https://lists.berlios.de/**mailman/listinfo/opensim-users<https://lists.berlios.de/mailman/listinfo/opensim-users>
>>>> or, via email, send a message with subject or body 'help' to
>>>>
>>>> opensim-users-request@lists.**berlios.de<[hidden email]>
>>>>
>>>> You can reach the person managing the list at
>>>>
>>>> opensim-users-owner@lists.**berlios.de<[hidden email]>
>>>>
>>>> When replying, please edit your Subject line so it is more specific
>>>> than "Re: Contents of Opensim-users digest..."
>>>>
>>>>
>>>> Today's Topics:
>>>>
>>>>    1. Got profiles working ([hidden email])
>>>>    2. Re: Got profiles working (ssm2017)
>>>>
>>>>
>>>> ------------------------------**------------------------------**
>>>> ----------
>>>>
>>>> Message: 1
>>>> Date: Tue, 22 Jan 2013 16:10:32 -0500
>>>> From: [hidden email]
>>>> To: [hidden email]
>>>> Subject: [Opensim-users] Got profiles working
>>>> Message-ID:
>>>> <20130122161032.**17051cbteed4urt4@74.50.85.33<20130122161032.17051cbteed4urt4@74.50.85.33>
>>>> >
>>>> Content-Type: text/plain; charset=ISO-8859-1; DelSp="Yes";
>>>>         format="flowed"
>>>>
>>>> Okay so after a lot of annoying bugs and frustration, I finally got
>>>> search, profiles, and offline messaging working.  Thanks to Guy for
>>>> giving me that last push I needed to revisit it.
>>>>
>>>> For those who are having trouble with the profiles, search, and
>>>> offline messaging and are running on windows I recommend the following
>>>> steps as it worked for me.
>>>>
>>>> 1. Install IIS (you can either install the IIS 7.5 express from
>>>> Microsoft or activate IIS 6.0 through your control panel by going to
>>>> the control panel and under programs turn on or off new features.  In
>>>> the features manager check the boxes for IIS and click ok.)
>>>>
>>>> 2. Through the web installer from Microsoft you'll want to install php
>>>> 5.3.19 (sorry I am not to sure yet why profiles, search, and offline
>>>> messaging hates php 5.4.x.  I'll try and play around with this when I
>>>> get some time and through the list of projects I have waiting for me
>>>> to implement.)
>>>>
>>>> 3. Go to your IIS Manager by clicking on start and typing in IIS
>>>> Manager to find the manager.
>>>>
>>>> 4. In the IIS manager you might need to scroll down to find the php
>>>> manager.  Open the manager.
>>>>
>>>> 5. In the php manager you might get an incompatibility highlighted in
>>>> yellow.  No need to panic this is normal.  Click the recommended link
>>>> next to this message and it will go away.
>>>>
>>>> 6. Click the php.ini link and edit the php.ini file and turn on
>>>> asp_tags and short_open_tags.  Then click save.
>>>>
>>>> 7. Click the phpinfo link to verify that you have configured
>>>> everything correctly.  No need to worry about the php_curl or
>>>> php_xmlrpc as these are on by default. (they were for me).
>>>>
>>>> 8. Minimize your IIS manager now.
>>>>
>>>> 9. Copy the web root folders for search and profiles to your IIS
>>>> wwwroot folder.  You can find this directory in C:\inetpub\wwwroot\
>>>>
>>>> 10. In my case I named the search, profile, and offline messaging
>>>> directory folders search, profiles, and messaging.  I also changed the
>>>> xmlrpc groups web root directory to groups.
>>>>
>>>> 11. Make sure to configure your database info and your ini files
>>>> accordingly in your opensim server.
>>>>
>>>> 12. Restart or launch your opensim instance.
>>>>
>>>> 13. Log in using your viewer of choice and test.  Everything should
>>>> work quite well.
>>>>
>>>> I am sorry to see these modules not working well with the current php
>>>> versions in wamp and xampp servers.  Someone will need to revisit that
>>>> and figure out how to actually make these compatible with any
>>>> php-xmlrpc version.
>>>>
>>>> Thanks to Guy who gave me that bit of encouragement I needed and to
>>>> Fleep/ Chris for posting his steps on his wiki.  Once I saw on Fleep's
>>>> wiki that he had it working with IIS it got me thinking there might be
>>>> a problem on windows with wamp and xampp server php-xmlrpc instances.
>>>>
>>>> My next project is the economy modules for our grid and then
>>>> addressing the issue relating to bigger region sizes.  Now that the
>>>> developers of Firestorm are implementing the var regions, it is time I
>>>> think to re address this.  I will let everyone know how this project
>>>> turns out once I get to it in a day or two.  Currency comes first.
>>>>
>>>> Emperor
>>>>
>>>>
>>>> ------------------------------
>>>>
>>>> Message: 2
>>>> Date: Wed, 23 Jan 2013 00:19:01 +0100
>>>> From: ssm2017 <[hidden email]>
>>>> To: [hidden email]
>>>> Subject: Re: [Opensim-users] Got profiles working
>>>> Message-ID:
>>>>         <CAE2ni0Em77Oqb0sRT0ehh8FnmNDv**9uiowHymEjv4+PCMhYbcgA@mail.**
>>>> gmail.com<CAE2ni0Em77Oqb0sRT0ehh8FnmNDv9uiowHymEjv4%[hidden email]>
>>>> >
>>>> Content-Type: text/plain; charset="iso-8859-1"
>>>>
>>>> maybe you can find a place on the wiki to add your tutorial to install
>>>> osmodules for iis and then add the link to the page in
>>>> http://opensimulator.org/wiki/**User_Documentation#Platform_**specific<http://opensimulator.org/wiki/User_Documentation#Platform_specific>
>>>>
>>>>
>>>> 2013/1/22 <[hidden email]>
>>>>
>>>>  Okay so after a lot of annoying bugs and frustration, I finally got
>>>>> search, profiles, and offline messaging working.  Thanks to Guy for
>>>>> giving
>>>>> me that last push I needed to revisit it.
>>>>>
>>>>> For those who are having trouble with the profiles, search, and offline
>>>>> messaging and are running on windows I recommend the following steps as
>>>>> it
>>>>> worked for me.
>>>>>
>>>>> 1. Install IIS (you can either install the IIS 7.5 express from Microsoft
>>>>> or activate IIS 6.0 through your control panel by going to the control
>>>>> panel and under programs turn on or off new features.  In the features
>>>>> manager check the boxes for IIS and click ok.)
>>>>>
>>>>> 2. Through the web installer from Microsoft you'll want to install php
>>>>> 5.3.19 (sorry I am not to sure yet why profiles, search, and offline
>>>>> messaging hates php 5.4.x.  I'll try and play around with this when I get
>>>>> some time and through the list of projects I have waiting for me to
>>>>> implement.)
>>>>>
>>>>> 3. Go to your IIS Manager by clicking on start and typing in IIS Manager
>>>>> to find the manager.
>>>>>
>>>>> 4. In the IIS manager you might need to scroll down to find the php
>>>>> manager.  Open the manager.
>>>>>
>>>>> 5. In the php manager you might get an incompatibility highlighted in
>>>>> yellow.  No need to panic this is normal.  Click the recommended link
>>>>> next
>>>>> to this message and it will go away.
>>>>>
>>>>> 6. Click the php.ini link and edit the php.ini file and turn on asp_tags
>>>>> and short_open_tags.  Then click save.
>>>>>
>>>>> 7. Click the phpinfo link to verify that you have configured everything
>>>>> correctly.  No need to worry about the php_curl or php_xmlrpc as these
>>>>> are
>>>>> on by default. (they were for me).
>>>>>
>>>>> 8. Minimize your IIS manager now.
>>>>>
>>>>> 9. Copy the web root folders for search and profiles to your IIS wwwroot
>>>>> folder.  You can find this directory in C:\inetpub\wwwroot\
>>>>>
>>>>> 10. In my case I named the search, profile, and offline messaging
>>>>> directory folders search, profiles, and messaging.  I also changed the
>>>>> xmlrpc groups web root directory to groups.
>>>>>
>>>>> 11. Make sure to configure your database info and your ini files
>>>>> accordingly in your opensim server.
>>>>>
>>>>> 12. Restart or launch your opensim instance.
>>>>>
>>>>> 13. Log in using your viewer of choice and test.  Everything should work
>>>>> quite well.
>>>>>
>>>>> I am sorry to see these modules not working well with the current php
>>>>> versions in wamp and xampp servers.  Someone will need to revisit that
>>>>> and
>>>>> figure out how to actually make these compatible with any php-xmlrpc
>>>>> version.
>>>>>
>>>>> Thanks to Guy who gave me that bit of encouragement I needed and to
>>>>> Fleep/
>>>>> Chris for posting his steps on his wiki.  Once I saw on Fleep's wiki that
>>>>> he had it working with IIS it got me thinking there might be a problem on
>>>>> windows with wamp and xampp server php-xmlrpc instances.
>>>>>
>>>>> My next project is the economy modules for our grid and then addressing
>>>>> the issue relating to bigger region sizes.  Now that the developers of
>>>>> Firestorm are implementing the var regions, it is time I think to re
>>>>> address this.  I will let everyone know how this project turns out once I
>>>>> get to it in a day or two.  Currency comes first.
>>>>>
>>>>> Emperor
>>>>> ______________________________****_________________
>>>>> Opensim-users mailing list
>>>>> [hidden email]
>>>>> https://lists.berlios.de/****mailman/listinfo/opensim-users<https://lists.berlios.de/**mailman/listinfo/opensim-users>
>>>>> **<https://lists.berlios.de/**mailman/listinfo/opensim-users<https://lists.berlios.de/mailman/listinfo/opensim-users>
>>>>> **>
>>>>>
>>>>>  -------------- next part --------------
>>>> An HTML attachment was scrubbed...
>>>> URL: <https://lists.berlios.de/**pipermail/opensim-users/**
>>>> attachments/20130123/545cafe3/**attachment-0001.html<https://lists.berlios.de/pipermail/opensim-users/attachments/20130123/545cafe3/attachment-0001.html>
>>>> >
>>>>
>>>> ------------------------------
>>>>
>>>> ______________________________**_________________
>>>> Opensim-users mailing list
>>>> [hidden email]
>>>> https://lists.berlios.de/**mailman/listinfo/opensim-users<https://lists.berlios.de/mailman/listinfo/opensim-users>
>>>>
>>>> End of Opensim-users Digest, Vol 65, Issue 40
>>>> ***********************************************
>>>>
>>>>
>>>
>>>
>>> Emperor Starfinder
>>> Core Developer
>>> Second Galaxy Development Team
>>> http://www.secondgalaxy.com
>>> ______________________________**_________________
>>> Opensim-users mailing list
>>> [hidden email]
>>> https://lists.berlios.de/**mailman/listinfo/opensim-users<https://lists.berlios.de/mailman/listinfo/opensim-users>
>>>
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL:
>> <https://lists.berlios.de/pipermail/opensim-users/attachments/20130124/c1d49794/attachment-0001.html>
>>
>> ------------------------------
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
>> End of Opensim-users Digest, Vol 65, Issue 42
>> *********************************************
>>
>
>
>
> Emperor Starfinder
> Core Developer
> Second Galaxy Development Team
> http://www.secondgalaxy.com
>
>
> ------------------------------
>
> Message: 3
> Date: Fri, 25 Jan 2013 04:06:59 +0000
> From: Justin Clark-Casey <[hidden email]>
> To: [hidden email]
> Subject: Re: [Opensim-users] Kinect motion capture date
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Hi John.  I believe you want the OpenSim [1] project rather than  
> OpenSimulator [2] for which this is the mailing list
>
> [1] https://simtk.org/home/opensim
> [2] http://opensimulator.org
>
> On 23/01/13 11:19, John Demetriou wrote:
>> I have motion capture data taken from kinect explorer application.  
>> Is it possible to use the xyz coordinates from that
>> application to perform inverse dynamics using opensim? Do I need  
>> more data? Are my data not suitable at all?
>>
>>
>>
>>
>> Ioannis Demetriou
>> everythingyoumightneed.blogspot.com  
>> <http://everythingyoumightneed.blogspot.com/>
>> [hidden email] <mailto:[hidden email]>
>> 0035799935231
>>
>>
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
>
>
> --
> Justin Clark-Casey (justincc)
> OSVW Consulting
> http://justincc.org
> http://twitter.com/justincc
>
>
> ------------------------------
>
> Message: 4
> Date: Fri, 25 Jan 2013 04:26:29 +0000
> From: Justin Clark-Casey <[hidden email]>
> To: [hidden email]
> Subject: Re: [Opensim-users] Remote Admin default_appearance.xml
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Hi Eugenio.  Unfortunately, "create user" on the console (or by  
> remote call to a configured UserAccount service which
> allows this call) and "create user" through the RemoteAdmin are  
> different codepaths.
>
> "create user" does all the work necessary to get a default 'Ruth' to  
> appear correctly on both version 1, 2 and 3
> viewers.  Unfortunately, it currently has no mechanism to do  
> anything other than set up a "Ruth" other than invoking
> various asset/inventory/avatar calls directly or by fiddling  
> directly with the database.  I think a mechanism to allow a
> different default appearance is something that core should have but  
> it hasn't been high on my priority list.
>
> The RemoteAdmin version of create user will only work for  
> standalones.  In theory, it can read from a
> default_appearance.xml file and use that to set up an appearance.  
> Unfortunately, afaik there is no example file.  Also,
> it's unlikely to work with v2/v3 viewers as I don't believe it will  
> create the necessary outfit links.
>
> Sorry there isn't a better answer right now.
>
> On 24/01/13 11:29, Eugenio Passacantilli wrote:
>> Hi all,
>> I have created new avatar using opensim remote api through PHP app..
>> All work fine, but I log in with the user created with remote api  
>> the avatar looks like the "classic" red cloud and it
>> doesn't load the default avatar..
>> I've read, within the Opensim.ini file, that the XML  
>> default_appearance file is required to get the default avatar when
>> using remote api avatar creation.
>> With this config I've created new user from OpenSim server console  
>> with perfect results.
>> So I think the problem is related to the remote api.
>> Could you please tell me how to solve this issue?
>>
>> Thanks a lot,
>>
>> --
>> Eugenio
>>
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
>
>
> --
> Justin Clark-Casey (justincc)
> OSVW Consulting
> http://justincc.org
> http://twitter.com/justincc
>
>
> ------------------------------
>
> Message: 5
> Date: Thu, 24 Jan 2013 22:32:24 -0600
> From: Chibo Ryder <[hidden email]>
> To: [hidden email]
> Subject: Re: [Opensim-users] Kinect motion capture date
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> On 1/24/2013 10:06 PM, Justin Clark-Casey wrote:
>
> unless John is referring to something like this:
> http://ucsim.uc.edu/blog/2012/03/sl-opensim-using-kinect/
>
> if not, ignore me ;)  just being thorough.
>
> chibo
>
>> Hi John.  I believe you want the OpenSim [1] project rather than
>> OpenSimulator [2] for which this is the mailing list
>>
>> [1] https://simtk.org/home/opensim
>> [2] http://opensimulator.org
>>
>> On 23/01/13 11:19, John Demetriou wrote:
>>> I have motion capture data taken from kinect explorer application. Is
>>> it possible to use the xyz coordinates from that
>>> application to perform inverse dynamics using opensim? Do I need more
>>> data? Are my data not suitable at all?
>>>
>>>
>>>
>>>
>>> Ioannis Demetriou
>>> everythingyoumightneed.blogspot.com
>>> <http://everythingyoumightneed.blogspot.com/>
>>> [hidden email] <mailto:[hidden email]>
>>> 0035799935231
>>>
>>>
>>>
>>> _______________________________________________
>>> Opensim-users mailing list
>>> [hidden email]
>>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>>
>>
>>
>
>
>
> ------------------------------
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
> End of Opensim-users Digest, Vol 65, Issue 43
> *********************************************
>



Emperor Starfinder
Core Developer
Second Galaxy Development Team
http://www.secondgalaxy.com
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Remote Admin default_appearance.xml (Eugenio Passacantilli)

InuYasha Meiji
Whoops, I should add this detail to my two cents worth.  I also have no
attachments in Group notice.  My groups are over two years old.  I used
the version by Jor3l. Locatd on this page,
https://github.com/jor3l/OSModules/tree/master/osgroups/require
It seems to work on all the other functions.

I have vivox voice, Profiles seem dependable,   The only thing I dont
have is search.  Where can I find the most updated version of the groups
module?  I seem to find a lot of conflicting web site, some are old and
not sure what info is still in use.
I am using window 7 64bit.

Yuukyuu / InuYasha.


On 1/25/2013 5:08 AM, Emperor Starfinder wrote:

> I am not sure if this will help any, but I saw eugene's post about
> creating a default_appearance with remote console.
>
> In grid mode I used diva's wifi (her current version for wifi for
> robust is 0.7.3.1.  I created the default avatars Female Avatar, Male
> Avatar, Neutral Avatar through the wifi.  Then I logged each one in
> and did their shapes, skin, hair, eyes, outfits, etc.  Now when new
> users register via the wifi they will get the default_appearance set
> to the default avatars.  Diva's wifi seems to be the only front end
> component that actually works without to much frustration currently.  
> You can get her wifi for robust at
> http://metaverseink.com/Downloads.html.  I hope that might help a bit
> at least.
>
> Emperor
> ________________________________________________________________________
> Opensim User: In Gridmode on Version 0.7.4. Nine Instances with 56
> Regions. on Windows 7, 64-bit. Phenom 9500 2.2 GHz Quad Core, Terabyte
> Hard Drive, 8gig DDR2 RAM. Used XAMPP to load PHP Version 5.3.0,
> Apache and MySQL 5.1.41-community edition. Groups, Profiles, Vivox
> Voice and Offline Messages all working. (Not yet Public, 6 users
> allowed Now).
> ________________________________________________________________________
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users