Robust Log Item Found

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Robust Log Item Found

Randy Pierce

I have been operating in a hypergrid multi-server configuration now for about 2 months after finally figuring out a network issue with SQL. Regardless, I have another issue (although it is not a show-stopper, just a nuisance and a redline). I am running a Robust, SQL, and single opensim instance on a Quad-Core server under Ubuntu 14.10. The problem I am running into is a robust-side problem as it is coming in on that log. Periodically, with varying time seqments, I am getting an error in the log that indicates “Handlerequest() threw exception System.UnauthorizedAccessException: Access to the path “/data” is denied.” It continues on for quite a few lines, but appears to be attempting to write data and sub-folders of data under this folder.

 

Can anyone shed any light on where the “/data” directory that it is looking for should be and what mods should be placed onto the folder? I was simply going to give the system full perms (777) and not worry about it. The issue at hand right now is that the folder needs to be put into the right location first, before I worry about authorizations.

 

Randy

Insight Concepts Grid

http://gcse.dyndns.org:8002

 


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Changing the world - one prim at a time! The Insight Concepts Grid http://gcse.dyndns.org:8002
Reply | Threaded
Open this post in threaded view
|

Re: Robust Log Item Found

Melanie
It appears you didn't edit the default configuration. At least one
of the defaults is /data, you should point that somewhere else. Read
the .ini file, it should be in there.

Melanie

On 29/12/2014 05:26, The Pierce Family wrote:

> I have been operating in a hypergrid multi-server configuration now for
> about 2 months after finally figuring out a network issue with SQL.
> Regardless, I have another issue (although it is not a show-stopper, just a
> nuisance and a redline). I am running a Robust, SQL, and single opensim
> instance on a Quad-Core server under Ubuntu 14.10. The problem I am running
> into is a robust-side problem as it is coming in on that log. Periodically,
> with varying time seqments, I am getting an error in the log that indicates
> "Handlerequest() threw exception System.UnauthorizedAccessException: Access
> to the path "/data" is denied." It continues on for quite a few lines, but
> appears to be attempting to write data and sub-folders of data under this
> folder.
>
>  
>
> Can anyone shed any light on where the "/data" directory that it is looking
> for should be and what mods should be placed onto the folder? I was simply
> going to give the system full perms (777) and not worry about it. The issue
> at hand right now is that the folder needs to be put into the right location
> first, before I worry about authorizations.
>
>  
>
> Randy
>
> Insight Concepts Grid
>
> http://gcse.dyndns.org:8002
>
>  
>
>
>
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Robust Log Item Found

Butch Arnold
In reply to this post by Randy Pierce
Hello Randy,

Check this section in your robust.ini file...

[BakedTextureService]
    LocalServiceModule = "OpenSim.Server.Handlers.dll:XBakes"
    ;; This directory must exist and be writable for the user ROBUST runs as
    BaseDirectory = "./data/bakes"

Notice the "dot" in front of /data/bakes

I think the default file does not place it there as I had to manually add this to our config.

~Butch



On 12/28/2014 11:26 PM, The Pierce Family wrote:

I have been operating in a hypergrid multi-server configuration now for about 2 months after finally figuring out a network issue with SQL. Regardless, I have another issue (although it is not a show-stopper, just a nuisance and a redline). I am running a Robust, SQL, and single opensim instance on a Quad-Core server under Ubuntu 14.10. The problem I am running into is a robust-side problem as it is coming in on that log. Periodically, with varying time seqments, I am getting an error in the log that indicates “Handlerequest() threw exception System.UnauthorizedAccessException: Access to the path “/data” is denied.” It continues on for quite a few lines, but appears to be attempting to write data and sub-folders of data under this folder.

 

Can anyone shed any light on where the “/data” directory that it is looking for should be and what mods should be placed onto the folder? I was simply going to give the system full perms (777) and not worry about it. The issue at hand right now is that the folder needs to be put into the right location first, before I worry about authorizations.

 

Randy

Insight Concepts Grid

http://gcse.dyndns.org:8002

 



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

RE: Robust Log Item Found

Randy Pierce
This post has NOT been accepted by the mailing list yet.

Thanks Butch, it has not passed any red lines in over an hour, I do believe it has been fixed = thank you J

 

 

From: Butch Arnold [via opensim-users] [mailto:[hidden email]]
Sent: Sunday, December 28, 2014 11:21 PM
To: Randy Pierce
Subject: Re: Robust Log Item Found

 

Hello Randy,

Check this section in your robust.ini file...

[BakedTextureService]
    LocalServiceModule = "OpenSim.Server.Handlers.dll:XBakes"
    ;; This directory must exist and be writable for the user ROBUST runs as
    BaseDirectory = "./data/bakes"

Notice the "dot" in front of /data/bakes

I think the default file does not place it there as I had to manually add this to our config.

~Butch



On 12/28/2014 11:26 PM, The Pierce Family wrote:

I have been operating in a hypergrid multi-server configuration now for about 2 months after finally figuring out a network issue with SQL. Regardless, I have another issue (although it is not a show-stopper, just a nuisance and a redline). I am running a Robust, SQL, and single opensim instance on a Quad-Core server under Ubuntu 14.10. The problem I am running into is a robust-side problem as it is coming in on that log. Periodically, with varying time seqments, I am getting an error in the log that indicates “Handlerequest() threw exception System.UnauthorizedAccessException: Access to the path “/data” is denied.” It continues on for quite a few lines, but appears to be attempting to write data and sub-folders of data under this folder.

 

Can anyone shed any light on where the “/data” directory that it is looking for should be and what mods should be placed onto the folder? I was simply going to give the system full perms (777) and not worry about it. The issue at hand right now is that the folder needs to be put into the right location first, before I worry about authorizations.

 

Randy

Insight Concepts Grid

http://gcse.dyndns.org:8002

 




_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


If you reply to this email, your message will be added to the discussion below:

http://opensim-users.2152040.n2.nabble.com/Robust-Log-Item-Found-tp7582037p7582040.html

To start a new topic under opensim-users, email [hidden email]
To unsubscribe from opensim-users, click here.
NAML

Changing the world - one prim at a time! The Insight Concepts Grid http://gcse.dyndns.org:8002
Reply | Threaded
Open this post in threaded view
|

Re: Robust Log Item Found

aiaustin
In reply to this post by Randy Pierce
Randy, as Melanie and Butch indicated... the issue is likely to be
that when XBakes was first included the location for saving avatar
baked textures was set to the unix-orientated /data/bakes in
Robust.ini.example.

In the latest dev master that's set to be ./bakes which will place it
in a directory (which does not have to preexist) in the OpenSim bin
directory, similar to things like the assetcache, scriptengines
script state folder, etc.

[BakedTextureService]
     LocalServiceModule = "OpenSim.Server.Handlers.dll:XBakes"
     ;; This directory must be writable by the user ROBUST runs as.
It will be created automatically.
     BaseDirectory = "./bakes"

Some of us place such things outside of the OpenSim install directory
which you can do using ../../bakes for example or some specific
directory of your choosing.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users