Running FreeSwitch with OpenSim

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Running FreeSwitch with OpenSim

Jor3l Boa
Hello there, trying to run FreeSwitch, I just got it working but when anyone connects to OS I'm getting the following errors:

From FreeSwitch Console:

freeswitch@desktop> 2010-05-11 14:21:51.525111 [ERR] mod_xml_curl.c:304 Received HTTP error 404 trying to fetch http://localhost:9000/api/freeswitch-config
data: [hostname=desktop&section=directory&tag_name=domain&key_name=name&key_value=192.168.0.171&Event-Name=GENERAL&Core-UUID=358c2422-5d32-11df-baab-b39ad4502342&FreeSWITCH-Hostname=desktop&FreeSWITCH-IPv4=192.168.0.171&FreeSWITCH-IPv6=%3A%3A1&Event-Date-Local=2010-05-11%2014%3A21%3A49&Event-Date-GMT=Tue,%2011%20May%202010%2019%3A21%3A49%20GMT&Event-Date-Timestamp=1273605709849611&Event-Calling-File=mod_voicemail.c&Event-Calling-Function=resolve_id&Event-Calling-Line-Number=1242&action=message-count&key=id&user=xdPCKuP4mQdqNMLD4z3su0w%3D%3D&domain=192.168.0.171]

From OpenSim Console:

14:28:29 - [FreeSwitchVoice]: FreeSwitchConfigHTTPHandler called with 
14:28:29 - [FreeSwitchVoice]: section was 
14:28:29 - [FreeSwitchVoice]: FreeSwitchConfigHTTPHandler return 
14:28:29 - [BASE HTTP SERVER]: OnRequest() failed with System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.DoHTTPGruntWork (System.Collections.Hashtable responsedata, OpenSim.Framework.Servers.HttpServer.OSHttpResponse response) [0x00000] 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleContentVerbs (OpenSim.Framework.Servers.HttpServer.OSHttpRequest request, OpenSim.Framework.Servers.HttpServer.OSHttpResponse response) [0x00000] 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleHTTPRequest (OpenSim.Framework.Servers.HttpServer.OSHttpRequest request, OpenSim.Framework.Servers.HttpServer.OSHttpResponse response) [0x00000] 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.HandleRequest (OpenSim.Framework.Servers.HttpServer.OSHttpRequest request, OpenSim.Framework.Servers.HttpServer.OSHttpResponse response) [0x00000] 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnHandleRequestIOThread (IHttpClientContext context, IHttpRequest request) [0x00000] 
  at OpenSim.Framework.Servers.HttpServer.BaseHttpServer.OnRequest (System.Object source, HttpServer.RequestEventArgs args) [0x00000] 

Seems like there is no file on api/freeswitch-config .. Followed OS instructions for FS but is not working, any idea? Thanks


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users