Singularity and Mesh LOD setting (RenderVolumeLODFactor)

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Singularity and Mesh LOD setting (RenderVolumeLODFactor)

aiaustin
Folks... can someone check if their Singularity 1.8.6 (latest
release) allows a change in the debug setting for
RenderVolumeLODFactor via Advanced - Show Debug Settings,
RenderVolumeLODFactor and look at teh defalt, which I think is 1.0.

I tried setting it to 4.0 to get better mesh display but Singularity
appears not to respect this setting whatever it is set to. I tried
even large numbers and the rendering does not appear to change. This
is also the case when relogging, but usually the change of the
parameter has immediate effect.

Can someone with a mesh region check it out as I am hiking something
must be odd about my setup given that we used a lot of mesh items at OSCC14.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Singularity and Mesh LOD setting (RenderVolumeLODFactor)

R.Gunther
Max setting is 2.0 in rendervolumelod factor.

On 2014-11-11 13:56, Ai Austin wrote:

> Folks... can someone check if their Singularity 1.8.6 (latest release)
> allows a change in the debug setting for RenderVolumeLODFactor via
> Advanced - Show Debug Settings, RenderVolumeLODFactor and look at teh
> defalt, which I think is 1.0.
>
> I tried setting it to 4.0 to get better mesh display but Singularity
> appears not to respect this setting whatever it is set to. I tried
> even large numbers and the rendering does not appear to change. This
> is also the case when relogging, but usually the change of the
> parameter has immediate effect.
>
> Can someone with a mesh region check it out as I am hiking something
> must be odd about my setup given that we used a lot of mesh items at
> OSCC14.
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Singularity and Mesh LOD setting (RenderVolumeLODFactor)

Kay McLennan
Ai, et al,

I use the Singularity viewer (but recently switched from the 64 bit to the 32 bit -- per Fleep's instructions prior to the OSCC14) and the RenderVolumeLoadFactor functionality in the Debug menu "holds" an increase of up to and beyond 10/11.  Are you saying the essence of any change is just a "2" not a "10" (even if the load factor says "10")?

Best,
Kay


On Tue, Nov 11, 2014 at 7:08 AM, R.Gunther <[hidden email]> wrote:
Max setting is 2.0 in rendervolumelod factor.


On 2014-11-11 13:56, Ai Austin wrote:
Folks... can someone check if their Singularity 1.8.6 (latest release) allows a change in the debug setting for RenderVolumeLODFactor via Advanced - Show Debug Settings, RenderVolumeLODFactor and look at teh defalt, which I think is 1.0.

I tried setting it to 4.0 to get better mesh display but Singularity appears not to respect this setting whatever it is set to. I tried even large numbers and the rendering does not appear to change. This is also the case when relogging, but usually the change of the parameter has immediate effect.

Can someone with a mesh region check it out as I am hiking something must be odd about my setup given that we used a lot of mesh items at OSCC14.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Singularity and Mesh LOD setting (RenderVolumeLODFactor)

R.Gunther
My mistake, where sleeping at the dekstop :O
I can set mine indeed higher then 2.0. just tried 4.0 closed the viewer and logged in again. It seems to stay at 4.0 here.

On 2014-11-11 15:49, Kay McLennan wrote:
Ai, et al,

I use the Singularity viewer (but recently switched from the 64 bit to the 32 bit -- per Fleep's instructions prior to the OSCC14) and the RenderVolumeLoadFactor functionality in the Debug menu "holds" an increase of up to and beyond 10/11.  Are you saying the essence of any change is just a "2" not a "10" (even if the load factor says "10")?

Best,
Kay


On Tue, Nov 11, 2014 at 7:08 AM, R.Gunther <[hidden email]> wrote:
Max setting is 2.0 in rendervolumelod factor.


On 2014-11-11 13:56, Ai Austin wrote:
Folks... can someone check if their Singularity 1.8.6 (latest release) allows a change in the debug setting for RenderVolumeLODFactor via Advanced - Show Debug Settings, RenderVolumeLODFactor and look at teh defalt, which I think is 1.0.

I tried setting it to 4.0 to get better mesh display but Singularity appears not to respect this setting whatever it is set to. I tried even large numbers and the rendering does not appear to change. This is also the case when relogging, but usually the change of the parameter has immediate effect.

Can someone with a mesh region check it out as I am hiking something must be odd about my setup given that we used a lot of mesh items at OSCC14.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Singularity and Mesh LOD setting (RenderVolumeLODFactor)

aiaustin
In reply to this post by aiaustin

>From: "R.Gunther" <[hidden email]>
>Max setting is 2.0 in rendervolumelod factor.

Ah, maybe I have misunderstood the setting as I normally set
RenderVolumeLODFactor to 4.0 in LL viewer and Firstorm  (the sliders
in Firestorm's quick prefs panel  definitely let you set up to 4.0)
and that renders meshes without them dropping out badly, which
happens at the lower defaults and indeed even with settings up to 3.0.

I found that some mesh that normally renders was not showing properly
at the same sort of view distance.

But maybe there are other settings affecting this.  I will experiment
more carefully tomorrow.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Singularity and Mesh LOD setting (RenderVolumeLODFactor)

aiaustin
In reply to this post by aiaustin
False alarm.. thanks for checking folks. I did more careful tests of
Singularity 1.8.6 and Firestorm 4.6.7 looking at complex mesh objects
from exactly the same viewpoint and with as near as I could tell the
same graphics quality settings, draw windows sizes, etc..

Singularity at RenderVolumeLODFactor = 2.0 drops out exactly the same
amount of mesh as Firestorm at 2.0

And when I set 4.0 (my usual setting) I see the meshes without
artifacts or drop out for my examples in both Singularity and Firestorm.

So this also confirms that Singularity takes, accepts, keeps and acts
upon a RenderVolumeLODFactor of 4 (or more).

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users