Strange behavior of the llsittarget when the primitive is rotated 90º in X

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Strange behavior of the llsittarget when the primitive is rotated 90º in X

Luisillo Contepomi
Test this please.
A prim rotate in x axe 90 and then try to modify rotation of sit target.

Use this script in a Cube
//

vector rotacion = <0,0,0> * DEG_TO_RAD;
vector posicion = <0.50, 0.0, 0.50> ;

default
{
    state_entry()
    {
        llSitTarget( posicion, llEuler2Rot(rotacion) );
   }
}

Then rotate the cube 90 º in x axe and edit for try to sit avatar up
on the cube.

Now Y rotations are Z and Z are Y and positions are bad.

My English is not enough to explain it clearly. Please use the script
and edit modify in the scripts rotations for sitting on top to see
what I am saying

Version 0.0.9.1 and all devs.

If have confirmation I will report to mantis.

Best regards,
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Strange behavior of the llsittarget when the primitive is rotated 90º in X

Luisillo Contepomi
The worst thing is that when the problem is fixed all the llsittarget
placed since 03-Sep-2018 will be badly positioned. Is a big problem
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Strange behavior of the llsittarget when the primitive is rotated 90º in X

Luisillo Contepomi
I test now in OpenSim 0.8.3.0 Dev the problem is present in this old
version too.
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users