Ubuntu 19.10 upgrade broke my mysql access to opensimulator

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Clint Ellis
I am getting an error complaining that "MySql.Data.MySqlClient.MySqlException: Authentication method 'caching_sha2_password' not supported by any of the available plugins"
Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both throw the same error.
Any ideas what is going on?

RC
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Dahlia Trimble
I don't think the mysql connector is compatible with mysql 8. I had the
same problem and I had to use 5.7.27

On Sat, Dec 7, 2019 at 7:19 PM Clint Ellis <[hidden email]> wrote:

> I am getting an error complaining that
> "MySql.Data.MySqlClient.MySqlException: Authentication method
> 'caching_sha2_password' not supported by any of the available plugins"
> Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both throw
> the same error.
> Any ideas what is going on?
>
> RC
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Opensimfan

turning off  TLS/SSL worked for me on Debian "Bullseye"
by addining "ssl=0" and/or "skip_ssl" to mysql configuration file..

- stop mysql server first and remove .pem files from mysql data folder.
- start/restart  mysql server again.


Info here:
http://tinyurl.com/y4ktppq8
http://tinyurl.com/qwlzoja



Op 8-12-2019 om 06:10 schreef Dahlia Trimble:

> I don't think the mysql connector is compatible with mysql 8. I had the
> same problem and I had to use 5.7.27
>
> On Sat, Dec 7, 2019 at 7:19 PM Clint Ellis <[hidden email]> wrote:
>
>> I am getting an error complaining that
>> "MySql.Data.MySqlClient.MySqlException: Authentication method
>> 'caching_sha2_password' not supported by any of the available plugins"
>> Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both throw
>> the same error.
>> Any ideas what is going on?
>>
>> RC
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>

--




____________________________________________________________________
Dank U - Thank You

*Twitter:*
http://twitter.com/OpenSimFan

*Facebook:*
http://www.facebook.com/andre.verwijs

*Instagram:*
André Verwijs - Instagram <https://instagram.com/dutchglory>


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
_________________________________________
OpenSimFan

My Opensim/Second Life Blog
http://verwijs.wordpress.com

(Dutch, basic hardware/software help windows, Mac, Linux)
http://verwijs-pc.nl

My Twitter Page:
http://twitter.com/OpenSimFan

My Facebook page (be my friend, please )
http://www.facebook.com/andre.verwijs

My Google+ page (follow me please )
André Verwijs - Google+
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Teravus Ovares
In reply to this post by Dahlia Trimble
I have also dealt with this with work phone systems.   The trick is
changing the authentication method for your users on your mysql server.
 The new versions of mysql use sha2 by default.  Old plugins don't support
it.   That said, you can switch back to the old authentication method
per-user in mysql with a command

On Sat, Dec 7, 2019 at 9:10 PM Dahlia Trimble <[hidden email]>
wrote:

> I don't think the mysql connector is compatible with mysql 8. I had the
> same problem and I had to use 5.7.27
>
> On Sat, Dec 7, 2019 at 7:19 PM Clint Ellis <[hidden email]> wrote:
>
> > I am getting an error complaining that
> > "MySql.Data.MySqlClient.MySqlException: Authentication method
> > 'caching_sha2_password' not supported by any of the available plugins"
> > Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both
> throw
> > the same error.
> > Any ideas what is going on?
> >
> > RC
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> >
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Drang Po
@ Teravus Ovares [hidden email]
" The new versions of mysql use sha2 by default.  Old plugins don't support
it.   That said, you can switch back to the old authentication method
per-user in mysql with a command"

what's the command?  or a webpage that gives it etc... thanks in advance

On Sun, Dec 8, 2019 at 1:14 AM Teravus Ovares <[hidden email]> wrote:

> I have also dealt with this with work phone systems.   The trick is
> changing the authentication method for your users on your mysql server.
>  The new versions of mysql use sha2 by default.  Old plugins don't support
> it.   That said, you can switch back to the old authentication method
> per-user in mysql with a command
>
> On Sat, Dec 7, 2019 at 9:10 PM Dahlia Trimble <[hidden email]>
> wrote:
>
> > I don't think the mysql connector is compatible with mysql 8. I had the
> > same problem and I had to use 5.7.27
> >
> > On Sat, Dec 7, 2019 at 7:19 PM Clint Ellis <[hidden email]>
> wrote:
> >
> > > I am getting an error complaining that
> > > "MySql.Data.MySqlClient.MySqlException: Authentication method
> > > 'caching_sha2_password' not supported by any of the available plugins"
> > > Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both
> > throw
> > > the same error.
> > > Any ideas what is going on?
> > >
> > > RC
> > > _______________________________________________
> > > Opensim-users mailing list
> > > [hidden email]
> > > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> > >
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> >
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>


--
Kalasiddhi Grid Co-Coordinator

HG: kalasiddhigrid.com:8002
Web: http://www.kalasiddhigrid.com
Buddhism in Virtual Reality

Drang Po
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Ubuntu 19.10 upgrade broke my mysql access to opensimulator

Dahlia Trimble
I found this in the meeting log from today's dev meeting:

[11:38] Andrew Hellershanks: Yup. Just found the setting in
/etc/mysql/mysql.conf.d/mysqld.cnf in the [mysqld] section.
[11:38] Andrew Hellershanks: default_authentication_plugin =
mysql_native_password

It seemed to work for me so now I'm running Mysql 8 on my Robust server and
all looks good so far.

ref: http://opensimulator.org/wiki/Chat_log_from_the_meeting_on_2019-12-10

On Tue, Dec 10, 2019 at 12:35 PM Drang Po <[hidden email]> wrote:

> @ Teravus Ovares [hidden email]
> " The new versions of mysql use sha2 by default.  Old plugins don't support
> it.   That said, you can switch back to the old authentication method
> per-user in mysql with a command"
>
> what's the command?  or a webpage that gives it etc... thanks in advance
>
> On Sun, Dec 8, 2019 at 1:14 AM Teravus Ovares <[hidden email]> wrote:
>
> > I have also dealt with this with work phone systems.   The trick is
> > changing the authentication method for your users on your mysql server.
> >  The new versions of mysql use sha2 by default.  Old plugins don't
> support
> > it.   That said, you can switch back to the old authentication method
> > per-user in mysql with a command
> >
> > On Sat, Dec 7, 2019 at 9:10 PM Dahlia Trimble <[hidden email]>
> > wrote:
> >
> > > I don't think the mysql connector is compatible with mysql 8. I had the
> > > same problem and I had to use 5.7.27
> > >
> > > On Sat, Dec 7, 2019 at 7:19 PM Clint Ellis <[hidden email]>
> > wrote:
> > >
> > > > I am getting an error complaining that
> > > > "MySql.Data.MySqlClient.MySqlException: Authentication method
> > > > 'caching_sha2_password' not supported by any of the available
> plugins"
> > > > Running MySQL 8.0, and Opensim 0.9.0 as well as OpenSim 0.9.1.  Both
> > > throw
> > > > the same error.
> > > > Any ideas what is going on?
> > > >
> > > > RC
> > > > _______________________________________________
> > > > Opensim-users mailing list
> > > > [hidden email]
> > > > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> > > >
> > > _______________________________________________
> > > Opensim-users mailing list
> > > [hidden email]
> > > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> > >
> > _______________________________________________
> > Opensim-users mailing list
> > [hidden email]
> > http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
> >
>
>
> --
> Kalasiddhi Grid Co-Coordinator
>
> HG: kalasiddhigrid.com:8002
> Web: http://www.kalasiddhigrid.com
> Buddhism in Virtual Reality
>
> Drang Po
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users