Unable to load or save OAR file.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to load or save OAR file.

Tom Haines
I am running OpenSim 0.6.6 in grid mode w/ 5 regions on Mono r139915.
I suspect this is a zlib error, but when I installed and configured mono I got the following:
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
Using system zlib

Here is the OpenSim log.
Region (Oxford) # load oar /tmp/maya3.oar
10:59:26 - [ARCHIVER]: Loading archive to region Oxford from /tmp/maya3.oar
10:59:26 - CreateZStream

Region (Oxford) # save oar /mnt/san1/oars/Oxford.oar
11:08:29 - [ARCHIVER]: Writing archive for region Oxford to /mnt/san1/oars/Oxford.oar
11:08:29 - Command error: System.EntryPointNotFoundException: CreateZStream
  at (wrapper managed-to-native) System.IO.Compression.DeflateStream:CreateZStream (System.IO.Compression.CompressionMode,bool,System.IO.Compression.DeflateStream/UnmanagedReadOrWrite)
  at System.IO.Compression.DeflateStream..ctor (System.IO.Stream compressedStream, CompressionMode mode, Boolean leaveOpen, Boolean gzip) [0x00000] 
  at (wrapper remoting-invoke-with-check) System.IO.Compression.DeflateStream:.ctor (System.IO.Stream,System.IO.Compression.CompressionMode,bool,bool)
  at System.IO.Compression.GZipStream..ctor (System.IO.Stream compressedStream, CompressionMode mode, Boolean leaveOpen) [0x00000] 
  at System.IO.Compression.GZipStream..ctor (System.IO.Stream compressedStream, CompressionMode mode) [0x00000] 
  at (wrapper remoting-invoke-with-check) System.IO.Compression.GZipStream:.ctor (System.IO.Stream,System.IO.Compression.CompressionMode)
  at OpenSim.Region.CoreModules.World.Archiver.ArchiveWriteRequestPreparation..ctor (OpenSim.Region.Framework.Scenes.Scene scene, System.String savePath, Guid requestId) [0x00000] 
  at OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion (System.String savePath, Guid requestId) [0x00000] 
  at OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion (System.String savePath) [0x00000] 
  at OpenSim.Region.Framework.Scenes.SceneManager.SaveCurrentSceneToArchive (System.String filename) [0x00000] 
  at OpenSim.OpenSim.SaveOar (System.String module, System.String[] cmdparams) [0x00000] 
  at OpenSim.Framework.Console.Commands.Resolve (System.String[] cmd) [0x00000] 
  at OpenSim.Framework.Console.LocalConsole.ReadLine (System.String p, Boolean isCommand, Boolean e) [0x00000] 
  at OpenSim.Framework.Console.CommandConsole.Prompt () [0x00000] 
  at OpenSim.Application.Main (System.String[] args) [0x00000]
Does this look like a Mono issue?


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to load or save OAR file.

justincc
Tom Haines wrote:
> I am running OpenSim 0.6.6 in grid mode w/ 5 regions on Mono r139915.
> I suspect this is a zlib error, but when I installed and configured mono
> I got the following:
> checking zlib.h usability... yes
> checking zlib.h presence... yes
> checking for zlib.h... yes
> Using system zlib

This does look like some kind of Mono issue rather than anything to do with OpenSim.

>
> Here is the OpenSim log.
> Region (Oxford) # load oar /tmp/maya3.oar
> 10:59:26 - [ARCHIVER]: Loading archive to region Oxford from /tmp/maya3.oar
> 10:59:26 - CreateZStream
>
> Region (Oxford) # save oar /mnt/san1/oars/Oxford.oar
> 11:08:29 - [ARCHIVER]: Writing archive for region Oxford to
> /mnt/san1/oars/Oxford.oar
> 11:08:29 - Command error: System.EntryPointNotFoundException: CreateZStream
>   at (wrapper managed-to-native)
> System.IO.Compression.DeflateStream:CreateZStream
> (System.IO.Compression.CompressionMode,bool,System.IO.Compression.DeflateStream/UnmanagedReadOrWrite)
>   at System.IO.Compression.DeflateStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode, Boolean leaveOpen, Boolean gzip)
> [0x00000]
>   at (wrapper remoting-invoke-with-check)
> System.IO.Compression.DeflateStream:.ctor
> (System.IO.Stream,System.IO.Compression.CompressionMode,bool,bool)
>   at System.IO.Compression.GZipStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode, Boolean leaveOpen) [0x00000]
>   at System.IO.Compression.GZipStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode) [0x00000]
>   at (wrapper remoting-invoke-with-check)
> System.IO.Compression.GZipStream:.ctor
> (System.IO.Stream,System.IO.Compression.CompressionMode)
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiveWriteRequestPreparation..ctor
> (OpenSim.Region.Framework.Scenes.Scene scene, System.String savePath,
> Guid requestId) [0x00000]
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion
> (System.String savePath, Guid requestId) [0x00000]
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion
> (System.String savePath) [0x00000]
>   at
> OpenSim.Region.Framework.Scenes.SceneManager.SaveCurrentSceneToArchive
> (System.String filename) [0x00000]
>   at OpenSim.OpenSim.SaveOar (System.String module, System.String[]
> cmdparams) [0x00000]
>   at OpenSim.Framework.Console.Commands.Resolve (System.String[] cmd)
> [0x00000]
>   at OpenSim.Framework.Console.LocalConsole.ReadLine (System.String p,
> Boolean isCommand, Boolean e) [0x00000]
>   at OpenSim.Framework.Console.CommandConsole.Prompt () [0x00000]
>   at OpenSim.Application.Main (System.String[] args) [0x00000]
> Does this look like a Mono issue?
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


--
justincc
Justin Clark-Casey
http://justincc.wordpress.com
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Unable to load or save OAR file.

Tom Haines
I just downgraded to Mono 2.4.2.3 (tarball) and this issue disappeared. I will make the Mono community aware of the issue.

On Fri, Aug 14, 2009 at 12:47 PM, Justin Clark-Casey <[hidden email]> wrote:
Tom Haines wrote:
> I am running OpenSim 0.6.6 in grid mode w/ 5 regions on Mono r139915.
> I suspect this is a zlib error, but when I installed and configured mono
> I got the following:
> checking zlib.h usability... yes
> checking zlib.h presence... yes
> checking for zlib.h... yes
> Using system zlib

This does look like some kind of Mono issue rather than anything to do with OpenSim.

>
> Here is the OpenSim log.
> Region (Oxford) # load oar /tmp/maya3.oar
> 10:59:26 - [ARCHIVER]: Loading archive to region Oxford from /tmp/maya3.oar
> 10:59:26 - CreateZStream
>
> Region (Oxford) # save oar /mnt/san1/oars/Oxford.oar
> 11:08:29 - [ARCHIVER]: Writing archive for region Oxford to
> /mnt/san1/oars/Oxford.oar
> 11:08:29 - Command error: System.EntryPointNotFoundException: CreateZStream
>   at (wrapper managed-to-native)
> System.IO.Compression.DeflateStream:CreateZStream
> (System.IO.Compression.CompressionMode,bool,System.IO.Compression.DeflateStream/UnmanagedReadOrWrite)
>   at System.IO.Compression.DeflateStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode, Boolean leaveOpen, Boolean gzip)
> [0x00000]
>   at (wrapper remoting-invoke-with-check)
> System.IO.Compression.DeflateStream:.ctor
> (System.IO.Stream,System.IO.Compression.CompressionMode,bool,bool)
>   at System.IO.Compression.GZipStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode, Boolean leaveOpen) [0x00000]
>   at System.IO.Compression.GZipStream..ctor (System.IO.Stream
> compressedStream, CompressionMode mode) [0x00000]
>   at (wrapper remoting-invoke-with-check)
> System.IO.Compression.GZipStream:.ctor
> (System.IO.Stream,System.IO.Compression.CompressionMode)
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiveWriteRequestPreparation..ctor
> (OpenSim.Region.Framework.Scenes.Scene scene, System.String savePath,
> Guid requestId) [0x00000]
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion
> (System.String savePath, Guid requestId) [0x00000]
>   at
> OpenSim.Region.CoreModules.World.Archiver.ArchiverModule.ArchiveRegion
> (System.String savePath) [0x00000]
>   at
> OpenSim.Region.Framework.Scenes.SceneManager.SaveCurrentSceneToArchive
> (System.String filename) [0x00000]
>   at OpenSim.OpenSim.SaveOar (System.String module, System.String[]
> cmdparams) [0x00000]
>   at OpenSim.Framework.Console.Commands.Resolve (System.String[] cmd)
> [0x00000]
>   at OpenSim.Framework.Console.LocalConsole.ReadLine (System.String p,
> Boolean isCommand, Boolean e) [0x00000]
>   at OpenSim.Framework.Console.CommandConsole.Prompt () [0x00000]
>   at OpenSim.Application.Main (System.String[] args) [0x00000]
> Does this look like a Mono issue?
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


--
justincc
Justin Clark-Casey
http://justincc.wordpress.com
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users