Weird issue with mysqld service restarting after Windows 8.1 upgrade

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Weird issue with mysqld service restarting after Windows 8.1 upgrade

aiaustin
After a Windows 8.1 upgrade on an OpenSim server that uses MySQL
Server 5.6 (CE) the service was not restarting.  On diging around I
have identified the problem to be the path to the mysqld command...
it seems to have lost the "/bin" part in the path!  No idea how that
could happen.

Before I take drastic action to try to fix that and risk messing up
what was a well working installation, I wonder if anyone else has
seen this or knows of a simple fix?  I am a bit reluctant to go
around messing about in the registry!

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Weird issue with mysqld service restarting after Windows 8.1 upgrade

Chris M
First thing I would do before attempting to fix the issue is make a
backup of your database; Once you've done that; check your environment
variables in System Properties > Advanced Tab > Environment Variables
and look under System Variables for Path, edit it and and see if
possibly the path to /mysql install path here/bin hasn't been removed
due to the upgrade. If it's not there then try putting that back in and
reboot your computer. If worse comes to worse I suppose you could
reinstall MySQL and then restore from your database backup if necessary
(not sure if it would get overwritten or not from a reinstall).

On 10/21/2013 6:30 AM, Ai Austin wrote:

> After a Windows 8.1 upgrade on an OpenSim server that uses MySQL
> Server 5.6 (CE) the service was not restarting.  On diging around I
> have identified the problem to be the path to the mysqld command... it
> seems to have lost the "/bin" part in the path!  No idea how that
> could happen.
>
> Before I take drastic action to try to fix that and risk messing up
> what was a well working installation, I wonder if anyone else has seen
> this or knows of a simple fix?  I am a bit reluctant to go around
> messing about in the registry!
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users


--
OpenSim: 10 Region Standalone on 0.7.6 Dev
Physics: Open Dynamics Engine
OS: Windows 7 (x64)
CPU: AMD Phenom II X4 840 3.2 GHz
Memory: 11 GB DDR3
Database: MySQL 5.1.63 (x64)

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Weird issue with mysqld service restarting after Windows 8.1 upgrade

aiaustin
In reply to this post by aiaustin

>From: Chris <[hidden email]>
>
>First thing I would do before attempting to fix the issue is make a
>backup of your database; Once you've done that; check your environment
>variables in System Properties > Advanced Tab > Environment Variables
>and look under System Variables for Path, edit it and and see if
>possibly the path to /mysql install path here/bin hasn't been removed
>due to the upgrade. If it's not there then try putting that back in and
>reboot your computer. If worse comes to worse I suppose you could
>reinstall MySQL and then restore from your database backup if necessary
>(not sure if it would get overwritten or not from a reinstall).


Thanks Chris... the path environment variable was okay and the usual
mysql and mysqld commands were being found.  It was the "MySQL"
service registration that had in it a faulty path to the myslyd
executable with the /bin stripped out, and indeed the parameter to
the --default-path removed!   Since the services area in the Task
Manager does not let you alter the executable I had to resort to
changing the registry.  But a simple change there to make it the same
as all my other MySQL 5.6 entries and it all worked again
fine.  Really peculiar upgrade issue!


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Weird issue with mysqld service restarting after Windows 8.1 upgrade

Chris M
On 10/22/2013 6:27 AM, Ai Austin wrote:

>
>> From: Chris <[hidden email]>
>>
>> First thing I would do before attempting to fix the issue is make a
>> backup of your database; Once you've done that; check your environment
>> variables in System Properties > Advanced Tab > Environment Variables
>> and look under System Variables for Path, edit it and and see if
>> possibly the path to /mysql install path here/bin hasn't been removed
>> due to the upgrade. If it's not there then try putting that back in and
>> reboot your computer. If worse comes to worse I suppose you could
>> reinstall MySQL and then restore from your database backup if necessary
>> (not sure if it would get overwritten or not from a reinstall).
>
>
> Thanks Chris... the path environment variable was okay and the usual
> mysql and mysqld commands were being found.  It was the "MySQL"
> service registration that had in it a faulty path to the myslyd
> executable with the /bin stripped out, and indeed the parameter to the
> --default-path removed!   Since the services area in the Task Manager
> does not let you alter the executable I had to resort to changing the
> registry.  But a simple change there to make it the same as all my
> other MySQL 5.6 entries and it all worked again fine.  Really peculiar
> upgrade issue!
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users

Very peculiar indeed :) Good to hear  you got it sorted out though!

--
OpenSim: 10 Region Standalone on 0.7.6 Dev
Physics: Open Dynamics Engine
OS: Windows 7 (x64)
CPU: AMD Phenom II X4 840 3.2 GHz
Memory: 11 GB DDR3
Database: MySQL 5.1.63 (x64)

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Weird issue with mysqld service restarting after Windows 8.1 upgrade

navalgandhi1989
This post has NOT been accepted by the mailing list yet.
Hi Chris,

I am facing the same problem, I am glad that you solved the issue, but it will be very helpful for other if you can post your solution here.

Thanks