Quantcast

Weird viewer crash

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Weird viewer crash

Jeff Kelley
I have a really weird issue. All of a sudden, Firestorm crashes when
tp'ing home from the hypergrid. As a variant, I can reach my home but
most prims are missing, unless I teleport to another local region
then back home, then the prims are here again.

I am speaking about a setup that was working fine for years. It
happened just following major changes to the router NAT rules. I
managed to revert back to the situation "it was working before", but
the issue persisted. I noted an excessive slowness in the router
administration console and suspected a network problem. Firing
Wireshark and bam! Tons of Spurious Retransmission, Dup ACK, RST in
the loopback route between my viewer ('amiral') and my external IP
('ns.pescadoo.net'), both ways.

http://www.pescadoo.net/tmp/wireshark-2.png

Topology is box <-> router <-> switch <-> (client, server). Checked
cables, rebooted switch and router, even upgraded the router (NETGEAR
FSV338) firmware.

Can bad network crash a viewer this way?

Is my router fried?


-- Jeff

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Missing baked texture (Was : Weird viewer crash)

Jeff Kelley
Well. The black ink in Wireshark (Spurious Retransmission, Dup ACK)
is not the *origin* of the problem. It is a *consequence* of
Firestorm crashing.

The old and venerable Imprudence do not crash, and give me an
opportunity to dig deeper. The issue is related to baked textures :

19:45:45 - [AVFACTORY]: Missing baked texture
1e9b4e3d-557c-c96a-7420-7204f6dbe044 (8) for Test User, requesting
rebake.
19:45:45 - [AVFACTORY]: Missing baked texture
8eb93d16-71c7-9406-371e-15cba27fdd6d (9) for Test User, requesting
rebake.
19:45:45 - [AVFACTORY]: Missing baked texture
e043e48f-bb6c-aaea-25be-ce7522e0740b (10) for Test User, requesting
rebake.
19:45:45 - [AVFACTORY]: Missing baked texture
7e001a31-9d58-febb-e02e-715748015640 (11) for Test User, requesting
rebake.
19:45:45 - [AVFACTORY]: Missing baked texture
bb978e35-517f-fdd0-400d-a711bc38ff52 (20) for Test User, requesting
rebake.
19:45:46 - [ASSET XFER UPLOADER]: Uploaded asset
0798cbf7-1197-6134-0db8-55e68df2afa2 for transaction
d109583d-0ff4-7e04-98e6-a832c867d2c9
19:45:48 - [ASSET XFER UPLOADER]: Uploaded asset
b74367f5-efaf-5f39-2f38-a45be55bd1d4 for transaction
23567d49-7ddc-9c40-d454-db5ada379da5
19:45:48 - [ASSET XFER UPLOADER]: Uploaded asset
79fae916-39f6-6ebc-ecfd-7b135a2b6d3b for transaction
4b7f1b14-3bfc-8e5e-4a62-358d7a984bf5
19:45:50 - [ASSET XFER UPLOADER]: Uploaded asset
f17989c7-30ad-6584-144b-d7add6a0f7d3 for transaction
55723397-2303-95dc-6406-4df2c519df97
19:45:51 - [ASSET XFER UPLOADER]: Uploaded asset
dcc013f4-9d39-536a-2f2a-c53c1ca30d07 for transaction
c5fe8787-c117-fe1d-c7d4-fdedefc101c7
19:45:51 - [AVFACTORY]: Received texture update for Test User
6dc43bf2-41dd-408e-98d4-e425d76c8c0c

And so on, ad infinitam.

It reproduces MANTIS 7031: On return to home avatar appears to
flicker, sometimes remains white.

Even on a fresh 0.8.0.2 sqlite.
Even on my old 0.8.0.2 mysql.
Even after changing host (same LAN), with a different OS and a different MONO.

So,

Configuration is not the issue.
Database is not the issue.
Network malfunction is not the issue, although network
misconfiguration could be.


-- Jeff
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Loading...