Whisper module

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Whisper module

fokides
Hi all,
 
Is anywhere available or has anyome compiled the whisper module (Whisper.dll, Ice.dll, Glacier2.dll) for opensim 0.7.5?
The dlls for the 0.7.4 version doesn't seem to work in 0.7.5 and opensim crashes.
 
Thanks in advace for your replies
 
Emmanuel Fokides

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

justincc
I'm really hoping one of the guys who wrote this module can answer but I'm not encouraged since their forum has been
colonised by spam.

I am interested in the error though - it could be something fairly simple since I believe the module still compiles even
if doesn't run.  Perhaps you could pastebin the error left in the log on the crash?

On 14/02/13 09:53, Fokides Manos wrote:

> Hi all,
> Is anywhere available or has anyome compiled the whisper module (Whisper.dll, Ice.dll, Glacier2.dll) for opensim 0.7.5?
> The dlls for the 0.7.4 version doesn't seem to work in 0.7.5 and opensim crashes.
> Thanks in advace for your replies
> Emmanuel Fokides
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
Justin Clark-Casey (justincc)
OSVW Consulting
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

fokides
Hi all again,

I' m posting part of the opensim.log where the error occurs:

APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.MissingMethodException: Method not found: 'Void
OpenSim.Region.Framework.Scenes.SceneBase.AddCommand(System.Object,
System.String, System.String, System.String,
OpenSim.Framework.CommandDelegate)'.
   at MurmurVoice.MurmurVoiceModule.Initialize(Scene scene)
   at MurmurVoice.MurmurVoiceModule.AddRegion(Scene scene)
   at
OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPl
ugin.AddRegionToModules(Scene scene)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
portadd_flag, Boolean do_post_init, IScene& mscene)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
portadd_flag, IScene& scene)
   at
OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
   at OpenSim.OpenSimBase.StartupSpecific()
   at OpenSim.OpenSim.StartupSpecific()
   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
   at OpenSim.Application.Main(String[] args)

Application is terminating: True


I believe a deleted (?) post in OsGrid forum back in December mentioned the
same problem and got no replies. I' m posting it to:


Twisted Stickfigure Post subject: Whisper module problem with 12-19-2012
release PostPosted: Fri Dec 21, 2012 9:38 am

I am having trouble getting my region server to start with this latest
release. I just updated to OSgrid OpenSimulator 0.7.5.dev.a9b9c0f - [zip]
[28.4mb] 12-19-2012 with a clean install, but when I try to start it with
mumble voice enabled I get a fatal error. It starts fine with the voice
disabled.

I have Whisper-20111110 installed, and my config files have not changed. I
missed installing the last OSGRID update but everything was running fine in
the one before.

Here is the error I get if I enable voice and try to start the region....


Code:

2012-12-21 11:30:16,274 INFO  - OpenSim.OpenSimBase [MODULES]: Loading
Region's modules (old style)
2012-12-21 11:30:16,275 INFO  - OpenSim.OpenSimBase [REGIONMODULES]: Loading
Region's modules (new style)
2012-12-21 11:30:16,282 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.MissingMethodException: Method not found:
'OpenSim.Region.Framework.Scenes.SceneBase.AddCommand'.
  at MurmurVoice.MurmurVoiceModule.AddRegion
(OpenSim.Region.Framework.Scenes.Scene scene) [0x00000] in <filename
unknown>:0
  at
OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPl
ugin.AddRegionToModules (OpenSim.Region.Framework.Scenes.Scene scene)
[0x00000] in <filename unknown>:0
  at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo
regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene)
[0x00000] in <filename unknown>:0
  at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo
regionInfo, Boolean portadd_flag, IScene& scene) [0x00000] in <filename
unknown>:0
  at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise
() [0x00000] in <filename unknown>:0
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000] in <filename
unknown>:0
  at OpenSim.OpenSim.StartupSpecific () [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in
<filename unknown>:0
  at OpenSim.Application.Main (System.String[] args) [0x00000] in <filename
unknown>:0

Application is terminating: True


I have double checked my permissions. Any Ideas?


I hope someone turns out with a solution

Regards
Emmanuel


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Justin
Clark-Casey
Sent: Saturday, February 16, 2013 4:49 AM
To: [hidden email]
Subject: Re: [Opensim-users] Whisper module

I'm really hoping one of the guys who wrote this module can answer but I'm
not encouraged since their forum has been colonised by spam.

I am interested in the error though - it could be something fairly simple
since I believe the module still compiles even if doesn't run.  Perhaps you
could pastebin the error left in the log on the crash?

On 14/02/13 09:53, Fokides Manos wrote:
> Hi all,
> Is anywhere available or has anyome compiled the whisper module
(Whisper.dll, Ice.dll, Glacier2.dll) for opensim 0.7.5?
> The dlls for the 0.7.4 version doesn't seem to work in 0.7.5 and opensim
crashes.
> Thanks in advace for your replies
> Emmanuel Fokides
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
Justin Clark-Casey (justincc)
OSVW Consulting
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

Melanie
You need a newer version of the plugin. If it's not actively
maintained, you may need to compile from source. If the source isn't
open, you will need to contact the creators.

Melanie

On 16/02/2013 11:58, Fokides Aegean wrote:

> Hi all again,
>
> I' m posting part of the opensim.log where the error occurs:
>
> APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs
>
> Exception: System.MissingMethodException: Method not found: 'Void
> OpenSim.Region.Framework.Scenes.SceneBase.AddCommand(System.Object,
> System.String, System.String, System.String,
> OpenSim.Framework.CommandDelegate)'.
>    at MurmurVoice.MurmurVoiceModule.Initialize(Scene scene)
>    at MurmurVoice.MurmurVoiceModule.AddRegion(Scene scene)
>    at
> OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPl
> ugin.AddRegionToModules(Scene scene)
>    at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
> portadd_flag, Boolean do_post_init, IScene& mscene)
>    at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean
> portadd_flag, IScene& scene)
>    at
> OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
>    at OpenSim.OpenSimBase.StartupSpecific()
>    at OpenSim.OpenSim.StartupSpecific()
>    at OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
>    at OpenSim.Application.Main(String[] args)
>
> Application is terminating: True
>
>
> I believe a deleted (?) post in OsGrid forum back in December mentioned the
> same problem and got no replies. I' m posting it to:
>
>
> Twisted Stickfigure Post subject: Whisper module problem with 12-19-2012
> release PostPosted: Fri Dec 21, 2012 9:38 am
>
> I am having trouble getting my region server to start with this latest
> release. I just updated to OSgrid OpenSimulator 0.7.5.dev.a9b9c0f - [zip]
> [28.4mb] 12-19-2012 with a clean install, but when I try to start it with
> mumble voice enabled I get a fatal error. It starts fine with the voice
> disabled.
>
> I have Whisper-20111110 installed, and my config files have not changed. I
> missed installing the last OSGRID update but everything was running fine in
> the one before.
>
> Here is the error I get if I enable voice and try to start the region....
>
>
> Code:
>
> 2012-12-21 11:30:16,274 INFO  - OpenSim.OpenSimBase [MODULES]: Loading
> Region's modules (old style)
> 2012-12-21 11:30:16,275 INFO  - OpenSim.OpenSimBase [REGIONMODULES]: Loading
> Region's modules (new style)
> 2012-12-21 11:30:16,282 ERROR - OpenSim.Application [APPLICATION]:
> APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs
>
> Exception: System.MissingMethodException: Method not found:
> 'OpenSim.Region.Framework.Scenes.SceneBase.AddCommand'.
>   at MurmurVoice.MurmurVoiceModule.AddRegion
> (OpenSim.Region.Framework.Scenes.Scene scene) [0x00000] in <filename
> unknown>:0
>   at
> OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPl
> ugin.AddRegionToModules (OpenSim.Region.Framework.Scenes.Scene scene)
> [0x00000] in <filename unknown>:0
>   at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo
> regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene)
> [0x00000] in <filename unknown>:0
>   at OpenSim.OpenSimBase.CreateRegion (OpenSim.Framework.RegionInfo
> regionInfo, Boolean portadd_flag, IScene& scene) [0x00000] in <filename
> unknown>:0
>   at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise
> () [0x00000] in <filename unknown>:0
>   at OpenSim.OpenSimBase.StartupSpecific () [0x00000] in <filename
> unknown>:0
>   at OpenSim.OpenSim.StartupSpecific () [0x00000] in <filename unknown>:0
>   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000] in
> <filename unknown>:0
>   at OpenSim.Application.Main (System.String[] args) [0x00000] in <filename
> unknown>:0
>
> Application is terminating: True
>
>
> I have double checked my permissions. Any Ideas?
>
>
> I hope someone turns out with a solution
>
> Regards
> Emmanuel
>
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of Justin
> Clark-Casey
> Sent: Saturday, February 16, 2013 4:49 AM
> To: [hidden email]
> Subject: Re: [Opensim-users] Whisper module
>
> I'm really hoping one of the guys who wrote this module can answer but I'm
> not encouraged since their forum has been colonised by spam.
>
> I am interested in the error though - it could be something fairly simple
> since I believe the module still compiles even if doesn't run.  Perhaps you
> could pastebin the error left in the log on the crash?
>
> On 14/02/13 09:53, Fokides Manos wrote:
>> Hi all,
>> Is anywhere available or has anyome compiled the whisper module
> (Whisper.dll, Ice.dll, Glacier2.dll) for opensim 0.7.5?
>> The dlls for the 0.7.4 version doesn't seem to work in 0.7.5 and opensim
> crashes.
>> Thanks in advace for your replies
>> Emmanuel Fokides
>>
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> https://lists.berlios.de/mailman/listinfo/opensim-users
>>
>
>
> --
> Justin Clark-Casey (justincc)
> OSVW Consulting
> http://justincc.org
> http://twitter.com/justincc
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

TwistedStickfigure
In reply to this post by fokides
Yes, I deleted that post fokides. I checked the authors website and it seemed inactive. The last release was for opensim 7.2 and that was compiled by Justin.  I just felt I had to let it go and get Vivox.  
Twisted Stickfigure
Twisted Labs on Osgrid
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

InuYasha Meiji
Good Idea, I love vivox.  Ever since I started using it, upgrading
Opensim and adding vivox into the ini files have been a snap.  Hehe, I
connect to voice beter in opensim sometimes more then SL.  Might be just
because it don't have all the bells and whistles of SL and the voice
changing options.  I would however one day like Vivox to include the
volume by distance thing.  Brain fart:  I can't remember the word for
it.    BEsides Mumble was a pain to explain to the new users with so
many different Operating Systems how to install it and get to make
mumble work.

InuYasha


On 2/21/2013 4:28 AM, TwistedStickfigure wrote:

> Yes, I deleted that post fokides. I checked the authors website and it seemed
> inactive. The last release was for opensim 7.2 and that was compiled by
> Justin.  I just felt I had to let it go and get Vivox.
>
>
>
> -----
> Twisted Stickfigure
> Bears Lair on Osgrid
> --
> View this message in context: http://opensim-users.2152040.n2.nabble.com/Whisper-module-tp7579498p7579539.html
> Sent from the opensim-users mailing list archive at Nabble.com.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
________________________________________________________________________
Opensim User: In Gridmode  on Version 0.7.4. Nine Instances with 56 Regions. on Windows 7, 64-bit. Phenom 9500 2.2 GHz Quad Core, Terabyte Hard Drive, 8gig DDR2 RAM.  Used XAMPP to load PHP Version 5.3.0, Apache
and MySQL 5.1.41-community edition.  Groups, Profiles, Vivox Voice and
Offline Messages all working. (Not yet Public, 10 user accounts so far).
________________________________________________________________________

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

justincc
In reply to this post by TwistedStickfigure
Honestly, I'd love to release a Mumble region module rebuild for OpenSimulator 0.7.5 but I just don't have time or
reasons of my own right now to deal with any issues on the C++/viewer plugin end.

I'm pretty sure the existing Mumble module builds against OpenSimulator 0.7.5.  It could be that it just needs to be
recompiled to update dependency references like Mono.Addins.

On 21/02/13 09:28, TwistedStickfigure wrote:

> Yes, I deleted that post fokides. I checked the authors website and it seemed
> inactive. The last release was for opensim 7.2 and that was compiled by
> Justin.  I just felt I had to let it go and get Vivox.
>
>
>
> -----
> Twisted Stickfigure
> Bears Lair on Osgrid
> --
> View this message in context: http://opensim-users.2152040.n2.nabble.com/Whisper-module-tp7579498p7579539.html
> Sent from the opensim-users mailing list archive at Nabble.com.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
Justin Clark-Casey (justincc)
OSVW Consulting
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

TwistedStickfigure
"I'm pretty sure the existing Mumble module builds against OpenSimulator 0.7.5."

I can give that a try. It should be a learning experience.  
Twisted Stickfigure
Twisted Labs on Osgrid
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

TwistedStickfigure
In reply to this post by justincc
So, It was a learning experience.  But not a success.
I followed the build instructions here.
and the 0.7.5 source from Opensimulator

  The build failed with a list of errors similar to this first set.

[csc] /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56): error CS1678: Parameter `4' is declared as type `OpenSim.Framework.Servers.HttpServer.OSHttpRequest' but should be `OpenSim.Framework.Servers.HttpServer.IOSHttpRequest'
[csc] /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56): error CS1678: Parameter `5' is declared as type `OpenSim.Framework.Servers.HttpServer.OSHttpResponse' but should be `OpenSim.Framework.Servers.HttpServer.IOSHttpResponse'
[csc] /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56): error CS1661: Cannot convert `anonymous method' to delegate type `OpenSim.Framework.Servers.HttpServer.RestMethod' since there is a parameter mismatch
[csc] /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(863,18): error CS1502: The best overloaded method match for `OpenSim.Framework.Capabilities.Caps.RegisterHandler(string, OpenSim.Framework.Servers.HttpServer.IRequestHandler)' has some invalid arguments
[csc] /home/opensim/opensim/opensim-0.7.5-source/bin/OpenSim.Capabilities.dll (Location of the symbol related to previous error)
   
If I have a list of errors and suggested solutions does that mean I need to change those parameters in the whisper source I built with?
Twisted Stickfigure
Twisted Labs on Osgrid
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

justincc
On 07/03/13 07:47, TwistedStickfigure wrote:

> So, It was a learning experience.  But not a success.
> I followed the build instructions  here
> <http://whisper.vcomm.ch/doc/0.2.0/Whisper_Murmur_Config.pdf>  .
> and the 0.7.5 source from  Opensimulator
> <http://opensimulator.org/wiki/Download>
>
>    The build failed with a list of errors similar to this first set.
>
> [csc]
> /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56):
> error CS1678: Parameter `4' is declared as type
> `OpenSim.Framework.Servers.HttpServer.OSHttpRequest' but should be
> `OpenSim.Framework.Servers.HttpServer.IOSHttpRequest'
> [csc]
> /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56):
> error CS1678: Parameter `5' is declared as type
> `OpenSim.Framework.Servers.HttpServer.OSHttpResponse' but should be
> `OpenSim.Framework.Servers.HttpServer.IOSHttpResponse'
> [csc]
> /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(865,56):
> error CS1661: Cannot convert `anonymous method' to delegate type
> `OpenSim.Framework.Servers.HttpServer.RestMethod' since there is a parameter
> mismatch
> [csc]
> /home/opensim/opensim/opensim-0.7.5-source/addon-modules/Whisper/Modules/MurmurVoiceModule.cs(863,18):
> error CS1502: The best overloaded method match for
> `OpenSim.Framework.Capabilities.Caps.RegisterHandler(string,
> OpenSim.Framework.Servers.HttpServer.IRequestHandler)' has some invalid
> arguments
> [csc]
> /home/opensim/opensim/opensim-0.7.5-source/bin/OpenSim.Capabilities.dll
> (Location of the symbol related to previous error)
>
> If I have a list of errors and suggested solutions does that mean I need to
> change those parameters in the whisper source I built with?

Yes.  There's a reasonable chance it will build if you just change the OSHttpRequest references to IOSHttpRequest instead.

--
Justin Clark-Casey (justincc)
OSVW Consulting
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Whisper module

ToddC
This post has NOT been accepted by the mailing list yet.
Hi, compiled/built the 7.5 version with the Whisper module in place.

The issue seems to be in the Whisper.dll which seems to be looking for "AddCommand" as described here:
An unhandled exception of type 'System.MissingMethodException' occurred in Whisper.dll

Additional information: Method not found: 'Void OpenSim.Region.Framework.Scenes.SceneBase.AddCommand(System.Object, System.String, System.String, System.String, OpenSim.Framework.CommandDelegate)'

But not sure does that mean it can n't find OpenSim 7.5?

Source code for Whisper.dll was not in the server "source code" just the module, as far as I can tell. Does anyone have access to Whisper.dll source?