attempt to upgrade Diva to 0.7.1 from 0.7.0.2 - crash on login

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

attempt to upgrade Diva to 0.7.1 from 0.7.0.2 - crash on login

Caia Naxos
Did a test installing 0.7.1 fresh, with a new database.  No problems. I decided to try upgrading the existing installation.  Didn't see any problems, so tried logging in.  Ran into an error: Unable to convert MySQL date/time value to System.DateTime - and then there's a crash.  In researching I found this Mantis record: #0005474 which seemed to mirror our problem. I also saw a resolution: 
The new connector has an option to allow a zero datetime, which needs to be added to the connect string.

What I need to know is which is the 'new connector' and how do I format the data to be entered - just a bit of clarification.  

Thanks!

--
Caia

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: attempt to upgrade Diva to 0.7.1 from 0.7.0.2 - crash on login

Diva Canto
First time I hear about this.
According to this:
http://dev.mysql.com/doc/refman/5.1/en/connector-net-connection-options.html
there is an Allow Zero Datetime option. According to Melanie, it looks like we need to add it to the connection string.

Edit your MyWorld.ini; your connection string should look like:
ConnectionString = "Data Source=localhost;Database=opensim;User ID=opensim;Password=***;Old Guids=true;Allow Zero Datetime=true;"

(don't forget the last ';')

Let me know if that solves the problem, and I'll add it to the default connection string in the next release. Also in OpenSim inis.

On 5/12/2011 8:37 PM, Caia Naxos wrote:
Did a test installing 0.7.1 fresh, with a new database.  No problems. I decided to try upgrading the existing installation.  Didn't see any problems, so tried logging in.  Ran into an error: Unable to convert MySQL date/time value to System.DateTime - and then there's a crash.  In researching I found this Mantis record: #0005474 which seemed to mirror our problem. I also saw a resolution: 
The new connector has an option to allow a zero datetime, which needs to be added to the connect string.

What I need to know is which is the 'new connector' and how do I format the data to be entered - just a bit of clarification.  

Thanks!

--
Caia
_______________________________________________ Opensim-users mailing list [hidden email] https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: attempt to upgrade Diva to 0.7.1 from 0.7.0.2 - crash on login

Caia Naxos
Diva: Thank you.  We put in that new bit to allow zero datetime and it seems to solve that problem - no more crashing on login, but...

I hate that there is a but and that this seems to be leading to another issue, perhaps - I am submitting another message titled "7.1 Diva Mesh Upload error?" in case 
it needs to be looked at separately.

But your solution, Diva, does address the crash on login problem - we just saw another issue that seems to be related to uploading Mesh.


On Thu, May 12, 2011 at 10:58 PM, Diva Canto <[hidden email]> wrote:
First time I hear about this.
According to this:
http://dev.mysql.com/doc/refman/5.1/en/connector-net-connection-options.html
there is an Allow Zero Datetime option. According to Melanie, it looks like we need to add it to the connection string.

Edit your MyWorld.ini; your connection string should look like:
ConnectionString = "Data Source=localhost;Database=opensim;User ID=opensim;Password=***;Old Guids=true;Allow Zero Datetime=true;"

(don't forget the last ';')

Let me know if that solves the problem, and I'll add it to the default connection string in the next release. Also in OpenSim inis.


On 5/12/2011 8:37 PM, Caia Naxos wrote:
Did a test installing 0.7.1 fresh, with a new database.  No problems. I decided to try upgrading the existing installation.  Didn't see any problems, so tried logging in.  Ran into an error: Unable to convert MySQL date/time value to System.DateTime - and then there's a crash.  In researching I found this Mantis record: #0005474 which seemed to mirror our problem. I also saw a resolution: 
The new connector has an option to allow a zero datetime, which needs to be added to the connect string.

What I need to know is which is the 'new connector' and how do I format the data to be entered - just a bit of clarification.  

Thanks!

--
Caia
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users




--
Caia

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

help with between-region crossings

Ovi Chris Rouly
In reply to this post by Diva Canto

Folks,
 
Is there a setting in the Configs that will help with between-region crossings?
 
When "walking" across regions that are contiguous my avatar momentarily freezes, drops into the scenery almost up to its waist, and then re-emerges 5-10 seconds later many, many meters farther ahead of its last controlled position than seems reasonable.
 
This is a human-controlled avatar.  My client-side NPCs experience far less of an upset when walking autonomously between regions.
 
Moreover, knowing this will happen, I usually only "barely," "timidly" hand-cross into the adjacent region (anticipating the above) and yet still encounter the very same events.
 
Thank you in advance for your advice.
 
Chris
 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: help with between-region crossings

Lindy (McKeown) Orwin
These tricks might help...lots of posts about this in the SL forums. I am assuming it should also work in OpenSim. 


Lindy

On Mon, Dec 12, 2011 at 12:58 PM, Ovi Chris Rouly <[hidden email]> wrote:
Folks,
 
Is there a setting in the Configs that will help with between-region crossings?
 
When "walking" across regions that are contiguous my avatar momentarily freezes, drops into the scenery almost up to its waist, and then re-emerges 5-10 seconds later many, many meters farther ahead of its last controlled position than seems reasonable.
 
This is a human-controlled avatar.  My client-side NPCs experience far less of an upset when walking autonomously between regions.
 
Moreover, knowing this will happen, I usually only "barely," "timidly" hand-cross into the adjacent region (anticipating the above) and yet still encounter the very same events.
 
Thank you in advance for your advice.
 
Chris
 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users




--

Lindy (McKeown) Orwin
Second Life and OpenSim Grids  - Decka Mah
Cell: 360 536 5047 (USA)
Skype Number : 07 3103 3106 (From Australian phones only)
Email: [hidden email]
Web: http://lindyorwin.com
Virtual World Project Manager:
Hypatia - A STEM Virtual World for Girls (USA)
and
SPICE Virtual Worlds for Counselling and Social Work (Australia)


"Reality is merely an illusion, albeit a very persistent one." Albert Einstein


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: help with between-region crossings

gstapltn
Just confirming.  Yes.  These tricks work in OpenSim as well.  Use them
all the time.

Jerry

On 12/12/2011 4:40 PM, Lindy Orwin wrote:

> These tricks might help...lots of posts about this in the SL forums. I am
> assuming it should also work in OpenSim.
>
> http://community.secondlife.com/t5/Building-and-Texturing-Forum/sim-crossing-trick/td-p/1179445
>
> Lindy
>
> On Mon, Dec 12, 2011 at 12:58 PM, Ovi Chris Rouly<[hidden email]>  wrote:
>
>> **
>> Folks,
>>
>> Is there a setting in the Configs that will help with between-region
>> crossings?
>>
>> When "walking" across regions that are contiguous my avatar momentarily
>> freezes, drops into the scenery almost up to its waist, and then re-emerges
>> 5-10 seconds later many, many meters farther ahead of its last controlled
>> position than seems reasonable.
>>
>> This is a human-controlled avatar.  My client-side NPCs experience far
>> less of an upset when walking autonomously between regions.
>>
>> Moreover, knowing this will happen, I usually only "barely," "timidly"
>> hand-cross into the adjacent region (anticipating the above) and yet still
>> encounter the very same events.
>>
>> Thank you in advance for your advice.
>>
>> Chris
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

question about compatibility

Ovi Chris Rouly
In reply to this post by Diva Canto

Folks,
 
we are looking at introducing a GoogleSketch-up to OpenSim building/object translation tool into one of our classes.
 
Ultimately, we need to be able to import fully built building-objects into our Sim.
 
Does anyone have any experience with the product AC3D (see links below)?
 
Thanks in advance for your advice.
 
Chris
 
 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: question about compatibility

Wade Schuette
I've only been looking at Sketchup a week and don't know all the capabilities.
I do know that supposedly the Collada  ".dae" format is one that Sketchup can export,
and one that Second Life (and I guess OpenSim) can import.     

I tried one SU to SL with one complex scene, via .dae format,  and all the objects came out on top of each other, with shapes and colors surviving and textures nowhere to be found.     Typical newbie issues.  Haven't searched out fully-worked examples yet.

I've never used AC3D.   
I see other forums talking as well about Silo3d in the low-end modeling tools (without rendering or animation)

Recent comparison, but still out of date:
http://en.wikipedia.org/wiki/Comparison_of_3D_computer_graphics_software.

Some people seem to end up with a pair of tools to cover the low and high end efficiently.

Some of Blender do their initial modeling in something else, such as Wings or Silo or perhaps AC3D, then use Blender for animation and rendering or touchup.   Still,  the initial learning curve for Blender seems to be more like 6 months than 6 days, at least for me, and it's definitely overkill for simple models.


Wade










On 2/14/12 5:22 PM, Ovi Chris Rouly wrote:
Folks,
 
we are looking at introducing a GoogleSketch-up to OpenSim building/object translation tool into one of our classes.
 
Ultimately, we need to be able to import fully built building-objects into our Sim.
 
Does anyone have any experience with the product AC3D (see links below)?
 
Thanks in advance for your advice.
 
Chris
 
 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: question about compatibility

Trinity
In reply to this post by Ovi Chris Rouly
i have yet to find a usable importable model off the scetchup gallery i think the Collaida spec they use is ether outdated or just plain wrong.

On Tue, Feb 14, 2012 at 7:22 PM, Ovi Chris Rouly <[hidden email]> wrote:
Folks,
 
we are looking at introducing a GoogleSketch-up to OpenSim building/object translation tool into one of our classes.
 
Ultimately, we need to be able to import fully built building-objects into our Sim.
 
Does anyone have any experience with the product AC3D (see links below)?
 
Thanks in advance for your advice.
 
Chris
 
 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users



_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: question about compatibility

Chris Kennedy-2
I have found that importing models from the sketchup gallery to AC3D first then reexporting it back to a new collada file seems to work fairly well for most models (I've tried about 10 different ones). Although some will upload to SL/OpenSim quite HUGE in size. And AC3D is pretty easy to use I have found; I caught on to AC3D basics much quicker than I did blender.



On 2/15/2012 4:26 AM, Trinity wrote:
i have yet to find a usable importable model off the scetchup gallery i think the Collaida spec they use is ether outdated or just plain wrong.

On Tue, Feb 14, 2012 at 7:22 PM, Ovi Chris Rouly <[hidden email]> wrote:
Folks,
 
we are looking at introducing a GoogleSketch-up to OpenSim building/object translation tool into one of our classes.
 
Ultimately, we need to be able to import fully built building-objects into our Sim.
 
Does anyone have any experience with the product AC3D (see links below)?
 
Thanks in advance for your advice.
 
Chris
 
 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users




_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users


-- 
OpenSim: 9 Region Standalone on 0.7.3 Dev
Physics: Open Dynamics Engine
OS: Windows 7 (x64)
CPU: AMD Phenom II X4 840 3.2 GHz
Memory: 11 GB DDR3
Database: MySQL 5.1.11

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users