lightshare water fog

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

lightshare water fog

paul emery
I am trying to change water fog setting to zero. such as in the atomist preset. I can do this manually using the Environmental Editor/Advanced water setting. I would like to allow avatar to do this by clicking on an object. I put the following script in a prim and expected to rez it and have it perform achieve this result. The script runs correctly but seems to have no effect on water fog. Anybody have any suggestions on what i am doing wrong. Using Imprudence 1.3.2 osgrid 0.7.3  2011-12-17 and mysql database. Help.

//This script trys to set LightShare water fog settings to zero.
//imprudence client has allow region lightshare to "always"
//opensim.ini has
// [LIghtShare]enable_windlight = true and
// [XEngine] AllowLightShareFunctions = true

integer result;
default
{
    state_entry()
        {
        llSetText("Touch to return lightshare\nto default",<1,1,1>,1);
        //llSetAlpha(1.0,ALL_SIDES);
    }        
     touch(integer num_detected)
     {
          llOwnerSay("I am being touched by " + llDetectedName(0) + ".");
          result=lsSetWindlightScene([WL_WATER_FOG_DENSITY_EXPONENT, 0.0]);
          llSay(0,"result is"+result);
     }

}
Reply | Threaded
Open this post in threaded view
|

Re: lightshare water fog

Shaun T. Erickson
I have found that in order to put LightShare settings, that are in a script, in a prim, into effect, I must select the prim in edit mode and then reset all scripts in selection, sometimes more than once.

-ste

On Jan 13, 2012, at 1:15 PM, paul emery <[hidden email]> wrote:

> I am trying to change water fog setting to zero. such as in the atomist
> preset. I can do this manually using the Environmental Editor/Advanced water
> setting. I would like to allow avatar to do this by clicking on an object. I
> put the following script in a prim and expected to rez it and have it
> perform achieve this result. The script runs correctly but seems to have no
> effect on water fog. Anybody have any suggestions on what i am doing wrong.
> Using Imprudence 1.3.2 osgrid 0.7.3  2011-12-17 and mysql database. Help.
>
> //This script trys to set LightShare water fog settings to zero.
> //imprudence client has allow region lightshare to "always"
> //opensim.ini has
> // [LIghtShare]enable_windlight = true and
> // [XEngine] AllowLightShareFunctions = true
>
> integer result;
> default
> {
>    state_entry()
>        {
>        llSetText("Touch to return lightshare\nto default",<1,1,1>,1);
>        //llSetAlpha(1.0,ALL_SIDES);
>    }        
>     touch(integer num_detected)
>     {
>          llOwnerSay("I am being touched by " + llDetectedName(0) + ".");
>          result=lsSetWindlightScene([WL_WATER_FOG_DENSITY_EXPONENT, 0.0]);
>          llSay(0,"result is"+result);
>     }
>
> }
>
>
> --
> View this message in context: http://opensim-users.2152040.n2.nabble.com/lightshare-water-fog-tp7184991p7184991.html
> Sent from the opensim-users mailing list archive at Nabble.com.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: lightshare water fog

paul emery
Well I tried multiple rez's and different prims. Still no luck. I am wondering if anybody can see something wrong with my script or if they could try it to see if my sim/client set up is incorrect.
Thanks for any help.