(no subject)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

(no subject)

paul emery

Hi,

 

Have been trying to save Oar from my osgrid linked region and then load to a Diva 4 region stand alone. Can't seem to get it to work. Any hints.

 

Paul Emery/Casias Falta

http://3dcolab.com

 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

Fleep Tuque
On Wed, Dec 22, 2010 at 3:09 PM, Paul Emery <[hidden email]> wrote:

Have been trying to save Oar from my osgrid linked region and then load to a Diva 4 region stand alone. Can't seem to get it to work. Any hints.


Hi Paul,

What happens when you try to load the oar file?  What command are you using?  Do you see any error messages on the console when you try to load it?

I've been able to successfully load oar files saved from my OSGrid region to a Diva Distro standalone, though haven't tried it recently.  I don't recall having any problems..

- Fleep


Chris M. Collins (SL: Fleep Tuque)
Project Manager, UC Second Life 
Second Life Ambassador, Ohio Learning Network 
UCit Instructional & Research Computing
University of Cincinnati 
406E Zimmer Hall
PO Box 210088
Cincinnati, OH 45221-0088
(513)556-3018


 

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

justincc
On 22/12/10 22:11, Fleep Tuque wrote:

> On Wed, Dec 22, 2010 at 3:09 PM, Paul Emery <[hidden email] <mailto:[hidden email]>> wrote:
>
>     Have been trying to save Oar from my osgrid linked region and then load to a Diva 4 region stand alone. Can't seem
>     to get it to work. Any hints.
>
>
> Hi Paul,
>
> What happens when you try to load the oar file?  What command are you using?  Do you see any error messages on the
> console when you try to load it?
>
> I've been able to successfully load oar files saved from my OSGrid region to a Diva Distro standalone, though haven't
> tried it recently.  I don't recall having any problems..

Hi Paul (and Fleep).  What I suspect you're seeing is errors like this when you try to load the oar.

2010-12-21 22:16:39,700 ERROR - OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer [SERIALIZER]:
Deserialization of xml failed with System.InvalidOperationException: There is an error in XML document. --->
System.InvalidOperationException: 'Scripted,' is not a valid value for OpenMetaverse.PrimFlags.

This is because the default object serialization format in the master dev branch briefly changed between about 17 Oct to
29 Nov in a way that was not backward compatible with older OpenSim releases (including the current Diva distro).  After
29 Nov, the format became backwards compatible again.

Because the OSGrid distro follows the development branch, this leaves a small window where OARs were saved with
non-backward compatible object serialization formats.

If this is the problem, then I suggest loading the OARs back into the most current OSGrid distro and saving them out
again.  This should give them the uptodate backward compatible format.

On older OSGrid distros there will also have been a --version switch on "save oar" which could save out the old object
format.  However, since Dec 11 this switch has been dropped as it's doesn't currently do anything significant.

Of course Paul, you could be experiencing something else entirely, in which case we would need answers to the questions
that Fleep asks, and data such as version numbers of the osgrid and diva distros.

--
Justin Clark-Casey (justincc)
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: (no subject)

paul emery
> >     Have been trying to save Oar from my osgrid linked region and
> then load to a Diva 4 region stand alone. Can't seem
> >     to get it to work. Any hints.
> >
> > What happens when you try to load the oar file?  What command are you
> using?  Do you see any error messages on the
> > console when you try to load it?

> What I suspect you're seeing is errors like this
> when you try to load the oar.
>
> 2010-12-21 22:16:39,700 ERROR -
> OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer
> [SERIALIZER]:
> Deserialization of xml failed with System.InvalidOperationException:
> There is an error in XML document. --->
> System.InvalidOperationException: 'Scripted,' is not a valid value for
> OpenMetaverse.PrimFlags.

> If this is the problem, then I suggest loading the OARs back into the most

> current OSGrid distro and saving them out again.  This should give them
the
> uptodate backward compatible format.


Yep that's pretty much the error except it is 'Phantom,' rather than
'Scripted,'

BTW The terrain loads and opensim.exe doesn't crash. Imprudence shows the
terrain to the avatar but no objects are created. The oar file was saved on
dec 14 from opensim.exe osgrid 0.7.1 (Dev) ed26376 2010-12-14. and the diva
distro that I am trying to put it into is diva-r13981. So in effect the OAR
that will not load into diva WAS created with a current opensim instance.

I will however try loading the oar back to our OSGrid region and resaving
and see if that does the trick. Thanks for the help.

Paul Emery
 


_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users