ossearch module fail on 0.8.1rc1

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
Hi all,
I am using the same dll "OpenSimSearch.Modules.dll" (Rev 216) as I have
working on version 0.8.0.3 but fail on 0.8.1rc1  version.

Robust console show this warning twice:

----------------------------
12:39:25 - [SERVER]: UserProfilesConnector loaded successfully
WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
'/OpenSim/RegionModules', but there isn't any add-in defining this
extension point
WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
'/OpenSim/RegionModules/OpenSimSearch.Modules.OpenSearch.OpenSearchModule',
but there isn't any add-
in defining this extension point
-----------------------------

What I am forgetting?

Thank you.
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

hack13
have you attempted to compile it with the source?

--
  Timothy Rogers
  [hidden email]

On Fri, Feb 6, 2015, at 06:49 AM, Luisillo Contepomi wrote:

> Hi all,
> I am using the same dll "OpenSimSearch.Modules.dll" (Rev 216) as I have
> working on version 0.8.0.3 but fail on 0.8.1rc1  version.
>
> Robust console show this warning twice:
>
> ----------------------------
> 12:39:25 - [SERVER]: UserProfilesConnector loaded successfully
> WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
> '/OpenSim/RegionModules', but there isn't any add-in defining this
> extension point
> WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
> '/OpenSim/RegionModules/OpenSimSearch.Modules.OpenSearch.OpenSearchModule',
> but there isn't any add-
> in defining this extension point
> -----------------------------
>
> What I am forgetting?
>
> Thank you.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
El 06/02/2015 a las 14:06, Timothy Rogers escribió:
> have you attempted to compile it with the source?
>

No.
Because the module has not been modified from Tue May 13 23:39:49 2014
UTC (8 months, 3 weeks ago).

This dll work fine with 0.8.0.3

Im testing in windows 7 -64


http://forge.opensimulator.org/gf/project/ossearch/scmsvn/?action=browse&path=%2Ftrunk%2Fbin%2FOpenSimSearch.Modules.dll&view=log



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Shaun T. Erickson
On 2/6/15 8:22 AM, Luisillo Contepomi wrote:

> El 06/02/2015 a las 14:06, Timothy Rogers escribió:
>> have you attempted to compile it with the source?
>>
>
> No.
> Because the module has not been modified from Tue May 13 23:39:49 2014
> UTC (8 months, 3 weeks ago).
>
> This dll work fine with 0.8.0.3
>
> Im testing in windows 7 -64
>
>
> http://forge.opensimulator.org/gf/project/ossearch/scmsvn/?action=browse&path=%2Ftrunk%2Fbin%2FOpenSimSearch.Modules.dll&view=log

Diva made changes to Core that require existing modules to make some
code changes before they will work with 0.8.1. This is all documented in
the Wiki, I believe.

-ste
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
Hi Shaun,
  I am not using Diva distro.
I am using opensim from source
http://dist.opensimulator.org/opensim-0.8.1-rc1-source.tar.gz

Please can you post the link to the wiki page where are documented?

I Know only http://opensimulator.org/wiki/OpenSimSearch

Thank you for answer.
Kinds regards,
Luisillo


> Diva made changes to Core that require existing modules to make some
> code changes before they will work with 0.8.1. This is all documented in
> the Wiki, I believe.
>
> -ste
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
In reply to this post by hack13
Compiled from the trunk show the same error.


WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
'/OpenSim/RegionModu
les', but there isn't any add-in defining this extension point
WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
'/OpenSim/RegionModu
les/OpenSimSearch.Modules.OpenSearch.OpenSearchModule', but there isn't
any add-
in defining this extension point

El 06/02/2015 a las 14:06, Timothy Rogers escribió:
> have you attempted to compile it with the source?
>

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

R.Gunther
Is the OpenSimSearch updated for the latest 0.8.1 version. because diva
changed code in core.
And core means also the normal opensim that yuo compile from source is
changed.
See previous posts.

On 2015-02-06 16:00, Luisillo Contepomi wrote:

> Compiled from the trunk show the same error.
>
>
> WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
> '/OpenSim/RegionModu
> les', but there isn't any add-in defining this extension point
> WARNING: The add-in 'OpenSimSearch,0.3' is trying to extend
> '/OpenSim/RegionModu
> les/OpenSimSearch.Modules.OpenSearch.OpenSearchModule', but there
> isn't any add-
> in defining this extension point
>
> El 06/02/2015 a las 14:06, Timothy Rogers escribió:
>> have you attempted to compile it with the source?
>>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
El 06/02/2015 a las 16:15, R.Gunther escribió:

> See previous posts.
>

Excuseme but I can not find any post in this list about this issue with
search or other modules and 0.8.1rc1 version


 > Is the OpenSimSearch updated for the latest 0.8.1 version. because
 > diva changed code in core.
 > And core means also the normal opensim that yuo compile from source >
  is changed.

I am confused.

Mean this that http://opensimulator.org/wiki/OpenSimSearch is deprecated
and all we "must" to use diva distro in the future?

By other hand last diva-r25084 have not the library
"OpenSimSearch.Modules.dll"

I am thinking wait for the 0.8.1. Something has been lost in the new
core if we can not use the search module.

Thank you for answer R.

Kindest regards,
Luisillo



_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Shaun T. Erickson
On 2/6/15 10:43 AM, Luisillo Contepomi wrote:

> El 06/02/2015 a las 16:15, R.Gunther escribió:
>
>> See previous posts.
>>
>
> Excuseme but I can not find any post in this list about this issue
> with search or other modules and 0.8.1rc1 version
>
>
> > Is the OpenSimSearch updated for the latest 0.8.1 version. because
> > diva changed code in core.
> > And core means also the normal opensim that yuo compile from source
> >  is changed.
>
> I am confused.
>
> Mean this that http://opensimulator.org/wiki/OpenSimSearch is
> deprecated and all we "must" to use diva distro in the future?
>
> By other hand last diva-r25084 have not the library
> "OpenSimSearch.Modules.dll"
>
> I am thinking wait for the 0.8.1. Something has been lost in the new
> core if we can not use the search module.
>
> Thank you for answer R.
>
> Kindest regards,
> Luisillo

You misunderstand.

Diva made changes to Core OpenSim Development code. The code that is
going to become 0.8.1, which you are running a release candidate of.
This has nothing to do with her separate "diva distribution".

It is simply a change for the next version of OpenSim. Module writers
need to update their modules so that they will work with the next
version of OpenSim.

http://opensimulator.org/wiki/Developing_OpenSim_Addins
http://opensimulator.org/wiki/Installing_3rd_party_addins

-ste
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

ssm2017
you can compile the ossearch module at the same time as the opensimulator core and then you will get a new dll.
i have confirmed that the ossearch module is working on my installation but not the osprofile.
osprofile is not displaying any error, it is just displaying nothing inworld.

2015-02-06 17:00 GMT+01:00 Shaun T. Erickson <[hidden email]>:
On 2/6/15 10:43 AM, Luisillo Contepomi wrote:
El 06/02/2015 a las 16:15, R.Gunther escribió:

See previous posts.


Excuseme but I can not find any post in this list about this issue with search or other modules and 0.8.1rc1 version


> Is the OpenSimSearch updated for the latest 0.8.1 version. because
> diva changed code in core.
> And core means also the normal opensim that yuo compile from source >  is changed.

I am confused.

Mean this that http://opensimulator.org/wiki/OpenSimSearch is deprecated and all we "must" to use diva distro in the future?

By other hand last diva-r25084 have not the library "OpenSimSearch.Modules.dll"

I am thinking wait for the 0.8.1. Something has been lost in the new core if we can not use the search module.

Thank you for answer R.

Kindest regards,
Luisillo

You misunderstand.

Diva made changes to Core OpenSim Development code. The code that is going to become 0.8.1, which you are running a release candidate of. This has nothing to do with her separate "diva distribution".

It is simply a change for the next version of OpenSim. Module writers need to update their modules so that they will work with the next version of OpenSim.

http://opensimulator.org/wiki/Developing_OpenSim_Addins
http://opensimulator.org/wiki/Installing_3rd_party_addins

-ste

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: ossearch module fail on 0.8.1rc1

Luisillo Contepomi-2
In reply to this post by Shaun T. Erickson
El 06/02/2015 a las 17:00, Shaun T. Erickson escribió:
> It is simply a change for the next version of OpenSim. Module writers
> need to update their modules so that they will work with the next
> version of OpenSim.
>
> http://opensimulator.org/wiki/Developing_OpenSim_Addins
> http://opensimulator.org/wiki/Installing_3rd_party_addins


Thank you very much Shaun!.
I understand now.
  kindest regards
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users