osslEnable.ini do not work.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

osslEnable.ini do not work.

Luisillo Contepomi
Using my OpenSim.ini from released 0.9.0.1 in
0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
fail
in OpenSim.ini

[NPC]
    ;# {Enabled} {} {Enable Non Player Character (NPC) facilities}
{true false} false
     Enabled = true
....


[OSSL]
    Include-osslEnable = "config-include/osslEnable.ini"


OpenSim.log red lines as:

I2018-09-08 23:28:07,403 DEBUG [SCRIPT INSTANCE]: OSSL Runtime Error:
osNpcRemove permission denied.  All OS functions are disabled.

this is only in 0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
released 0.9.0.1 all OS functions work fine.
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: osslEnable.ini do not work.

AJLDuarte
Hi,
        Using ini files from one version on another is a invite to fail.
        So you got it :)
        Apply to 0.9.1.0dev ini files your changes, using the ini files from
0.9.0.1 just as reference

Regards,
Ubit

PS: that ossl fail is because a change on the section name in file
osslEnable.ini
But other things changed, and it only takes a line to cause issues.


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Luisillo
Contepomi
Sent: Saturday, September 08, 2018 22:50
To: [hidden email]
Subject: [Opensim-users] osslEnable.ini do not work.

Using my OpenSim.ini from released 0.9.0.1 in
0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
fail
in OpenSim.ini

[NPC]
    ;# {Enabled} {} {Enable Non Player Character (NPC) facilities}
{true false} false
     Enabled = true
....


[OSSL]
    Include-osslEnable = "config-include/osslEnable.ini"


OpenSim.log red lines as:

I2018-09-08 23:28:07,403 DEBUG [SCRIPT INSTANCE]: OSSL Runtime Error:
osNpcRemove permission denied.  All OS functions are disabled.

this is only in 0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
released 0.9.0.1 all OS functions work fine.
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: osslEnable.ini do not work.

Luisillo Contepomi
Thank you very much Ubit. :-)
Yes was the change on the section name [XEngine] now is named [OSSL]
in osslEnable.ini file
Now all is working perfectly.
Best regards,
Luisillo
El dom., 9 sept. 2018 a las 2:11, AJLDuarte (<[hidden email]>) escribió:

>
> Hi,
>         Using ini files from one version on another is a invite to fail.
>         So you got it :)
>         Apply to 0.9.1.0dev ini files your changes, using the ini files from
> 0.9.0.1 just as reference
>
> Regards,
> Ubit
>
> PS: that ossl fail is because a change on the section name in file
> osslEnable.ini
> But other things changed, and it only takes a line to cause issues.
>
>
> -----Original Message-----
> From: [hidden email]
> [mailto:[hidden email]] On Behalf Of Luisillo
> Contepomi
> Sent: Saturday, September 08, 2018 22:50
> To: [hidden email]
> Subject: [Opensim-users] osslEnable.ini do not work.
>
> Using my OpenSim.ini from released 0.9.0.1 in
> 0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
> fail
> in OpenSim.ini
>
> [NPC]
>     ;# {Enabled} {} {Enable Non Player Character (NPC) facilities}
> {true false} false
>      Enabled = true
> ....
>
>
> [OSSL]
>     Include-osslEnable = "config-include/osslEnable.ini"
>
>
> OpenSim.log red lines as:
>
> I2018-09-08 23:28:07,403 DEBUG [SCRIPT INSTANCE]: OSSL Runtime Error:
> osNpcRemove permission denied.  All OS functions are disabled.
>
> this is only in 0.9.0.1dev commit f466c56ba4316e839591a05ae9d704091d3cc639
> released 0.9.0.1 all OS functions work fine.
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: osslEnable.ini do not work.

aiaustin
In reply to this post by Luisillo Contepomi

>From: Luisillo Contepomi <[hidden email]>
>
>Yes was the change on the section name [XEngine] now is named [OSSL]
>in osslEnable.ini file


This change for the Dev Master branch, to accommodate the
introduction of the alternative YEngine is easy to miss.  I
thoroughly checked all my working previous config .ini files and
found this was the ONLY change I had to make to continue.

As @Ubit indicated its wise to make sure .ini files are up to
date  and based on the latest examples, but for those keeping things
up to date as changes occur,. for the next release based on dev
master I suggest that explicit attention in the announcement is drawn
to this change and it be highlighted prominently in the changes and
release notes to avoid a lot of simple issues for upgraders.

I assume it will apply for OSGrid region add-on people as well when
OSGrid updates to a released based on latest Dev Master (latest
OSGrid packaged version is from 5-Apr-2018 ).  Anyone with a modified
osslEnable.ini will be impacted there too.




_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: osslEnable.ini do not work.

Gwyneth Llewelyn
Note that this change is not trivial. Most macros that I’ve got on the osslEnable.ini file still use {XEngine} as opposed to {OSSL}. As I tinkered around with this, ultimately I got a completely useless configuration and could not revert it back — even getting rid of macros and explicitly writing out all permissions did not work. As a consequence, I had to go back to the last stable version — just to find out that my tinkered configuration is now broken beyond repair :-) and I have to basically check each line by itself…

BTW, this is not a complaint, just a warning — I’m actually quite curious about the work being done on the YEngine and wonder how that will work out in the end.

One solution for the eventual release of this change is to have the INI parser accept, for a while, both configuration type directives (especially for those who will continue to use XEngine), but perhaps this is not feasible...

   - Gwyn

> On 12 Sep 2018, at 09:58 , Ai Austin <[hidden email]> wrote:
>
>
>> From: Luisillo Contepomi <[hidden email]>
>>
>> Yes was the change on the section name [XEngine] now is named [OSSL] in osslEnable.ini file
>
>
> This change for the Dev Master branch, to accommodate the introduction of the alternative YEngine is easy to miss.  I thoroughly checked all my working previous config .ini files and found this was the ONLY change I had to make to continue.
>
> As @Ubit indicated its wise to make sure .ini files are up to date  and based on the latest examples, but for those keeping things up to date as changes occur,. for the next release based on dev master I suggest that explicit attention in the announcement is drawn to this change and it be highlighted prominently in the changes and release notes to avoid a lot of simple issues for upgraders.
>
> I assume it will apply for OSGrid region add-on people as well when OSGrid updates to a released based on latest Dev Master (latest OSGrid packaged version is from 5-Apr-2018 ).  Anyone with a modified osslEnable.ini will be impacted there too.
>
>
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
--
"I'm not building a game. I'm building a new country."
  -- Philip "Linden" Rosedale, interview to Wired, 2004-05-08
Reply | Threaded
Open this post in threaded view
|

Re: osslEnable.ini do not work.

AJLDuarte
Hi
        Sorry happened to you config, but things seem working fine
        Did you tried using the new master file, then adding your macros?
        Yes.. line by line is a pain we all hate it...
        Macros are a Nini thing only, code gets them expanded.
        Of course Nini and API also hate any typo
        Hope you get it sorted
Ubit



-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Gwyneth Llewelyn
Sent: Wednesday, September 12, 2018 11:09
To: [hidden email]
Subject: Re: [Opensim-users] osslEnable.ini do not work.

Note that this change is not trivial. Most macros that I’ve got on the osslEnable.ini file still use {XEngine} as opposed to {OSSL}. As I tinkered around with this, ultimately I got a completely useless configuration and could not revert it back — even getting rid of macros and explicitly writing out all permissions did not work. As a consequence, I had to go back to the last stable version — just to find out that my tinkered configuration is now broken beyond repair :-) and I have to basically check each line by itself…

BTW, this is not a complaint, just a warning — I’m actually quite curious about the work being done on the YEngine and wonder how that will work out in the end.

One solution for the eventual release of this change is to have the INI parser accept, for a while, both configuration type directives (especially for those who will continue to use XEngine), but perhaps this is not feasible...

   - Gwyn

> On 12 Sep 2018, at 09:58 , Ai Austin <[hidden email]> wrote:
>
>
>> From: Luisillo Contepomi <[hidden email]>
>>
>> Yes was the change on the section name [XEngine] now is named [OSSL] in osslEnable.ini file
>
>
> This change for the Dev Master branch, to accommodate the introduction of the alternative YEngine is easy to miss.  I thoroughly checked all my working previous config .ini files and found this was the ONLY change I had to make to continue.
>
> As @Ubit indicated its wise to make sure .ini files are up to date  and based on the latest examples, but for those keeping things up to date as changes occur,. for the next release based on dev master I suggest that explicit attention in the announcement is drawn to this change and it be highlighted prominently in the changes and release notes to avoid a lot of simple issues for upgraders.
>
> I assume it will apply for OSGrid region add-on people as well when OSGrid updates to a released based on latest Dev Master (latest OSGrid packaged version is from 5-Apr-2018 ).  Anyone with a modified osslEnable.ini will be impacted there too.
>
>
>
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users