save iar authentication issues

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

save iar authentication issues

Paul Fishwick
Thought I'd try out the IAR capability but cannot get it to work under Unix
or Windows - my user "Test User" is logged into the region but there is an
authentication issue - the "password" is correct since I use it on the
SL client
Also "myIP" is my external IP that is used and implemented in OpenSim.ini

The opensim version is 0.6.7-post-fixes, with a 2x2 Standalone, Hypergrid
enabled.

Any ideas? Must be missing something simple....

.......

Region (root) # save iar Test User / password
21:42:41 - [INVENTORY ARCHIVER]: PLEASE NOTE THAT THIS FACILITY IS
EXPERIMENTAL.
  BUG REPORTS WELCOME.
21:42:41 - [INVENTORY ARCHIVER]: Saving archive user-inventory.iar from
inventory path / for Test User
21:42:41 - [INVENTORY ARCHIVER]: Could not authenticate password, XMLRPC
method
'authenticate_user_by_password' not yet implemented by user service at
http://myIP:9000
Region (root) #

--
Paul Fishwick, PhD
Professor
University of Florida
CISE Department, CSE 301
Gainesville, FL 32611
Email: [hidden email]
Web: http://www.cise.ufl.edu/~fishwick

_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: save iar authentication issues

Diva Canto
I think that bug has been fixed since 0.6.7-post-fixes.

Paul Fishwick wrote:

> Thought I'd try out the IAR capability but cannot get it to work under Unix
> or Windows - my user "Test User" is logged into the region but there is an
> authentication issue - the "password" is correct since I use it on the
> SL client
> Also "myIP" is my external IP that is used and implemented in OpenSim.ini
>
> The opensim version is 0.6.7-post-fixes, with a 2x2 Standalone, Hypergrid
> enabled.
>
> Any ideas? Must be missing something simple....
>
> .......
>
> Region (root) # save iar Test User / password
> 21:42:41 - [INVENTORY ARCHIVER]: PLEASE NOTE THAT THIS FACILITY IS
> EXPERIMENTAL.
>   BUG REPORTS WELCOME.
> 21:42:41 - [INVENTORY ARCHIVER]: Saving archive user-inventory.iar from
> inventory path / for Test User
> 21:42:41 - [INVENTORY ARCHIVER]: Could not authenticate password, XMLRPC
> method
> 'authenticate_user_by_password' not yet implemented by user service at
> http://myIP:9000
> Region (root) #
>
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Trying the load and save IAR

Karen_Palen
Just tried out the save IAR and it works great with OpenSim Diva-r11651, Linux/Ubuntu 9.10!

A couple of minor problems:

1) If the syntax of the load iar or save iar is incorrect the command line never gets onto the Gnome Terminal scrollback stack.  Scrollback is a very useful feature for someone like me who has to make several tries to get the entire line typo free! (BTW this feature is not found in Windows command line mode.)

2) The save iar identified 12 files with missing components, but did not appear to name them anywhere! I suspect that these were objects in which I accidentally deleted the texture files (OOPS!). The Clothing directory which I dumped already has 440 files in it, so it sure would be nice to identify any bad files so they can be fixed.


     
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Trying the load and save IAR

justincc
Karen Palen wrote:
> Just tried out the save IAR and it works great with OpenSim Diva-r11651, Linux/Ubuntu 9.10!
>
> A couple of minor problems:
>
> 1) If the syntax of the load iar or save iar is incorrect the command line never gets onto the Gnome Terminal scrollback stack.  Scrollback is a very useful feature for someone like me who has to make several tries to get the entire line typo free! (BTW this feature is not found in Windows command line mode.)

Yep, this is an issue that's annoyed me too :)  I'm sure this could be tweaked
so that exception causing commands are still saved in command history.  Of
course, if anyone else wants to make a patch... :)

>
> 2) The save iar identified 12 files with missing components, but did not appear to name them anywhere! I suspect that these were objects in which I accidentally deleted the texture files (OOPS!). The Clothing directory which I dumped already has 440 files in it, so it sure would be nice to identify any bad files so they can be fixed.

Good idea.  Unfortunately, it's not a straightforward fix since only missing
asset uuids are currently saved but it would be a helpful thing to have.

--
Justin Clark-Casey (justincc)
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: save iar authentication issues

justincc
In reply to this post by Diva Canto
[hidden email] wrote:
> I think that bug has been fixed since 0.6.7-post-fixes.

The save and load iar commands exist in 0.6.7 (and before) but there's no
guarantee that they completely work properly.  0.6.8.RC1 does contain all the
present iar related fixes, though I know you're having other problems with this
version.

And I too remember Diva doing a fix for using iars with Hypergrids a month or so
ago :) (so post 0.6.7).

>
> Paul Fishwick wrote:
>> Thought I'd try out the IAR capability but cannot get it to work under Unix
>> or Windows - my user "Test User" is logged into the region but there is an
>> authentication issue - the "password" is correct since I use it on the
>> SL client
>> Also "myIP" is my external IP that is used and implemented in OpenSim.ini
>>
>> The opensim version is 0.6.7-post-fixes, with a 2x2 Standalone, Hypergrid
>> enabled.
>>
>> Any ideas? Must be missing something simple....
>>
>> .......
>>
>> Region (root) # save iar Test User / password
>> 21:42:41 - [INVENTORY ARCHIVER]: PLEASE NOTE THAT THIS FACILITY IS
>> EXPERIMENTAL.
>>   BUG REPORTS WELCOME.
>> 21:42:41 - [INVENTORY ARCHIVER]: Saving archive user-inventory.iar from
>> inventory path / for Test User
>> 21:42:41 - [INVENTORY ARCHIVER]: Could not authenticate password, XMLRPC
>> method
>> 'authenticate_user_by_password' not yet implemented by user service at
>> http://myIP:9000
>> Region (root) #
>>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


--
Justin Clark-Casey (justincc)
http://justincc.org
http://twitter.com/justincc
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Trying the load and save IAR

Karen_Palen
In reply to this post by justincc
1) I will put it onto my stack - expect execution in 2020 :-)

2) I agree that anything more than the UUID could be very difficult or impossible to figure out. If the information is not there you really are guessing! That being said, just the UUIDs (in a log file!) would be very helpful.

Karen

--- On Thu, 12/10/09, Justin Clark-Casey <[hidden email]> wrote:

> From: Justin Clark-Casey <[hidden email]>
> Subject: Re: [Opensim-users] Trying the load and save IAR
> To: [hidden email]
> Date: Thursday, December 10, 2009, 11:02 AM
> Karen Palen wrote:
> > Just tried out the save IAR and it works great with
> OpenSim Diva-r11651, Linux/Ubuntu 9.10!
> >
> > A couple of minor problems:
> >
> > 1) If the syntax of the load iar or save iar is
> incorrect the command line never gets onto the Gnome
> Terminal scrollback stack.  Scrollback is a very useful
> feature for someone like me who has to make several tries to
> get the entire line typo free! (BTW this feature is not
> found in Windows command line mode.)
>
> Yep, this is an issue that's annoyed me too :)  I'm
> sure this could be tweaked
> so that exception causing commands are still saved in
> command history.  Of
> course, if anyone else wants to make a patch... :)
>
> >
> > 2) The save iar identified 12 files with missing
> components, but did not appear to name them anywhere! I
> suspect that these were objects in which I accidentally
> deleted the texture files (OOPS!). The Clothing directory
> which I dumped already has 440 files in it, so it sure would
> be nice to identify any bad files so they can be fixed.
>
> Good idea.  Unfortunately, it's not a straightforward
> fix since only missing
> asset uuids are currently saved but it would be a helpful
> thing to have.
>
> --
> Justin Clark-Casey (justincc)
> http://justincc.org
> http://twitter.com/justincc
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> https://lists.berlios.de/mailman/listinfo/opensim-users
>


     
_______________________________________________
Opensim-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/opensim-users