simian grid still in use?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

simian grid still in use?

AJLDuarte
Hi,

     Simian Grid was a alternative to Robust gird services from
openmetaverse foundation
(https://github.com/openmetaversefoundation/simiangrid).

     Seems all activity on that project stopped about 7 years ago.

    Despite our interest in maintaining old code, the presence of it
entails maintenance costs and worse hinders the evolution of the
remaining code.

    This effort makes no sense if no one has an interest in this ancient
code.

     Please let us know if you still use it or if we can drop it.

Regards,

Ubit


_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Old ODE still to keep?

AJLDuarte
Hi,

     Old ODE physics module was rendered obsolete with the introduction
of BulletSim physics module, back in 2012, and even more with the
introduction of ubODE on 0.9x series.

     Old ODE engine is very different from the new ones, in particular
on lsl vehicle model simulation, reason why we still keep it.

     But changes on the rest of the region code, in particular LSL/OSSL
functions, made the old content dependent on it, to have other issues.

     Its support increases the difficulty of improving the rest of the
simulation (in this case also the unmanaged c/c++ support library i.e.
modified Open Dynamics Engine.

     Please let us know if you still need it, or we can drop it...

Regards,

Ubit.

_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Old ODE still to keep?

Peter Gloor
I don't know about others, but personally I don't need legacy ODE any
longer as I'm already running my regions either on BulletSim or ubODE.
Looking back I think it was worth the effort in changing the LSL scripts
where needed. However, not everybody will be able to do this.

My primary home grid, Metropolis, changed from ODE to BulletSim as
default when they moved to Opensim 0.9 about 9 months ago. I placed a call
for feedback on their forum today.

Regarding the underlying unmanaged c/c++ support library, wouldn't it be
possible to keep it and to use a new and better one for ubODE in parallel?

Regards,
Pius Noel

Am So., 1. Dez. 2019 um 16:52 Uhr schrieb Leal Duarte <[hidden email]>:

> Hi,
>
>      Old ODE physics module was rendered obsolete with the introduction
> of BulletSim physics module, back in 2012, and even more with the
> introduction of ubODE on 0.9x series.
>
>      Old ODE engine is very different from the new ones, in particular
> on lsl vehicle model simulation, reason why we still keep it.
>
>      But changes on the rest of the region code, in particular LSL/OSSL
> functions, made the old content dependent on it, to have other issues.
>
>      Its support increases the difficulty of improving the rest of the
> simulation (in this case also the unmanaged c/c++ support library i.e.
> modified Open Dynamics Engine.
>
>      Please let us know if you still need it, or we can drop it...
>
> Regards,
>
> Ubit.
>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
Reply | Threaded
Open this post in threaded view
|

Re: Old ODE still to keep?

AJLDuarte
Sure we could add extra unmanaged dlls

On 04-Dec-19 10:15, Peter Gloor wrote:

> I don't know about others, but personally I don't need legacy ODE any
> longer as I'm already running my regions either on BulletSim or ubODE.
> Looking back I think it was worth the effort in changing the LSL scripts
> where needed. However, not everybody will be able to do this.
>
> My primary home grid, Metropolis, changed from ODE to BulletSim as
> default when they moved to Opensim 0.9 about 9 months ago. I placed a call
> for feedback on their forum today.
>
> Regarding the underlying unmanaged c/c++ support library, wouldn't it be
> possible to keep it and to use a new and better one for ubODE in parallel?
>
> Regards,
> Pius Noel
>
> Am So., 1. Dez. 2019 um 16:52 Uhr schrieb Leal Duarte <[hidden email]>:
>
>> Hi,
>>
>>       Old ODE physics module was rendered obsolete with the introduction
>> of BulletSim physics module, back in 2012, and even more with the
>> introduction of ubODE on 0.9x series.
>>
>>       Old ODE engine is very different from the new ones, in particular
>> on lsl vehicle model simulation, reason why we still keep it.
>>
>>       But changes on the rest of the region code, in particular LSL/OSSL
>> functions, made the old content dependent on it, to have other issues.
>>
>>       Its support increases the difficulty of improving the rest of the
>> simulation (in this case also the unmanaged c/c++ support library i.e.
>> modified Open Dynamics Engine.
>>
>>       Please let us know if you still need it, or we can drop it...
>>
>> Regards,
>>
>> Ubit.
>>
>> _______________________________________________
>> Opensim-users mailing list
>> [hidden email]
>> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>>
> _______________________________________________
> Opensim-users mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users
>
_______________________________________________
Opensim-users mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-users